summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-11-18 07:53:04 +0000
committerMark Wright <gienah@gentoo.org>2012-11-18 07:53:04 +0000
commit0f5f9a9bc96820dbde1b7cc3cdef967f596d0ef8 (patch)
tree9a1e2def91c2c822f9e182ccfab1279c9adda65a
parentLoosen agda dep in agda-executable-2.3.0.1-r1 to fix build with agda 2.3.2 (diff)
downloadgentoo-2-0f5f9a9bc96820dbde1b7cc3cdef967f596d0ef8.tar.gz
gentoo-2-0f5f9a9bc96820dbde1b7cc3cdef967f596d0ef8.tar.bz2
gentoo-2-0f5f9a9bc96820dbde1b7cc3cdef967f596d0ef8.zip
Bump agda stdlib to a development snapshot, which I just name 0.7_pre20121118 because I have to call it something, for agda 2.3.2.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
-rw-r--r--sci-mathematics/agda-stdlib/ChangeLog10
-rw-r--r--sci-mathematics/agda-stdlib/agda-stdlib-0.7_pre20121118.ebuild58
2 files changed, 66 insertions, 2 deletions
diff --git a/sci-mathematics/agda-stdlib/ChangeLog b/sci-mathematics/agda-stdlib/ChangeLog
index 1eaf98e412f9..7729832f194f 100644
--- a/sci-mathematics/agda-stdlib/ChangeLog
+++ b/sci-mathematics/agda-stdlib/ChangeLog
@@ -1,10 +1,16 @@
# ChangeLog for sci-mathematics/agda-stdlib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda-stdlib/ChangeLog,v 1.1 2012/03/25 14:02:15 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda-stdlib/ChangeLog,v 1.2 2012/11/18 07:53:04 gienah Exp $
+
+*agda-stdlib-0.7_pre20121118 (18 Nov 2012)
+
+ 18 Nov 2012; Mark Wright <gienah@gentoo.org>
+ +agda-stdlib-0.7_pre20121118.ebuild:
+ Bump agda stdlib to a development snapshot, which I just name 0.7_pre20121118
+ because I have to call it something, for agda 2.3.2.
*agda-stdlib-0.6 (25 Mar 2012)
25 Mar 2012; Mark Wright <gienah@gentoo.org> +agda-stdlib-0.6.ebuild,
+files/50agda-stdlib-gentoo.el, +metadata.xml:
Thanks to tomprince for adding support for agda-stdlib.
-
diff --git a/sci-mathematics/agda-stdlib/agda-stdlib-0.7_pre20121118.ebuild b/sci-mathematics/agda-stdlib/agda-stdlib-0.7_pre20121118.ebuild
new file mode 100644
index 000000000000..53d36d3f16fc
--- /dev/null
+++ b/sci-mathematics/agda-stdlib/agda-stdlib-0.7_pre20121118.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda-stdlib/agda-stdlib-0.7_pre20121118.ebuild,v 1.1 2012/11/18 07:53:04 gienah Exp $
+
+EAPI=5
+
+CABAL_FEATURES="bin"
+inherit haskell-cabal elisp-common
+
+DESCRIPTION="Agda standard library"
+HOMEPAGE="http://wiki.portal.chalmers.se/agda/"
+SRC_URI="http://dev.gentoo.org/~gienah/snapshots/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="profile"
+
+DEPEND=">=sci-mathematics/agda-executable-2.3.0.1"
+RDEPEND="=sci-mathematics/agda-2.3.2*[profile?]
+ =dev-haskell/filemanip-0.3*[profile?]"
+
+SITEFILE="50${PN}-gentoo.el"
+
+S="${WORKDIR}/lib-${PV}"
+
+src_prepare() {
+ cabal-mksetup
+}
+
+src_compile() {
+ haskell-cabal_src_compile
+ "${S}"/dist/build/GenerateEverything/GenerateEverything \
+ || die "GenerateEverything failed"
+ local prof
+ use profile && prof="--ghc-flag=-prof"
+ agda +RTS -K1G -RTS ${prof} \
+ -i "${S}" -i "${S}"/src "${S}"/Everything.agda || die
+ # Although my agda-9999 build has
+ # /var/tmp/portage/sci-mathematics/agda-9999/work/agda-9999/dist/build/autogen/Paths_Agda.hs
+ # containing:
+ # datadir = "/usr/share/agda-9999/ghc-7.6.1"
+ # it fails without the --css option like:
+ # /usr/share/agda-9999/ghc-7.4.1/Agda.css: copyFile: does not exist
+ local cssdir=$(egrep 'datadir *=' "${S}/dist/build/autogen/Paths_lib.hs" | sed -e 's@datadir = \(.*\)@\1@')
+ agda --html -i "${S}" -i "${S}"/src --css="${cssdir}/Agda.css" "${S}"/README.agda || die
+}
+
+src_test() {
+ agda -i "${S}" -i "${S}"/src README.agda || die
+}
+
+src_install() {
+ insinto usr/share/agda-stdlib
+ doins -r src/*
+ dodoc -r html/*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+}