summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-04-21 11:24:21 +0000
committerBen de Groot <yngwin@gentoo.org>2008-04-21 11:24:21 +0000
commit13d2806b64bd45ff9983133150c2917e24abd968 (patch)
tree2fee4caff52708b495661ef69e7fe2515c0f7ded
parentVersion bump. Correct name of pkg_postinst function. (diff)
downloadgentoo-2-13d2806b64bd45ff9983133150c2917e24abd968.tar.gz
gentoo-2-13d2806b64bd45ff9983133150c2917e24abd968.tar.bz2
gentoo-2-13d2806b64bd45ff9983133150c2917e24abd968.zip
qmpdclient version bump, fixes bug 218594
(Portage version: 2.1.5_rc5)
-rw-r--r--media-sound/qmpdclient/ChangeLog8
-rw-r--r--media-sound/qmpdclient/metadata.xml2
-rw-r--r--media-sound/qmpdclient/qmpdclient-1.0.9.ebuild43
3 files changed, 51 insertions, 2 deletions
diff --git a/media-sound/qmpdclient/ChangeLog b/media-sound/qmpdclient/ChangeLog
index 101db6f6be9c..42e92311e6c6 100644
--- a/media-sound/qmpdclient/ChangeLog
+++ b/media-sound/qmpdclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/qmpdclient
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qmpdclient/ChangeLog,v 1.27 2008/04/20 18:23:32 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qmpdclient/ChangeLog,v 1.28 2008/04/21 11:24:21 yngwin Exp $
+
+*qmpdclient-1.0.9 (21 Apr 2008)
+
+ 21 Apr 2008; Ben de Groot <yngwin@gentoo.org> metadata.xml,
+ +qmpdclient-1.0.9.ebuild:
+ Version bump, fixes bug 218594.
20 Apr 2008; Raúl Porcel <armin76@gentoo.org> qmpdclient-1.0.8-r1.ebuild:
Add ~sparc
diff --git a/media-sound/qmpdclient/metadata.xml b/media-sound/qmpdclient/metadata.xml
index 688469afc49a..c876ac5b7df2 100644
--- a/media-sound/qmpdclient/metadata.xml
+++ b/media-sound/qmpdclient/metadata.xml
@@ -5,5 +5,5 @@
<maintainer>
<email>ticho@gentoo.org</email>
</maintainer>
-<longdescription>QMPDClient is an easy to use MPD client written in Qt 4.1.</longdescription>
+<longdescription>QMPDClient is an easy to use MPD client written in Qt 4</longdescription>
</pkgmetadata>
diff --git a/media-sound/qmpdclient/qmpdclient-1.0.9.ebuild b/media-sound/qmpdclient/qmpdclient-1.0.9.ebuild
new file mode 100644
index 000000000000..7378a60a2fe3
--- /dev/null
+++ b/media-sound/qmpdclient/qmpdclient-1.0.9.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qmpdclient/qmpdclient-1.0.9.ebuild,v 1.1 2008/04/21 11:24:21 yngwin Exp $
+
+EAPI=1
+
+inherit eutils multilib qt4 toolchain-funcs
+
+DESCRIPTION="An easy to use MPD client written in Qt4"
+HOMEPAGE="http://havtknut.tihlde.org/qmpdclient"
+SRC_URI="http://havtknut.tihlde.org/${PN}/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="|| ( >=x11-libs/qt-4.2:4 x11-libs/qt-gui:4 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix the install path
+ sed -i -e "s:PREFIX = /usr/local:PREFIX = /usr:" qmpdclient.pro \
+ || die "sed failed"
+}
+
+src_compile() {
+ eqmake4 || die "qmake failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ dodoc README AUTHORS THANKSTO Changelog
+ for res in 16 22 32 64 128 ; do
+ insinto /usr/share/icons/hicolor/${res}x${res}/apps/
+ newins icons/qmpdclient${res}.png ${PN}.png
+ done
+
+ dobin qmpdclient || die "dobin failed"
+ make_desktop_entry qmpdclient "QMPDClient" ${PN} "Qt;AudioVideo;Audio"
+}