summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2012-09-02 09:13:25 +0000
committerBen de Groot <yngwin@gentoo.org>2012-09-02 09:13:25 +0000
commit1b8c1fe6c97ca8cefbb11a5d281fff9226cd4fe9 (patch)
treee67e5428b2e530208d17648a06a83e92a30903b6
parentFix dependency for renamed package. (diff)
downloadgentoo-2-1b8c1fe6c97ca8cefbb11a5d281fff9226cd4fe9.tar.gz
gentoo-2-1b8c1fe6c97ca8cefbb11a5d281fff9226cd4fe9.tar.bz2
gentoo-2-1b8c1fe6c97ca8cefbb11a5d281fff9226cd4fe9.zip
Version bump. Build system changed to cmake.
(Portage version: 2.2.0_alpha123/cvs/Linux x86_64)
-rw-r--r--x11-misc/qlipper/ChangeLog7
-rw-r--r--x11-misc/qlipper/qlipper-2.0.1.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/x11-misc/qlipper/ChangeLog b/x11-misc/qlipper/ChangeLog
index be5eaab3fe45..e5323658817d 100644
--- a/x11-misc/qlipper/ChangeLog
+++ b/x11-misc/qlipper/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/qlipper
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/qlipper/ChangeLog,v 1.2 2012/07/31 12:05:13 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/qlipper/ChangeLog,v 1.3 2012/09/02 09:13:25 yngwin Exp $
+
+*qlipper-2.0.1 (02 Sep 2012)
+
+ 02 Sep 2012; Ben de Groot <yngwin@gentoo.org> +qlipper-2.0.1.ebuild:
+ Version bump. Build system changed to cmake.
*qlipper-2.0.0-r1 (31 Jul 2012)
diff --git a/x11-misc/qlipper/qlipper-2.0.1.ebuild b/x11-misc/qlipper/qlipper-2.0.1.ebuild
new file mode 100644
index 000000000000..42629061d3c8
--- /dev/null
+++ b/x11-misc/qlipper/qlipper-2.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/qlipper/qlipper-2.0.1.ebuild,v 1.1 2012/09/02 09:13:25 yngwin Exp $
+
+EAPI=4
+PLOCALES="cs sr"
+inherit l10n cmake-utils
+
+DESCRIPTION="Lightweight and cross-platform clipboard history applet"
+HOMEPAGE="http://code.google.com/p/qlipper/"
+SRC_URI="http://qlipper.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/qt-gui:4"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ l10n_for_each_disabled_locale_do rm_loc
+}
+
+src_configure() {
+ cmake-utils_src_configure INSTALL_PREFIX="${EPREFIX}"/usr
+}
+
+rm_loc() {
+ rm ts/${PN}.${1}.*
+}