summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-12-05 12:03:00 +0000
committerPacho Ramos <pacho@gentoo.org>2014-12-05 12:03:00 +0000
commit1df19360f25e0b7afa067ec2ecd229e4f6e9ae0b (patch)
tree1466d24b20db62ccef5e7f938bdf7a2ef1bac43a
parentFix gentoo theme installation, fix building with -Werror=format-security (#53... (diff)
downloadgentoo-2-1df19360f25e0b7afa067ec2ecd229e4f6e9ae0b.tar.gz
gentoo-2-1df19360f25e0b7afa067ec2ecd229e4f6e9ae0b.tar.bz2
gentoo-2-1df19360f25e0b7afa067ec2ecd229e4f6e9ae0b.zip
Ensure obexd is launched when needed and add missing rdepend on bluez[obex] (#531376 by Chris Mayo)
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
-rw-r--r--gnome-extra/gnome-user-share/ChangeLog10
-rw-r--r--gnome-extra/gnome-user-share/files/gnome-user-share-3.10.2-launch-obexd.patch29
-rw-r--r--gnome-extra/gnome-user-share/gnome-user-share-3.10.2-r1.ebuild54
3 files changed, 92 insertions, 1 deletions
diff --git a/gnome-extra/gnome-user-share/ChangeLog b/gnome-extra/gnome-user-share/ChangeLog
index 5d3c4881e975..aa34f9af0c28 100644
--- a/gnome-extra/gnome-user-share/ChangeLog
+++ b/gnome-extra/gnome-user-share/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnome-extra/gnome-user-share
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-user-share/ChangeLog,v 1.38 2014/11/13 11:56:56 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-user-share/ChangeLog,v 1.39 2014/12/05 12:03:00 pacho Exp $
+
+*gnome-user-share-3.10.2-r1 (05 Dec 2014)
+
+ 05 Dec 2014; Pacho Ramos <pacho@gentoo.org>
+ +files/gnome-user-share-3.10.2-launch-obexd.patch,
+ +gnome-user-share-3.10.2-r1.ebuild:
+ Ensure obexd is launched when needed and add missing rdepend on bluez[obex]
+ (#531376 by Chris Mayo)
13 Nov 2014; Pacho Ramos <pacho@gentoo.org>
-files/gnome-user-share-2.30.1-libnotify-0.7.patch,
diff --git a/gnome-extra/gnome-user-share/files/gnome-user-share-3.10.2-launch-obexd.patch b/gnome-extra/gnome-user-share/files/gnome-user-share-3.10.2-launch-obexd.patch
new file mode 100644
index 000000000000..a6bb00156fe2
--- /dev/null
+++ b/gnome-extra/gnome-user-share/files/gnome-user-share-3.10.2-launch-obexd.patch
@@ -0,0 +1,29 @@
+From 5bca8742e96bc5f3447be18e9c6ac5692cc3e3cd Mon Sep 17 00:00:00 2001
+From: Mario Sanchez Prada <mario@endlessm.com>
+Date: Thu, 30 Oct 2014 11:06:44 -0700
+Subject: obex: Make sure obexd daemon is launched if needed when starting to
+ watch it
+
+This fixes a situation where files can't be sent to the computer (e.g.
+from a phone) until you enable and then disable the bluetooth sharing
+options at least once, as the shutting down will cause the obexd daemon
+to run due to the UnregisterAgent D-Bus call in obex_agent_down().
+
+https://bugzilla.gnome.org/show_bug.cgi?id=739417
+
+diff --git a/src/obexpush.c b/src/obexpush.c
+index 6424bd2..6d305d7 100644
+--- a/src/obexpush.c
++++ b/src/obexpush.c
+@@ -740,7 +740,7 @@ on_bus_acquired (GDBusConnection *connection,
+
+ self->obexd_watch_id = g_bus_watch_name_on_connection (self->connection,
+ MANAGER_SERVICE,
+- G_BUS_NAME_WATCHER_FLAGS_NONE,
++ G_BUS_NAME_WATCHER_FLAGS_AUTO_START,
+ obexd_appeared_cb,
+ NULL,
+ self,
+--
+cgit v0.10.1
+
diff --git a/gnome-extra/gnome-user-share/gnome-user-share-3.10.2-r1.ebuild b/gnome-extra/gnome-user-share/gnome-user-share-3.10.2-r1.ebuild
new file mode 100644
index 000000000000..65eb0cd0073a
--- /dev/null
+++ b/gnome-extra/gnome-user-share/gnome-user-share-3.10.2-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-user-share/gnome-user-share-3.10.2-r1.ebuild,v 1.1 2014/12/05 12:03:00 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 multilib
+
+DESCRIPTION="Personal file sharing for the GNOME desktop"
+HOMEPAGE="https://git.gnome.org/browse/gnome-user-share"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth"
+
+# FIXME: could libnotify be made optional ?
+# FIXME: selinux automagic support
+RDEPEND="
+ >=dev-libs/glib-2.28:2
+ >=x11-libs/gtk+-3:3
+ >=gnome-base/nautilus-2.91.7
+ media-libs/libcanberra[gtk3]
+ >=www-apache/mod_dnssd-0.6
+ >=www-servers/apache-2.2[apache2_modules_dav,apache2_modules_dav_fs,apache2_modules_authn_file,apache2_modules_auth_digest,apache2_modules_authz_groupfile]
+ >=x11-libs/libnotify-0.7:=
+ bluetooth? (
+ >=net-wireless/gnome-bluetooth-3.9.3:2=
+ >=net-wireless/bluez-5[obex] )
+"
+DEPEND="${RDEPEND}
+ !<gnome-base/gnome-control-center-3.9
+ app-text/yelp-tools
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Make sure obexd daemon is launched if needed when starting to watch it (from 'master')
+ epatch "${FILESDIR}/${PN}-3.10.2-launch-obexd.patch"
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable bluetooth) \
+ ITSTOOL=$(type -P true) \
+ --with-httpd=apache2 \
+ --with-modules-path=/usr/$(get_libdir)/apache2/modules/
+}