summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-09-23 23:59:35 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-09-23 23:59:35 +0000
commit204ed0407ac651b4b04e35e5baa29eb31c1440f6 (patch)
treed034b848d38e0746386214220759b4634ebc1471
parentVersion bump. Cleanup old. (diff)
downloadgentoo-2-204ed0407ac651b4b04e35e5baa29eb31c1440f6.tar.gz
gentoo-2-204ed0407ac651b4b04e35e5baa29eb31c1440f6.tar.bz2
gentoo-2-204ed0407ac651b4b04e35e5baa29eb31c1440f6.zip
Version bump
(Portage version: 2.2.13/cvs/Linux x86_64, signed Manifest commit with key )
-rw-r--r--net-libs/gloox/ChangeLog7
-rw-r--r--net-libs/gloox/gloox-1.0.11.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/net-libs/gloox/ChangeLog b/net-libs/gloox/ChangeLog
index 7d55244f1365..45f0993a1b5f 100644
--- a/net-libs/gloox/ChangeLog
+++ b/net-libs/gloox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/gloox
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/ChangeLog,v 1.27 2014/08/29 02:12:38 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/ChangeLog,v 1.28 2014/09/23 23:59:35 mrueg Exp $
+
+*gloox-1.0.11 (23 Sep 2014)
+
+ 23 Sep 2014; Manuel Rüger <mrueg@gentoo.org> +gloox-1.0.11.ebuild:
+ Version bump
29 Aug 2014; Anthony G. Basile <blueness@gentoo.org> gloox-1.0.10-r1.ebuild,
gloox-1.0.9.ebuild, gloox-1.0.ebuild:
diff --git a/net-libs/gloox/gloox-1.0.11.ebuild b/net-libs/gloox/gloox-1.0.11.ebuild
new file mode 100644
index 000000000000..bbd4aab53628
--- /dev/null
+++ b/net-libs/gloox/gloox-1.0.11.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/gloox-1.0.11.ebuild,v 1.1 2014/09/23 23:59:35 mrueg Exp $
+
+EAPI=5
+
+inherit eutils
+
+MY_P="${P/_/-}"
+DESCRIPTION="A portable high-level Jabber/XMPP library for C++"
+HOMEPAGE="http://camaya.net/gloox"
+SRC_URI="http://camaya.net/download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0/12"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~ia64 ~sparc ~x86"
+IUSE="debug gnutls idn ssl static-libs test zlib"
+
+DEPEND="idn? ( net-dns/libidn )
+ gnutls? ( net-libs/gnutls )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ # Examples are not installed anyway, so - why should we build them?
+ econf \
+ --without-examples \
+ $(use debug && echo "--enable-debug") \
+ $(use_enable static-libs static) \
+ $(use_with idn libidn) \
+ $(use_with gnutls) \
+ $(use_with ssl openssl) \
+ $(use_with test tests) \
+ $(use_with zlib)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}