summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-04-28 17:08:46 +0000
committerHans de Graaff <graaff@gentoo.org>2011-04-28 17:08:46 +0000
commit23e717cd2d4fd8a2aa631f8d2132892d46d9e62a (patch)
tree7d9b876f7aae01156e71449cf5d66676156fb73a
parentppc64 stable wrt #353436 (diff)
downloadgentoo-2-23e717cd2d4fd8a2aa631f8d2132892d46d9e62a.tar.gz
gentoo-2-23e717cd2d4fd8a2aa631f8d2132892d46d9e62a.tar.bz2
gentoo-2-23e717cd2d4fd8a2aa631f8d2132892d46d9e62a.zip
Version bump. Run specs for jruby.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
-rw-r--r--dev-ruby/rake-compiler/ChangeLog8
-rw-r--r--dev-ruby/rake-compiler/rake-compiler-0.7.8.ebuild61
2 files changed, 68 insertions, 1 deletions
diff --git a/dev-ruby/rake-compiler/ChangeLog b/dev-ruby/rake-compiler/ChangeLog
index 63e58ea8d3e8..c288243c5f84 100644
--- a/dev-ruby/rake-compiler/ChangeLog
+++ b/dev-ruby/rake-compiler/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rake-compiler
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/ChangeLog,v 1.37 2011/04/16 17:40:42 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/ChangeLog,v 1.38 2011/04/28 17:08:46 graaff Exp $
+
+*rake-compiler-0.7.8 (28 Apr 2011)
+
+ 28 Apr 2011; Hans de Graaff <graaff@gentoo.org>
+ +rake-compiler-0.7.8.ebuild:
+ Version bump. Run specs for jruby.
16 Apr 2011; Raúl Porcel <armin76@gentoo.org> rake-compiler-0.7.5.ebuild:
ia64 stable wrt #357489
diff --git a/dev-ruby/rake-compiler/rake-compiler-0.7.8.ebuild b/dev-ruby/rake-compiler/rake-compiler-0.7.8.ebuild
new file mode 100644
index 000000000000..9891465bb013
--- /dev/null
+++ b/dev-ruby/rake-compiler/rake-compiler-0.7.8.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/rake-compiler-0.7.8.ebuild,v 1.1 2011/04/28 17:08:46 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+# Tests for now seem only to work when rubygems is fully installed for
+# the implementation and that for now only means Ruby 1.8
+RUBY_FAKEGEM_TASK_TEST="-f tasks/rspec.rake -f tasks/cucumber.rake spec cucumber"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Provide a standard and simplified way to build and package Ruby extensions"
+HOMEPAGE="http://github.com/luislavena/rake-compiler"
+LICENSE="as-is" # truly
+
+SRC_URI="http://github.com/luislavena/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+S="${WORKDIR}/luislavena-${PN}-*"
+
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+USE_RUBY=ruby18 \
+ ruby_add_bdepend "test? ( dev-util/cucumber )"
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:0 dev-ruby/rubygems )"
+ruby_add_rdepend "dev-ruby/rake"
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby19|*jruby)
+ # Remove this task so that it won't load on Ruby 1.9 and JRuby
+ # that lack the package_task file. It is, though, needed for the
+ # tests
+ rm tasks/gem.rake || die
+ # Remove specs aimed at a C-compiling ruby implementation.
+ rm spec/lib/rake/extensiontask_spec.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *ruby19)
+ ewarn "Tests disabled for this implementation. Long story, check ebuild if you want."
+ ;;
+ *jruby)
+ ${RUBY} -S spec spec || die "Tests failed."
+ ;;
+ *)
+ each_fakegem_test
+ ;;
+ esac
+}