summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2002-08-21 15:09:38 +0000
committerTilman Klar <phoenix@gentoo.org>2002-08-21 15:09:38 +0000
commit317bdff71d701bd56bac122fad65e27512a63ef2 (patch)
tree439a69e814c076b1a0d7bba948027688bb741450
parentMasked modutils-2.4.19 (diff)
downloadgentoo-2-317bdff71d701bd56bac122fad65e27512a63ef2.tar.gz
gentoo-2-317bdff71d701bd56bac122fad65e27512a63ef2.tar.bz2
gentoo-2-317bdff71d701bd56bac122fad65e27512a63ef2.zip
Bumped to new version in order to fix bug 6730.
-rw-r--r--sys-apps/modutils/ChangeLog11
-rw-r--r--sys-apps/modutils/files/digest-modutils-2.4.191
-rw-r--r--sys-apps/modutils/modutils-2.4.19.ebuild38
3 files changed, 48 insertions, 2 deletions
diff --git a/sys-apps/modutils/ChangeLog b/sys-apps/modutils/ChangeLog
index 22fb05f16eb5..471f7ede8b4a 100644
--- a/sys-apps/modutils/ChangeLog
+++ b/sys-apps/modutils/ChangeLog
@@ -1,8 +1,15 @@
# ChangeLog for sys-apps/modutils
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/modutils/ChangeLog,v 1.6 2002/07/14 19:20:18 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/modutils/ChangeLog,v 1.7 2002/08/21 15:09:38 phoenix Exp $
-*modutils-2.4.16-r3.ebuild (14 July 2002)
+*modutils-2.4.19 (21 Aug 2002)
+
+ 21 Aug 2002; phoen][x <phoenix@gentoo.org> modutils-2.4.19.ebuild,
+ files/digest-modutils-2.4.19 :
+
+ Bumped to new version - this should take care of bug #6730.
+
+*modutils-2.4.16-r3 (14 July 2002)
14 Jul 2002; phoen][x <phoenix@gentoo.org> modutils-2.4.16-r3.ebuild :
Added LICENSE, KEYWORDS.
diff --git a/sys-apps/modutils/files/digest-modutils-2.4.19 b/sys-apps/modutils/files/digest-modutils-2.4.19
new file mode 100644
index 000000000000..463264594a89
--- /dev/null
+++ b/sys-apps/modutils/files/digest-modutils-2.4.19
@@ -0,0 +1 @@
+MD5 a7987ee972c2cf7f0141a73631b4dddf modutils-2.4.19.tar.bz2 218002
diff --git a/sys-apps/modutils/modutils-2.4.19.ebuild b/sys-apps/modutils/modutils-2.4.19.ebuild
new file mode 100644
index 000000000000..32df48ce0673
--- /dev/null
+++ b/sys-apps/modutils/modutils-2.4.19.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/modutils/modutils-2.4.19.ebuild,v 1.1 2002/08/21 15:09:38 phoenix Exp $
+
+SLOT="0"
+DESCRIPTION="Standard kernel module utilities"
+SRC_URI="http://www.kernel.org/pub/linux/utils/kernel/modutils/v2.4/${P}.tar.bz2"
+HOMEPAGE=""
+KEYWORDS="x86 ppc sparc sparc64"
+LICENSE="GPL-2"
+DEPEND="virtual/glibc"
+
+src_compile() {
+ myconf=""
+ # see bug #3897 ... we need insmod static, as libz.so is in /usr/lib
+ #
+ # Final resolution ... dont make it link against zlib, as the static
+ # version do not want to autoload modules :(
+ myconf="${myconf} --disable-zlib"
+
+ ./configure --prefix=/ \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --disable-strip \
+ --enable-insmod-static \
+ ${myconf} || die "./configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make prefix=${D} \
+ mandir=${D}/usr/share/man \
+ install || die "make install failed"
+
+ dodoc COPYING CREDITS ChangeLog NEWS README TODO
+}
+