summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-11-28 18:53:04 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-11-28 18:53:04 +0000
commit35a4a220b4a2411ac4560fba934c2bfed3da8d5b (patch)
treedccc1910914e706850966b2f75edaac4d9534836
parentmark stable (diff)
downloadgentoo-2-35a4a220b4a2411ac4560fba934c2bfed3da8d5b.tar.gz
gentoo-2-35a4a220b4a2411ac4560fba934c2bfed3da8d5b.tar.bz2
gentoo-2-35a4a220b4a2411ac4560fba934c2bfed3da8d5b.zip
icc USE flag
-rw-r--r--x11-wm/fvwm/ChangeLog5
-rw-r--r--x11-wm/fvwm/Manifest4
-rw-r--r--x11-wm/fvwm/fvwm-2.5.8-r2.ebuild22
3 files changed, 24 insertions, 7 deletions
diff --git a/x11-wm/fvwm/ChangeLog b/x11-wm/fvwm/ChangeLog
index 70c4f5dfb7db..548d8e5597bc 100644
--- a/x11-wm/fvwm/ChangeLog
+++ b/x11-wm/fvwm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-wm/fvwm
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/ChangeLog,v 1.47 2003/11/27 16:28:17 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/ChangeLog,v 1.48 2003/11/28 18:52:59 taviso Exp $
+
+ 28 Nov 2003; Tavis Ormandy <taviso@gentoo.org> fvwm-2.5.8-r2.ebuild:
+ optionally compile fvwm with icc.
*fvwm-2.5.8-r2 (27 Nov 2003)
diff --git a/x11-wm/fvwm/Manifest b/x11-wm/fvwm/Manifest
index 0b13a0657a35..06e0f835ade1 100644
--- a/x11-wm/fvwm/Manifest
+++ b/x11-wm/fvwm/Manifest
@@ -1,8 +1,8 @@
MD5 e79bd2fa2e46e650aabaa16754e25583 fvwm-2.5.7-r5.ebuild 8757
MD5 b893f78193652b275ce5d276ac38af29 fvwm-2.4.17.ebuild 3961
-MD5 8f195cb9d937ee113ebb6e4a453171ca ChangeLog 9506
+MD5 90da0216de371ab937c87b5aea3d982a ChangeLog 9614
MD5 4833e4d0685ef48988c0c5c4f9c6b377 metadata.xml 527
-MD5 04f205d4ad9e39c0e0488c71f70674e3 fvwm-2.5.8-r2.ebuild 9587
+MD5 8321c9e2742d4b9fc66892f028cb78b6 fvwm-2.5.8-r2.ebuild 9939
MD5 e2ceb5d855c5406a09d82442196efad8 files/README.transluceny.gz 5788
MD5 e5701841190ad529d5577c8da69d5006 files/fvwmtabs-insecure-tmp-handling.diff 2350
MD5 b2af3c1c8fe4f142e2b8debbb5c59a94 files/digest-fvwm-2.4.17 65
diff --git a/x11-wm/fvwm/fvwm-2.5.8-r2.ebuild b/x11-wm/fvwm/fvwm-2.5.8-r2.ebuild
index 10bb6986a622..47d13eb95a5b 100644
--- a/x11-wm/fvwm/fvwm-2.5.8-r2.ebuild
+++ b/x11-wm/fvwm/fvwm-2.5.8-r2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.5.8-r2.ebuild,v 1.2 2003/11/28 09:26:59 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.5.8-r2.ebuild,v 1.3 2003/11/28 18:52:59 taviso Exp $
inherit eutils flag-o-matic
-IUSE="readline truetype ncurses gtk stroke gnome rplay xinerama perl nls png bidi imlib tcltk debug gtk2"
+IUSE="readline truetype ncurses gtk stroke gnome rplay xinerama perl nls png bidi imlib tcltk debug gtk2 icc"
DESCRIPTION="An extremely powerful ICCCM-compliant multiple virtual desktop window manager"
SRC_URI="ftp://ftp.fvwm.org/pub/fvwm/version-2/${P}.tar.bz2
@@ -41,9 +41,8 @@ RDEPEND="readline? ( >=sys-libs/readline-4.1
# XXX: netpbm is used by FvwmScript-ScreenDump...im assuming anyone with
# `use noxpm` will not want them.
DEPEND="${RDEPEND}
+ icc? ( dev-lang/icc )
>=sys-apps/sed-4
- sys-devel/automake
- sys-devel/autoconf
dev-util/pkgconfig"
S=${WORKDIR}/${P}
@@ -197,6 +196,21 @@ src_compile() {
myconf="${myconf} --without-xpm-library"
fi
+ # use intel's C compiler to compile fvwm?
+ if use icc; then
+ export CC="icc"
+
+ # test if any icc specific flags have been requested
+ if test "${ICCFLAGS}"; then
+ einfo "Setting CFLAGS for the Intel Compiler..."
+
+ # ipo refuses to link libfvwm.a
+ export CFLAGS="${ICCFLAGS/-ipo/-ip}"
+ else
+ einfo "ICCFLAGS Not set, continuing with CFLAGS..."
+ fi
+ fi
+
# set the local maintainer for fvwm-bug.
export FVWM_BUGADDR="taviso@gentoo.org"