summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-07 02:41:58 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-07 02:41:58 +0000
commit36ce127bce01287fada55c6c3baef192c3921a3c (patch)
tree12779b9744f3ea1b924732a662a0033449261679
parentVersion Bump (diff)
downloadgentoo-2-36ce127bce01287fada55c6c3baef192c3921a3c.tar.gz
gentoo-2-36ce127bce01287fada55c6c3baef192c3921a3c.tar.bz2
gentoo-2-36ce127bce01287fada55c6c3baef192c3921a3c.zip
fix license/repoman
-rw-r--r--dev-python/pyOpenSSL/pyOpenSSL-0.5.1.ebuild62
-rw-r--r--dev-python/pyframer/pyframer-0.2.ebuild7
-rw-r--r--dev-python/pygtk/pygtk-0.6.11.ebuild5
-rw-r--r--dev-python/pygtk/pygtk-0.6.9.ebuild29
-rw-r--r--dev-python/pygtk/pygtk-1.99.13-r1.ebuild21
-rw-r--r--dev-python/pygtk/pygtk-1.99.16.ebuild15
-rw-r--r--dev-python/pygtk/pygtk-1.99.17.ebuild15
7 files changed, 65 insertions, 89 deletions
diff --git a/dev-python/pyOpenSSL/pyOpenSSL-0.5.1.ebuild b/dev-python/pyOpenSSL/pyOpenSSL-0.5.1.ebuild
index 008ee3ad3a52..389e1f610562 100644
--- a/dev-python/pyOpenSSL/pyOpenSSL-0.5.1.ebuild
+++ b/dev-python/pyOpenSSL/pyOpenSSL-0.5.1.ebuild
@@ -1,50 +1,48 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyOpenSSL/pyOpenSSL-0.5.1.ebuild,v 1.8 2003/07/12 12:49:26 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyOpenSSL/pyOpenSSL-0.5.1.ebuild,v 1.9 2003/08/07 02:38:23 vapier Exp $
-IUSE="tetex"
+inherit distutils
-S=${WORKDIR}/${P}
DESCRIPTION="Python interface to the OpenSSL library"
-SRC_URI="mirror://sourceforge/pyopenssl/${P}.tar.gz"
HOMEPAGE="http://pyopenssl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pyopenssl/${P}.tar.gz"
+
LICENSE="LGPL-2.1"
SLOT="0"
-RDEPEND="virtual/python
- >=dev-libs/openssl-0.9.6g"
-DEPEND="$RDEPEND
- tetex? ( >=dev-tex/latex2html-2002.2 )"
KEYWORDS="x86"
+IUSE="tetex"
-inherit distutils
+RDEPEND="virtual/python
+ >=dev-libs/openssl-0.9.6g"
+DEPEND="${RDEPEND}
+ tetex? ( >=dev-tex/latex2html-2002.2 )"
src_compile() {
- distutils_src_compile
-
- if [ "`use tetex`" ] ; then
- cd ${S}/doc
- make html ps dvi
- fi
+ distutils_src_compile
+ if [ "`use tetex`" ] ; then
+ cd ${S}/doc
+ make html ps dvi
+ fi
}
src_install() {
- distutils_src_install
-
- if [ "`use tetex`" ] ; then
- dohtml ${S}/doc/html/*
- dodoc ${S}/doc/pyOpenSSL.*
- fi
-
- # install examples
- dodir /usr/share/doc/${PF}/examples/simple
- insinto /usr/share/doc/${PF}/examples
- doins ${S}/examples/*
- insinto /usr/share/doc/${PF}/examples/simple
- doins ${S}/examples/simple/*
+ distutils_src_install
+
+ if [ "`use tetex`" ] ; then
+ dohtml ${S}/doc/html/*
+ dodoc ${S}/doc/pyOpenSSL.*
+ fi
+
+ # install examples
+ docinto examples
+ dodoc ${S}/examples/*
+ docinto examples/simple
+ dodoc ${S}/examples/simple/*
}
pkg_postinst() {
- echo
- einfo "For docs in html you need to have tetex in your USE var"
- echo
+ echo
+ einfo "For docs in html you need to have tetex in your USE var"
+ echo
}
diff --git a/dev-python/pyframer/pyframer-0.2.ebuild b/dev-python/pyframer/pyframer-0.2.ebuild
index 8efde132dca3..b74298bb1e14 100644
--- a/dev-python/pyframer/pyframer-0.2.ebuild
+++ b/dev-python/pyframer/pyframer-0.2.ebuild
@@ -1,17 +1,16 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyframer/pyframer-0.2.ebuild,v 1.7 2003/07/12 12:49:26 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyframer/pyframer-0.2.ebuild,v 1.8 2003/08/07 02:39:48 vapier Exp $
inherit distutils
DESCRIPTION="Python interface for framerd"
-SRC_URI="http://twistedmatrix.com/users/washort/pyframer/${P}.tar.gz"
HOMEPAGE="http://twistedmatrix.com/users/washort/pyframer/"
+SRC_URI="http://twistedmatrix.com/users/washort/pyframer/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="x86"
-IUSE=""
DEPEND="virtual/python
>=dev-db/framerd-2.4.3"
diff --git a/dev-python/pygtk/pygtk-0.6.11.ebuild b/dev-python/pygtk/pygtk-0.6.11.ebuild
index e1eaeee13c32..a657b30d7aea 100644
--- a/dev-python/pygtk/pygtk-0.6.11.ebuild
+++ b/dev-python/pygtk/pygtk-0.6.11.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-0.6.11.ebuild,v 1.9 2003/06/22 12:15:59 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-0.6.11.ebuild,v 1.10 2003/08/07 02:41:58 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="GTK+ bindings for Python"
-SRC_URI="ftp://ftp.gtk.org/pub/gtk/python/v1.2/${P}.tar.gz"
HOMEPAGE="http://www.daa.com.au/~james/pygtk/"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/python/v1.2/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="1.2"
diff --git a/dev-python/pygtk/pygtk-0.6.9.ebuild b/dev-python/pygtk/pygtk-0.6.9.ebuild
index 9299d33cc099..796d250f204e 100644
--- a/dev-python/pygtk/pygtk-0.6.9.ebuild
+++ b/dev-python/pygtk/pygtk-0.6.9.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-0.6.9.ebuild,v 1.12 2003/06/22 12:15:59 liquidx Exp $
-
-S=${WORKDIR}/${P}
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-0.6.9.ebuild,v 1.13 2003/08/07 02:41:58 vapier Exp $
DESCRIPTION="GTK+ bindings for Python"
-
+HOMEPAGE="http://www.daa.com.au/~james/pygtk/"
SRC_URI="ftp://ftp.gtk.org/pub/gtk/python/${P}.tar.gz"
-HOMEPAGE="http://www.daa.com.au/~james/pygtk/"
+LICENSE="LGPL-2.1"
+SLOT="1.2"
+KEYWORDS="x86 ppc sparc alpha"
DEPEND="virtual/python
>=gnome-base/libglade-0.17-r6
@@ -17,24 +17,15 @@ DEPEND="virtual/python
( >=x11-libs/gtk+-1.2.10
<x11-libs/gtk+-2.0.0 )"
-KEYWORDS="x86 ppc sparc alpha"
-LICENSE="LGPL-2.1"
-SLOT="1.2"
-
src_compile() {
-
./configure --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --prefix=/usr \
- --with-libglade-config=/usr/bin/libglade-config \
- --host=${CHOST} || die
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --with-libglade-config=/usr/bin/libglade-config \
+ --host=${CHOST} || die
emake || die
}
-src_install () {
-
+src_install() {
make prefix=${D}/usr install || die
-
-# make DESTDIR=${D} install || die
}
-
diff --git a/dev-python/pygtk/pygtk-1.99.13-r1.ebuild b/dev-python/pygtk/pygtk-1.99.13-r1.ebuild
index 454cd5e68b56..f412fcbd8688 100644
--- a/dev-python/pygtk/pygtk-1.99.13-r1.ebuild
+++ b/dev-python/pygtk/pygtk-1.99.13-r1.ebuild
@@ -1,37 +1,32 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-1.99.13-r1.ebuild,v 1.8 2003/06/22 12:15:59 liquidx Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-1.99.13-r1.ebuild,v 1.9 2003/08/07 02:41:58 vapier Exp $
# since its a development version
inherit debug
-S=${WORKDIR}/${P}
-DESCRIPTION="GTK+2 bindings for Python"
-SRC_URI="ftp://ftp.gtk.org/pub/gtk/python/v2.0/${P}.tar.gz"
+DESCRIPTION="GTK+2 bindings for Python"
HOMEPAGE="http://www.daa.com.au/~james/pygtk/"
-LICENSE="LGPL-2.1"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/python/v2.0/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="2.0"
KEYWORDS="x86 ~ppc sparc alpha"
-
DEPEND=">=dev-lang/python-2.2
>=x11-libs/pango-1.0.0
>=gnome-base/libglade-2.0.0
opengl? ( >=x11-libs/gtkglarea-1.99.0 )"
-SLOT="2.0"
-
src_compile() {
-
./configure --prefix=/usr/ \
--enable-thread \
- --host=${CHOST} || die
+ --host=${CHOST} || die
emake || die
}
-src_install () {
+src_install() {
make prefix=${D}/usr install || die
-
dodoc AUTHORS COPYING ChangeLog INSTALL MAPPING NEWS README THREADS TODO
}
diff --git a/dev-python/pygtk/pygtk-1.99.16.ebuild b/dev-python/pygtk/pygtk-1.99.16.ebuild
index 9c4c06d6d77c..0b99c08033f9 100644
--- a/dev-python/pygtk/pygtk-1.99.16.ebuild
+++ b/dev-python/pygtk/pygtk-1.99.16.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-1.99.16.ebuild,v 1.5 2003/08/01 16:13:39 foser Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-1.99.16.ebuild,v 1.6 2003/08/07 02:41:58 vapier Exp $
# since its a development version
inherit debug gnome.org
-IUSE="gnome opengl"
-
DESCRIPTION="GTK+2 bindings for Python"
#SRC_URI="ftp://ftp.gtk.org/pub/gtk/python/v2.0/${P}.tar.gz"
HOMEPAGE="http://www.daa.com.au/~james/pygtk/"
-LICENSE="LGPL-2.1"
+LICENSE="LGPL-2.1"
+SLOT="2.0"
KEYWORDS="x86 ~ppc ~sparc ~alpha"
+IUSE="gnome opengl"
DEPEND=">=dev-lang/python-2.2
>=x11-libs/pango-1
@@ -22,16 +22,13 @@ DEPEND=">=dev-lang/python-2.2
gnome? ( >=gnome-base/libglade-2 )
opengl? ( >=x11-libs/gtkglarea-1.99 )"
-SLOT="2.0"
-
src_compile() {
econf --enable-thread || die
emake || die
}
-src_install () {
+src_install() {
einstall || die
-
dodoc AUTHORS COPYING ChangeLog INSTALL MAPPING NEWS README THREADS TODO
}
diff --git a/dev-python/pygtk/pygtk-1.99.17.ebuild b/dev-python/pygtk/pygtk-1.99.17.ebuild
index 4a15402f62ce..fe01aa9b266c 100644
--- a/dev-python/pygtk/pygtk-1.99.17.ebuild
+++ b/dev-python/pygtk/pygtk-1.99.17.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-1.99.17.ebuild,v 1.1 2003/08/01 16:13:39 foser Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-1.99.17.ebuild,v 1.2 2003/08/07 02:41:58 vapier Exp $
# since its a development version
inherit debug gnome.org
-IUSE="gnome opengl"
-
DESCRIPTION="GTK+2 bindings for Python"
HOMEPAGE="http://www.daa.com.au/~james/pygtk/"
-LICENSE="LGPL-2.1"
+LICENSE="LGPL-2.1"
+SLOT="2"
KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE="gnome opengl"
DEPEND=">=dev-lang/python-2.2
>=x11-libs/pango-1
@@ -21,16 +21,13 @@ DEPEND=">=dev-lang/python-2.2
gnome? ( >=gnome-base/libglade-2 )
opengl? ( >=x11-libs/gtkglarea-1.99 )"
-SLOT="2"
-
src_compile() {
econf --enable-thread || die
emake || die
}
-src_install () {
+src_install() {
einstall || die
-
dodoc AUTHORS COPYING ChangeLog INSTALL MAPPING NEWS README THREADS TODO
}