summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-11-12 19:53:56 +0000
committerHans de Graaff <graaff@gentoo.org>2012-11-12 19:53:56 +0000
commit3b8f52f79969a1c6d64e9b9c0850334047034e59 (patch)
treec431b3f5c33bb92beb17ae5cbd017217e0dd202e
parentVersion bump. (diff)
downloadgentoo-2-3b8f52f79969a1c6d64e9b9c0850334047034e59.tar.gz
gentoo-2-3b8f52f79969a1c6d64e9b9c0850334047034e59.tar.bz2
gentoo-2-3b8f52f79969a1c6d64e9b9c0850334047034e59.zip
Version bump.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
-rw-r--r--dev-ruby/activeresource/ChangeLog7
-rw-r--r--dev-ruby/activeresource/activeresource-3.2.9.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-ruby/activeresource/ChangeLog b/dev-ruby/activeresource/ChangeLog
index 63e560d57517..0deace3a99bf 100644
--- a/dev-ruby/activeresource/ChangeLog
+++ b/dev-ruby/activeresource/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activeresource
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.121 2012/08/27 18:18:15 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.122 2012/11/12 19:53:56 graaff Exp $
+
+*activeresource-3.2.9 (12 Nov 2012)
+
+ 12 Nov 2012; Hans de Graaff <graaff@gentoo.org> +activeresource-3.2.9.ebuild:
+ Version bump.
27 Aug 2012; Hans de Graaff <graaff@gentoo.org>
-activeresource-3.0.16.ebuild, -activeresource-3.1.7.ebuild,
diff --git a/dev-ruby/activeresource/activeresource-3.2.9.ebuild b/dev-ruby/activeresource/activeresource-3.2.9.ebuild
new file mode 100644
index 000000000000..07393b26b8fb
--- /dev/null
+++ b/dev-ruby/activeresource/activeresource-3.2.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/activeresource-3.2.9.ebuild,v 1.1 2012/11/12 19:53:56 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activeresource.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Think Active Record for web resources.."
+HOMEPAGE="http://rubyforge.org/projects/activeresource/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/activeresource"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}"
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+}