summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Klausmann <klausman@gentoo.org>2014-10-14 10:53:36 +0000
committerTobias Klausmann <klausman@gentoo.org>2014-10-14 10:53:36 +0000
commit403849deaa39dc1ee5f321554c356bb3ba8d115a (patch)
tree6a6f22e94f06c86b54229bdb27916fa09a3f28e4
parentVersion bump (diff)
downloadgentoo-2-403849deaa39dc1ee5f321554c356bb3ba8d115a.tar.gz
gentoo-2-403849deaa39dc1ee5f321554c356bb3ba8d115a.tar.bz2
gentoo-2-403849deaa39dc1ee5f321554c356bb3ba8d115a.zip
Update initd file to check for file permissions, re-add systemd files and clean up init script a bit
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key CE5D54E8)
-rw-r--r--net-im/prosody/ChangeLog9
-rw-r--r--net-im/prosody/files/prosody.initd-r147
-rw-r--r--net-im/prosody/prosody-0.9.5-r1.ebuild83
3 files changed, 138 insertions, 1 deletions
diff --git a/net-im/prosody/ChangeLog b/net-im/prosody/ChangeLog
index 625f88e01c01..2a0115098234 100644
--- a/net-im/prosody/ChangeLog
+++ b/net-im/prosody/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/prosody
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/ChangeLog,v 1.39 2014/10/13 18:56:33 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/ChangeLog,v 1.40 2014/10/14 10:53:36 klausman Exp $
+
+*prosody-0.9.5-r1 (14 Oct 2014)
+
+ 14 Oct 2014; Tobias Klausmann <klausman@gentoo.org> +prosody-0.9.5-r1.ebuild,
+ +files/prosody.initd-r1:
+ Update initd file to check for file permissions, re-add systemd files and
+ clean up init script a bit
13 Oct 2014; Tobias Klausmann <klausman@gentoo.org> prosody-0.9.4.ebuild:
Stable on amd64, bug 511532
diff --git a/net-im/prosody/files/prosody.initd-r1 b/net-im/prosody/files/prosody.initd-r1
new file mode 100644
index 000000000000..bc72e2e90ef1
--- /dev/null
+++ b/net-im/prosody/files/prosody.initd-r1
@@ -0,0 +1,47 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/files/prosody.initd-r1,v 1.1 2014/10/14 10:53:36 klausman Exp $
+
+description="Prosody is a server for Jabber/XMPP written in Lua."
+description_reload="Reload configuration and reopen log files."
+extra_started_commands="reload"
+pidfile="/var/run/jabber/prosody.pid"
+
+depend() {
+ use dns
+ need net
+ provide jabber-server
+}
+
+checkconfig() {
+ if [ ! -e /etc/jabber/prosody.cfg.lua ] ; then
+ eerror "You need a /etc/jabber/prosody.cfg.lua file to run prosody"
+ return 1
+ fi
+ luac -p /etc/jabber/prosody.cfg.lua
+ return $?
+}
+
+start() {
+ checkconfig || return 1
+ checkpath -q -d -m 0770 -o jabber:jabber "$(dirname ${pidfile})"
+ checkpath -q -d -m 0770 -o jabber:jabber "${pidfile}"
+ checkpath -q -d -m 0750 -o jabber:jabber /var/log/jabber
+ ebegin "Starting Prosody XMPP Server"
+ prosodyctl start
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Prosody XMPP Server"
+ prosodyctl stop
+ eend $?
+}
+
+reload() {
+ checkconfig || return 1
+ ebegin "Reloading configuration of Prosody XMPP Server"
+ prosodyctl reload
+ eend $?
+}
diff --git a/net-im/prosody/prosody-0.9.5-r1.ebuild b/net-im/prosody/prosody-0.9.5-r1.ebuild
new file mode 100644
index 000000000000..bc2426a8b9a5
--- /dev/null
+++ b/net-im/prosody/prosody-0.9.5-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/prosody-0.9.5-r1.ebuild,v 1.1 2014/10/14 10:53:36 klausman Exp $
+
+EAPI=5
+
+inherit flag-o-matic multilib systemd versionator
+
+MY_PV=$(replace_version_separator 3 '')
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="Prosody is a flexible communications server for Jabber/XMPP written in Lua"
+HOMEPAGE="http://prosody.im/"
+SRC_URI="http://prosody.im/tmp/${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="ipv6 libevent mysql postgres sqlite ssl zlib jit"
+
+DEPEND="net-im/jabber-base
+ !jit? ( >=dev-lang/lua-5.1 )
+ jit? ( dev-lang/luajit )
+ >=net-dns/libidn-1.1
+ >=dev-libs/openssl-0.9.8"
+RDEPEND="${DEPEND}
+ >=dev-lua/luaexpat-1.3.0
+ dev-lua/luafilesystem
+ ipv6? ( >=dev-lua/luasocket-3 )
+ !ipv6? ( dev-lua/luasocket )
+ libevent? ( >=dev-lua/luaevent-0.4.3 )
+ mysql? ( dev-lua/luadbi[mysql] )
+ postgres? ( dev-lua/luadbi[postgres] )
+ sqlite? ( dev-lua/luadbi[sqlite] )
+ ssl? ( dev-lua/luasec )
+ zlib? ( dev-lua/lua-zlib )"
+
+S=${WORKDIR}/${MY_P}
+
+JABBER_ETC="/etc/jabber"
+JABBER_SPOOL="/var/spool/jabber"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.9.2-cfg.lua.patch"
+ sed -i -e "s!MODULES = \$(DESTDIR)\$(PREFIX)/lib/!MODULES = \$(DESTDIR)\$(PREFIX)/$(get_libdir)/!"\
+ -e "s!SOURCE = \$(DESTDIR)\$(PREFIX)/lib/!SOURCE = \$(DESTDIR)\$(PREFIX)/$(get_libdir)/!"\
+ -e "s!INSTALLEDSOURCE = \$(PREFIX)/lib/!INSTALLEDSOURCE = \$(PREFIX)/$(get_libdir)/!"\
+ -e "s!INSTALLEDMODULES = \$(PREFIX)/lib/!INSTALLEDMODULES = \$(PREFIX)/$(get_libdir)/!"\
+ Makefile || die
+}
+
+src_configure() {
+ # the configure script is handcrafted (and yells at unknown options)
+ # hence do not use 'econf'
+ append-cflags -D_GNU_SOURCE
+ luajit=""
+ if use jit; then
+ luajit="--runwith=luajit"
+ fi
+ ./configure \
+ --ostype=linux $luajit \
+ --prefix="/usr" \
+ --sysconfdir="${JABBER_ETC}" \
+ --datadir="${JABBER_SPOOL}" \
+ --with-lua-include=/usr/include \
+ --with-lua-lib=/usr/$(get_libdir)/lua \
+ --cflags="${CFLAGS} -Wall -fPIC" \
+ --ldflags="${LDFLAGS} -shared" \
+ --c-compiler="$(tc-getCC)" \
+ --linker="$(tc-getCC)" \
+ --require-config || die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ systemd_dounit "${FILESDIR}/${PN}".service
+ systemd_newtmpfilesd "${FILESDIR}/${PN}".tmpfilesd "${PN}".conf
+ newinitd "${FILESDIR}/${PN}".initd-r1 ${PN}
+}
+
+src_test() {
+ cd tests || die
+ ./run_tests.sh || die
+}