summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Brindle <method@gentoo.org>2003-03-17 20:00:39 +0000
committerJoshua Brindle <method@gentoo.org>2003-03-17 20:00:39 +0000
commit460db45a91ba612e1380a155b822fcc482b7229e (patch)
treef347ed70c9b6f3361cb0a94f53bac9ff8be6ddb7
parentAdding gnucash-1.8.1 mask (diff)
downloadgentoo-2-460db45a91ba612e1380a155b822fcc482b7229e.tar.gz
gentoo-2-460db45a91ba612e1380a155b822fcc482b7229e.tar.bz2
gentoo-2-460db45a91ba612e1380a155b822fcc482b7229e.zip
added selinux patch
-rw-r--r--sys-apps/coreutils/ChangeLog7
-rw-r--r--sys-apps/coreutils/coreutils-4.5.9-r2.ebuild93
-rw-r--r--sys-apps/coreutils/files/digest-coreutils-4.5.101
-rw-r--r--sys-apps/coreutils/files/digest-coreutils-4.5.9-r22
4 files changed, 102 insertions, 1 deletions
diff --git a/sys-apps/coreutils/ChangeLog b/sys-apps/coreutils/ChangeLog
index c9e57b10b6f6..16ef1937cf68 100644
--- a/sys-apps/coreutils/ChangeLog
+++ b/sys-apps/coreutils/ChangeLog
@@ -1,12 +1,17 @@
# ChangeLog for sys-apps/coreutils
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.7 2003/03/15 03:28:31 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.8 2003/03/17 20:00:39 method Exp $
*coreutils-4.5.10 (14 Mar 2003)
14 Mar 2003; Seemant Kulleen <seemant@gentoo.org> coreutils-4.5.10.ebuild:
version bump thanks to drobbins on -core
+*coreutils-4.5.9-r2 (17 Mar 2003)
+
+ 17 Mar 2003; root <root@gentoo.org> coreutils-4.5.9-r2.ebuild:
+ Added SELinux patch
+
*coreutils-4.5.9-r1 (11 Mar 2003)
11 Mar 2003; Martin Schlemmer <azarah@gentoo.org> coreutils-4.5.9-r1.ebuild :
diff --git a/sys-apps/coreutils/coreutils-4.5.9-r2.ebuild b/sys-apps/coreutils/coreutils-4.5.9-r2.ebuild
new file mode 100644
index 000000000000..18c1ebf8663a
--- /dev/null
+++ b/sys-apps/coreutils/coreutils-4.5.9-r2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-4.5.9-r2.ebuild,v 1.1 2003/03/17 20:00:39 method Exp $
+
+inherit eutils
+
+IUSE="nls build selinux"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls...), text utilities (sort, tr, head, wc..), and shell utilities (whoami, who,...)"
+HOMEPAGE="http://www.gnu.org/software/coreutils/"
+SRC_URI="ftp://alpha.gnu.org/gnu/coreutils/${P}.tar.bz2"
+use selinux && SRC_URI="${SRC_URI} http://www.coker.com.au/selinux/coreutils/core-diff-4.5.9"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa arm"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ use selinux && epatch ${DISTDIR}/core-diff-4.5.9
+
+ # patch to remove Stallman's su/wheel group rant (which doesn't apply,
+ # since Gentoo's su is not GNU/su, but that from shadow.
+ epatch ${FILESDIR}/${P}-gentoo-rms.diff
+
+ # Patch to add processor specific info to the uname output
+ if [ -z "`use hppa`" ] && [ -z "`use arm`" ]
+ then
+ epatch ${FILESDIR}/${P}-gentoo-uname.diff
+ fi
+}
+
+src_compile() {
+ local myconf=""
+ use nls || myconf="--disable-nls"
+
+ econf \
+ --bindir=/bin \
+ ${myconf} || die
+
+ if [ "`use static`" ]
+ then
+ emake LDFLAGS=-static || die
+ else
+ emake || die
+ fi
+}
+
+src_install() {
+ einstall \
+ bindir=${D}/bin || die
+
+ # hostname comes from net-base
+ # hostname does not work with the -f switch, which breaks gnome2
+ # amongst other things
+ rm -f ${D}/{bin,usr/bin}/hostname ${D}/usr/share/man/man1/hostname.*
+
+ # /bin/su comes from sys-apps/shadow
+ rm -f ${D}/{bin,usr/bin}/su ${D}/usr/share/man/man1/su.*
+
+ # /usr/bin/uptime comes from the sys-apps/procps packaga
+ rm -f ${D}/{bin,usr/bin}/uptime ${D}/usr/share/man/man1/uptime*
+
+ cd ${D}
+ dodir /usr/bin
+ rm -rf usr/lib
+ cd usr/bin
+ ln -s ../../bin/* .
+
+ if [ -z "`use build`" ]
+ then
+ cd ${S}
+ dodoc AUTHORS ChangeLog* COPYING NEWS README* THANKS TODO
+ else
+ rm -rf ${D}/usr/share
+ fi
+}
+
+pkg_postinst() {
+ # hostname does not get removed as it is included with older stage1
+ # tarballs, and net-tools installs to /bin
+ if [ -e ${ROOT}/usr/bin/hostname ] && [ ! -L ${ROOT}/usr/bin/hostname ]
+ then
+ rm -f ${ROOT}/usr/bin/hostname
+ fi
+}
diff --git a/sys-apps/coreutils/files/digest-coreutils-4.5.10 b/sys-apps/coreutils/files/digest-coreutils-4.5.10
index 87522f8520b7..141dd6089801 100644
--- a/sys-apps/coreutils/files/digest-coreutils-4.5.10
+++ b/sys-apps/coreutils/files/digest-coreutils-4.5.10
@@ -1 +1,2 @@
MD5 073aa616506e2eede6c199fa9c759ae2 coreutils-4.5.10.tar.bz2 3981173
+MD5 c3fba5a37ab5ff4d4c228da9a5533df5 core-diff-4.5.9 92345
diff --git a/sys-apps/coreutils/files/digest-coreutils-4.5.9-r2 b/sys-apps/coreutils/files/digest-coreutils-4.5.9-r2
new file mode 100644
index 000000000000..88c7698056e8
--- /dev/null
+++ b/sys-apps/coreutils/files/digest-coreutils-4.5.9-r2
@@ -0,0 +1,2 @@
+MD5 3dfa6dedf941caff97a7b69ac13cb664 coreutils-4.5.9.tar.bz2 3972934
+MD5 c3fba5a37ab5ff4d4c228da9a5533df5 core-diff-4.5.9 92345