summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2007-05-28 17:49:05 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2007-05-28 17:49:05 +0000
commit464c8c8ec45e176867ff536b9c03259e191e9069 (patch)
tree3ce4be25329bfd718c8717d020827e6635a05814
parentFix bashisms thanks Mike Arthur <mike@mikearthur.co.uk> in bug 179786 (diff)
downloadgentoo-2-464c8c8ec45e176867ff536b9c03259e191e9069.tar.gz
gentoo-2-464c8c8ec45e176867ff536b9c03259e191e9069.tar.bz2
gentoo-2-464c8c8ec45e176867ff536b9c03259e191e9069.zip
version bump from upstream
(Portage version: 2.1.2.7)
-rw-r--r--dev-util/glade/ChangeLog7
-rw-r--r--dev-util/glade/files/digest-glade-3.2.23
-rw-r--r--dev-util/glade/glade-3.2.2.ebuild39
3 files changed, 48 insertions, 1 deletions
diff --git a/dev-util/glade/ChangeLog b/dev-util/glade/ChangeLog
index 0594b96ca269..061131ff50b7 100644
--- a/dev-util/glade/ChangeLog
+++ b/dev-util/glade/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/glade
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/glade/ChangeLog,v 1.64 2007/05/03 20:51:22 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/glade/ChangeLog,v 1.65 2007/05/28 17:49:05 compnerd Exp $
+
+*glade-3.2.2 (28 May 2007)
+
+ 28 May 2007; Saleem Abdulrasool <compnerd@gentoo.org> +glade-3.2.2.ebuild:
+ Version bump from upstream with fixes
*glade-3.2.1 (03 May 2007)
diff --git a/dev-util/glade/files/digest-glade-3.2.2 b/dev-util/glade/files/digest-glade-3.2.2
new file mode 100644
index 000000000000..990fce602581
--- /dev/null
+++ b/dev-util/glade/files/digest-glade-3.2.2
@@ -0,0 +1,3 @@
+MD5 07f24fed99e424988964d6b2d77d5ba7 glade3-3.2.2.tar.bz2 1429808
+RMD160 6953c52ab921e6d0727e428796095fe9b84a0873 glade3-3.2.2.tar.bz2 1429808
+SHA256 28f97d7c41c6e1e1fd91e1e660e49aa0a7dee7839ea92f5cb661e571685b19bd glade3-3.2.2.tar.bz2 1429808
diff --git a/dev-util/glade/glade-3.2.2.ebuild b/dev-util/glade/glade-3.2.2.ebuild
new file mode 100644
index 000000000000..a0463b1a1e6f
--- /dev/null
+++ b/dev-util/glade/glade-3.2.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/glade/glade-3.2.2.ebuild,v 1.1 2007/05/28 17:49:05 compnerd Exp $
+
+inherit eutils gnome2
+
+MY_PN="glade3"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="GNOME GUI Builder"
+HOMEPAGE="http://glade.gnome.org/"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="devhelp doc gnome python"
+
+RDEPEND=">=dev-libs/glib-2.8.0
+ >=x11-libs/gtk+-2.10.0
+ >=dev-libs/libxml2-2.4
+ !alpha? ( !ppc64? ( devhelp? ( >=dev-util/devhelp-0.12 ) ) )
+ gnome? (
+ >=gnome-base/libgnomeui-2.0
+ >=gnome-base/libbonoboui-2.0
+ )
+ !alpha? ( python? ( >=dev-python/pygtk-2.10.0 ) )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.19
+ doc? ( >=dev-util/gtk-doc-1.4 )"
+
+S="${WORKDIR}/${MY_P}"
+DOCS="AUTHORS BUGS ChangeLog HACKING INTERNALS MAINTAINERS NEWS README TODO"
+
+pkg_config() {
+ G2CONF="${G2CONF} $(use_with devhelp) $(use_enable gnome) $(use_enable python)"
+}