summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-03-28 22:33:47 +0000
committerPacho Ramos <pacho@gentoo.org>2013-03-28 22:33:47 +0000
commit47852c8f8cabe32a2d7fb346dcdfd0e01f07810b (patch)
treeaa66604926dbb324b77057fe4f5c4046f5cf3a7b
parentVersion bump for Gnome 3.8 (diff)
downloadgentoo-2-47852c8f8cabe32a2d7fb346dcdfd0e01f07810b.tar.gz
gentoo-2-47852c8f8cabe32a2d7fb346dcdfd0e01f07810b.tar.bz2
gentoo-2-47852c8f8cabe32a2d7fb346dcdfd0e01f07810b.zip
Version bump for Gnome 3.8
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
-rw-r--r--net-libs/gnome-online-accounts/ChangeLog8
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-3.8.0.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/net-libs/gnome-online-accounts/ChangeLog b/net-libs/gnome-online-accounts/ChangeLog
index 2bdff7473c18..c92a74c0a2a2 100644
--- a/net-libs/gnome-online-accounts/ChangeLog
+++ b/net-libs/gnome-online-accounts/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/gnome-online-accounts
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnome-online-accounts/ChangeLog,v 1.11 2013/02/02 23:02:57 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnome-online-accounts/ChangeLog,v 1.12 2013/03/28 22:33:47 pacho Exp $
+
+*gnome-online-accounts-3.8.0 (28 Mar 2013)
+
+ 28 Mar 2013; Pacho Ramos <pacho@gentoo.org>
+ +gnome-online-accounts-3.8.0.ebuild:
+ Version bump for Gnome 3.8
02 Feb 2013; Agostino Sarubbo <ago@gentoo.org>
gnome-online-accounts-3.6.2.ebuild:
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-3.8.0.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-3.8.0.ebuild
new file mode 100644
index 000000000000..facc54c41f72
--- /dev/null
+++ b/net-libs/gnome-online-accounts/gnome-online-accounts-3.8.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnome-online-accounts/gnome-online-accounts-3.8.0.ebuild,v 1.1 2013/03/28 22:33:47 pacho Exp $
+
+EAPI="5"
+inherit gnome2
+
+DESCRIPTION="GNOME framework for accessing online accounts"
+HOMEPAGE="https://live.gnome.org/GnomeOnlineAccounts"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+IUSE="gnome +introspection kerberos"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# pango used in goaeditablelabel
+# libsoup used in goaoauthprovider
+# goa kerberos provider is incompatible with app-crypt/heimdal, see
+# https://bugzilla.gnome.org/show_bug.cgi?id=692250
+RDEPEND="
+ >=dev-libs/glib-2.35:2
+ app-crypt/libsecret
+ dev-libs/json-glib
+ dev-libs/libxml2:2
+ >=net-libs/libsoup-2.41:2.4[gnome]
+ net-libs/rest:0.7
+ net-libs/webkit-gtk:3
+ >=x11-libs/gtk+-3.5.1:3
+ >=x11-libs/libnotify-0.7:=
+ x11-libs/pango
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2 )
+ kerberos? (
+ app-crypt/gcr
+ app-crypt/mit-krb5 )
+"
+# goa-daemon can launch gnome-control-center
+PDEPEND="gnome? ( >=gnome-base/gnome-control-center-3.2[gnome-online-accounts(+)] )"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.3
+ >=dev-util/gdbus-codegen-2.30.0
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # TODO: Give users a way to set the G/Y!/FB/Twitter/Windows Live secrets
+ gnome2_src_configure \
+ --disable-static \
+ --enable-documentation \
+ --enable-exchange \
+ --enable-facebook \
+ --with-facebook-client-id \
+ --enable-imap-smtp \
+ --enable-owncloud \
+ --with-windows-live-client-id \
+ $(use_enable kerberos)
+}