summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Horelick <jdhore@gentoo.org>2015-03-14 18:42:23 +0000
committerJeff Horelick <jdhore@gentoo.org>2015-03-14 18:42:23 +0000
commit4b56c5a2330889cffdc92a47f05c607428a6001a (patch)
treedbecb12e3fb5bd80a62774c5ac30bdc9f6542ac5
parentamd64 stable, bug 534012 (diff)
downloadgentoo-2-4b56c5a2330889cffdc92a47f05c607428a6001a.tar.gz
gentoo-2-4b56c5a2330889cffdc92a47f05c607428a6001a.tar.bz2
gentoo-2-4b56c5a2330889cffdc92a47f05c607428a6001a.zip
Version bump
(Portage version: 2.2.18/cvs/Linux i686, unsigned Manifest commit)
-rw-r--r--dev-util/pkgconf/ChangeLog9
-rw-r--r--dev-util/pkgconf/pkgconf-0.9.8.ebuild56
2 files changed, 63 insertions, 2 deletions
diff --git a/dev-util/pkgconf/ChangeLog b/dev-util/pkgconf/ChangeLog
index e40de182217b..f0231d456dbd 100644
--- a/dev-util/pkgconf/ChangeLog
+++ b/dev-util/pkgconf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/pkgconf
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/ChangeLog,v 1.86 2014/08/28 04:27:21 jdhore Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/ChangeLog,v 1.87 2015/03/14 18:42:23 jdhore Exp $
+
+*pkgconf-0.9.8 (14 Mar 2015)
+
+ 14 Mar 2015; Jeff Horelick <jdhore@gentoo.org> +pkgconf-0.9.8.ebuild:
+ Version bump
*pkgconf-0.9.6 (28 Aug 2014)
diff --git a/dev-util/pkgconf/pkgconf-0.9.8.ebuild b/dev-util/pkgconf/pkgconf-0.9.8.ebuild
new file mode 100644
index 000000000000..b82959aa8aa1
--- /dev/null
+++ b/dev-util/pkgconf/pkgconf-0.9.8.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/pkgconf-0.9.8.ebuild,v 1.1 2015/03/14 18:42:23 jdhore Exp $
+
+EAPI=5
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/pkgconf/pkgconf.git"
+ inherit autotools git-2 multilib-minimal
+else
+ inherit eutils multilib-minimal
+ SRC_URI="http://rabbit.dereferenced.org/~nenolod/distfiles/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc64-solaris ~x64-solaris"
+fi
+
+DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
+HOMEPAGE="https://github.com/pkgconf/pkgconf"
+
+LICENSE="BSD-1"
+SLOT="0"
+IUSE="+pkg-config strict"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ pkg-config? (
+ !dev-util/pkgconfig
+ !dev-util/pkg-config-lite
+ !dev-util/pkgconfig-openbsd[pkg-config]
+ )"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/pkgconf
+)
+
+src_prepare() {
+ [[ -e configure ]] || eautoreconf
+
+ if use pkg-config; then
+ MULTILIB_CHOST_TOOLS+=(
+ /usr/bin/pkg-config
+ )
+ fi
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf $(use_enable strict)
+}
+
+multilib_src_install() {
+ default
+ use pkg-config \
+ && dosym pkgconf /usr/bin/pkg-config \
+ || rm "${ED}"/usr/share/aclocal/pkg.m4 \
+ || die
+}