summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-05-31 09:46:25 +0000
committerPacho Ramos <pacho@gentoo.org>2014-05-31 09:46:25 +0000
commit4bfced6dcea256f4ed6ae512d88781ed94bec373 (patch)
tree0830d2ba664134a3a2764fbbc49def01b73a0475
parentVersion bump (diff)
downloadgentoo-2-4bfced6dcea256f4ed6ae512d88781ed94bec373.tar.gz
gentoo-2-4bfced6dcea256f4ed6ae512d88781ed94bec373.tar.bz2
gentoo-2-4bfced6dcea256f4ed6ae512d88781ed94bec373.zip
Version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
-rw-r--r--net-libs/gssdp/ChangeLog7
-rw-r--r--net-libs/gssdp/gssdp-0.14.8.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/net-libs/gssdp/ChangeLog b/net-libs/gssdp/ChangeLog
index 6e271088928a..6050a9175721 100644
--- a/net-libs/gssdp/ChangeLog
+++ b/net-libs/gssdp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/gssdp
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gssdp/ChangeLog,v 1.70 2014/04/26 06:36:52 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gssdp/ChangeLog,v 1.71 2014/05/31 09:46:25 pacho Exp $
+
+*gssdp-0.14.8 (31 May 2014)
+
+ 31 May 2014; Pacho Ramos <pacho@gentoo.org> +gssdp-0.14.8.ebuild:
+ Version bump
26 Apr 2014; Pacho Ramos <pacho@gentoo.org> -gssdp-0.12.2.1.ebuild,
-gssdp-0.14.6.ebuild:
diff --git a/net-libs/gssdp/gssdp-0.14.8.ebuild b/net-libs/gssdp/gssdp-0.14.8.ebuild
new file mode 100644
index 000000000000..3e600a3904d9
--- /dev/null
+++ b/net-libs/gssdp/gssdp-0.14.8.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gssdp/gssdp-0.14.8.ebuild,v 1.1 2014/05/31 09:46:25 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.14"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="A GObject-based API for handling resource discovery and announcement over SSDP"
+HOMEPAGE="https://wiki.gnome.org/Projects/GUPnP"
+
+LICENSE="LGPL-2"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="+introspection +gtk"
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=net-libs/libsoup-2.26.1:2.4[introspection?]
+ gtk? ( >=x11-libs/gtk+-3.0:3 )
+ introspection? (
+ $(vala_depend)
+ >=dev-libs/gobject-introspection-0.6.7 )
+ !<net-libs/gupnp-vala-0.10.3
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.10
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Disable functional test as it requires port that might be used by rygel to
+ # be free of use
+ sed 's/\(check_PROGRAMS.*\)test-functional$(EXEEXT)/\1/' \
+ -i "${S}"/tests/gtest/Makefile.in || die
+
+ use introspection && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ $(use_with gtk) \
+ --disable-static
+}