summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2005-09-29 01:29:51 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2005-09-29 01:29:51 +0000
commit4d6986ab396fc62374bbb17a366b4add671867a9 (patch)
tree08570341c1de950d0c7d55f9992d809723e6ad0e
parentStable on mips. (diff)
downloadgentoo-2-4d6986ab396fc62374bbb17a366b4add671867a9.tar.gz
gentoo-2-4d6986ab396fc62374bbb17a366b4add671867a9.tar.bz2
gentoo-2-4d6986ab396fc62374bbb17a366b4add671867a9.zip
Do not dodoc INSTALL, add gcc4 patch
(Portage version: 2.0.52-r1)
-rw-r--r--app-text/ots/ChangeLog6
-rw-r--r--app-text/ots/Manifest5
-rw-r--r--app-text/ots/files/ots-0.4.2-gcc4.diff21
-rw-r--r--app-text/ots/ots-0.4.1.ebuild4
-rw-r--r--app-text/ots/ots-0.4.2.ebuild11
5 files changed, 40 insertions, 7 deletions
diff --git a/app-text/ots/ChangeLog b/app-text/ots/ChangeLog
index f7d40552d336..be3f10a113bd 100644
--- a/app-text/ots/ChangeLog
+++ b/app-text/ots/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/ots
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ots/ChangeLog,v 1.10 2005/09/03 00:41:27 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ots/ChangeLog,v 1.11 2005/09/29 01:29:51 vanquirius Exp $
+
+ 29 Sep 2005; Marcelo Goes <vanquirius@gentoo.org>
+ +files/ots-0.4.2-gcc4.diff, ots-0.4.1.ebuild, ots-0.4.2.ebuild:
+ Do not dodoc INSTALL, add gcc4 patch.
*ots-0.4.2 (03 Sep 2005)
diff --git a/app-text/ots/Manifest b/app-text/ots/Manifest
index 56bef65e541f..ccf8c0f0ba86 100644
--- a/app-text/ots/Manifest
+++ b/app-text/ots/Manifest
@@ -1,6 +1,7 @@
-MD5 677547a59e1d66ba9caab3275f716e82 ots-0.4.1.ebuild 849
+MD5 9c451c033c2a312c80362a859aa33d6f ots-0.4.1.ebuild 841
MD5 0204947ebc421e8b03cf09f27b5c2960 ChangeLog 1545
MD5 5c0cf8693a8e3f46bbd06854f4d8a6f7 metadata.xml 258
-MD5 35134f9cd5fc509c13190bc50daba500 ots-0.4.2.ebuild 871
+MD5 6dd563e65a8d0bb9e7efdfbafab29726 ots-0.4.2.ebuild 958
+MD5 77ea1e5c9421e55a38bc2f9bebcb17ed files/ots-0.4.2-gcc4.diff 677
MD5 4fb352a699bbaed36ab4cd3ae199aca5 files/digest-ots-0.4.1 61
MD5 90b8180610e12a5b5f83f128256082ea files/digest-ots-0.4.2 61
diff --git a/app-text/ots/files/ots-0.4.2-gcc4.diff b/app-text/ots/files/ots-0.4.2-gcc4.diff
new file mode 100644
index 000000000000..7ec0f46a8fed
--- /dev/null
+++ b/app-text/ots/files/ots-0.4.2-gcc4.diff
@@ -0,0 +1,21 @@
+--- ots-0.4.2.orig/src/article.c 2005-09-28 22:11:41.000000000 -0300
++++ ots-0.4.2/src/article.c 2005-09-28 22:18:24.000000000 -0300
+@@ -35,7 +35,7 @@
+ ots_new_sentence (void)
+ {
+ OtsSentence *aLine = g_new0 (OtsSentence, 1);
+- (GList *) aLine->words = NULL;
++ aLine->words = (GList *)NULL;
+ aLine->wc = 0;
+ aLine->selected = 0;
+ aLine->score = 0;
+--- ots-0.4.2.orig/src/grader-tf.c 2005-09-28 22:11:41.000000000 -0300
++++ ots-0.4.2/src/grader-tf.c 2005-09-28 22:21:48.000000000 -0300
+@@ -22,6 +22,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include "libots.h"
++#include <math.h>
+
+ /*Grader - using the Term frequency algorithm. Will give each line a score*/
+
diff --git a/app-text/ots/ots-0.4.1.ebuild b/app-text/ots/ots-0.4.1.ebuild
index bd09ad48ef6d..3967c316cf1a 100644
--- a/app-text/ots/ots-0.4.1.ebuild
+++ b/app-text/ots/ots-0.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ots/ots-0.4.1.ebuild,v 1.9 2005/09/03 00:41:27 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ots/ots-0.4.1.ebuild,v 1.10 2005/09/29 01:29:51 vanquirius Exp $
DESCRIPTION="Open source Text Summarizer, as used in newer releases of abiword and kword."
HOMEPAGE="http://libots.sourceforge.net/"
@@ -27,7 +27,7 @@ src_compile() {
src_install() {
einstall || die
rm -rf "${D}"/usr/share/doc/libots
- dodoc AUTHORS BUGS ChangeLog HACKING INSTALL NEWS README TODO
+ dodoc AUTHORS BUGS ChangeLog HACKING NEWS README TODO
cd "${S}"/doc/html
dohtml -r ./
}
diff --git a/app-text/ots/ots-0.4.2.ebuild b/app-text/ots/ots-0.4.2.ebuild
index a4d40e115d8a..c5ce052c928f 100644
--- a/app-text/ots/ots-0.4.2.ebuild
+++ b/app-text/ots/ots-0.4.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ots/ots-0.4.2.ebuild,v 1.1 2005/09/03 00:41:27 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ots/ots-0.4.2.ebuild,v 1.2 2005/09/29 01:29:51 vanquirius Exp $
+
+inherit eutils
DESCRIPTION="Open source Text Summarizer, as used in newer releases of abiword and kword."
HOMEPAGE="http://libots.sourceforge.net/"
@@ -18,6 +20,11 @@ RDEPEND="=dev-libs/glib-2*
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_unpack() {
+ unpack ${A}; cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc4.diff
+}
+
src_compile() {
# bug 97448
econf --disable-gtk-doc || die
@@ -27,7 +34,7 @@ src_compile() {
src_install() {
make DESTDIR="${D}" install || die
rm -rf "${D}"/usr/share/doc/libots
- dodoc AUTHORS BUGS ChangeLog HACKING INSTALL NEWS README TODO
+ dodoc AUTHORS BUGS ChangeLog HACKING NEWS README TODO
cd "${S}"/doc/html
dohtml -r ./
}