summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-06-05 20:08:46 +0000
committerDan Armak <danarmak@gentoo.org>2002-06-05 20:08:46 +0000
commit52b5e46a72be67cd1ec9d21612cfef7c76d849b9 (patch)
treeb671741b8f3465f9f68bd1231b9e39e4b1dad844
parentnew version (diff)
downloadgentoo-2-52b5e46a72be67cd1ec9d21612cfef7c76d849b9.tar.gz
gentoo-2-52b5e46a72be67cd1ec9d21612cfef7c76d849b9.tar.bz2
gentoo-2-52b5e46a72be67cd1ec9d21612cfef7c76d849b9.zip
enable objc bindnigs, make mozilla bindings dependant on mozilla use flag
-rw-r--r--kde-base/kdebindings/kdebindings-3.0.1.20020604.ebuild18
1 files changed, 16 insertions, 2 deletions
diff --git a/kde-base/kdebindings/kdebindings-3.0.1.20020604.ebuild b/kde-base/kdebindings/kdebindings-3.0.1.20020604.ebuild
index c715ce991c26..c6654eaa56b8 100644
--- a/kde-base/kdebindings/kdebindings-3.0.1.20020604.ebuild
+++ b/kde-base/kdebindings/kdebindings-3.0.1.20020604.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings/kdebindings-3.0.1.20020604.ebuild,v 1.1 2002/06/05 19:14:09 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings/kdebindings-3.0.1.20020604.ebuild,v 1.2 2002/06/05 20:08:46 danarmak Exp $
inherit kde-patch kde-dist
@@ -14,10 +14,24 @@ newdepend ">=kde-base/kdebase-${PV}
java? ( virtual/jdk )
=x11-libs/gtk+-1.2*
=dev-libs/glib-1.2*
- ~kde-base/kdenetwork-${PV}"
+ >=kde-base/kdenetwork-${PV}
+ mozilla? ( net-www/mozilla )"
use python || myconf="$myconf --without-python"
use java && myconf="$myconf --with-java=$(java-config --jdk-home)" || myconf="$myconf --without-java"
+myconf="$myconf --enable-objc"
export LIBPYTHON="`python-config`"
+src_unpack()
+{
+ base_src_unpack
+
+ if [ -z "`use mozilla`" ]; then
+ # disable mozilla bindings/xpart
+ cd ${S}
+ cp configure configure.orig
+ sed -e 's:mozilla_incldirs=:# mozilla_incldirs=:' configure.orig > configure
+ chmod +x configure
+ fi
+} \ No newline at end of file