summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2006-06-23 12:46:43 +0000
committerJeroen Roovers <jer@gentoo.org>2006-06-23 12:46:43 +0000
commit544a77a358432b6f43b4c2f68cdf8716bfdd2259 (patch)
tree69252e2dd7e2707cfd61bdd3c660db3d5d20c3b5
parentVersion bump to 1.0.12_rc1 version. (diff)
downloadgentoo-2-544a77a358432b6f43b4c2f68cdf8716bfdd2259.tar.gz
gentoo-2-544a77a358432b6f43b4c2f68cdf8716bfdd2259.tar.bz2
gentoo-2-544a77a358432b6f43b4c2f68cdf8716bfdd2259.zip
SRC_URI and HOMEPAGE changed. Bugs #65829, #91760 fixed in new release and #136843 fixed by patch submitted by jieryn (thank you!).
(Portage version: 2.1.1_pre1-r1)
-rw-r--r--app-text/pinfo/ChangeLog9
-rw-r--r--app-text/pinfo/files/digest-pinfo-0.6.93
-rw-r--r--app-text/pinfo/files/pinfo-0.6.9-FTPVIEWER.patch11
-rw-r--r--app-text/pinfo/pinfo-0.6.9.ebuild40
4 files changed, 62 insertions, 1 deletions
diff --git a/app-text/pinfo/ChangeLog b/app-text/pinfo/ChangeLog
index 2b2524319356..9cad188b841b 100644
--- a/app-text/pinfo/ChangeLog
+++ b/app-text/pinfo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/pinfo
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pinfo/ChangeLog,v 1.25 2006/06/23 12:33:45 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pinfo/ChangeLog,v 1.26 2006/06/23 12:46:43 jer Exp $
+
+*pinfo-0.6.9 (23 Jun 2006)
+
+ 23 Jun 2006; Jeroen Roovers <jer@gentoo.org>
+ +files/pinfo-0.6.9-FTPVIEWER.patch, +pinfo-0.6.9.ebuild:
+ SRC_URI and HOMEPAGE changed. Bugs #65829, #91760 fixed in new release and
+ #136843 fixed by patch submitted by jieryn (thank you!).
23 Jun 2006; Jeroen Roovers <jer@gentoo.org> metadata.xml:
Taking up maintainership.
diff --git a/app-text/pinfo/files/digest-pinfo-0.6.9 b/app-text/pinfo/files/digest-pinfo-0.6.9
new file mode 100644
index 000000000000..3b269087a4d1
--- /dev/null
+++ b/app-text/pinfo/files/digest-pinfo-0.6.9
@@ -0,0 +1,3 @@
+MD5 e0c788467945f5f97fbacad55863e5b8 pinfo-0.6.9.tar.bz2 448469
+RMD160 e67582e0839d431c48b9849c477a2cd6917e568e pinfo-0.6.9.tar.bz2 448469
+SHA256 03037330e7626932adb31c54d6c5e71b667bcde4854fd75357e67b7b7cf87ae5 pinfo-0.6.9.tar.bz2 448469
diff --git a/app-text/pinfo/files/pinfo-0.6.9-FTPVIEWER.patch b/app-text/pinfo/files/pinfo-0.6.9-FTPVIEWER.patch
new file mode 100644
index 000000000000..52dbe0cbd097
--- /dev/null
+++ b/app-text/pinfo/files/pinfo-0.6.9-FTPVIEWER.patch
@@ -0,0 +1,11 @@
++++ src/parse_config.c 2006-03-09 20:44:51.000000000 +0100
+--- src/parse_config.c 2006-06-23 14:16:02.000000000 +0200
+@@ -601,7 +601,7 @@
+ else
+ return 1;
+ }
+- else if (!strncmp(temp, "FTPVIEWER", 10))
++ else if (!strncmp(temp, "FTPVIEWER", 9))
+ {
+ temp = strtok(NULL, "\n");
+ if (temp)
diff --git a/app-text/pinfo/pinfo-0.6.9.ebuild b/app-text/pinfo/pinfo-0.6.9.ebuild
new file mode 100644
index 000000000000..de817434604f
--- /dev/null
+++ b/app-text/pinfo/pinfo-0.6.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pinfo/pinfo-0.6.9.ebuild,v 1.1 2006/06/23 12:46:43 jer Exp $
+
+inherit eutils
+
+DESCRIPTION="Hypertext info and man viewer based on (n)curses"
+HOMEPAGE="http:/pinfo.alioth.debian.org"
+SRC_URI="https://alioth.debian.org/download.php/1498/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls readline"
+
+RDEPEND="sys-libs/ncurses
+ nls? ( virtual/libintl )"
+
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-FTPVIEWER.patch
+}
+
+src_compile() {
+ econf \
+ $(use_with readline) \
+ $(use_enable nls) \
+ || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} sysconfdir=/etc install || die
+}