summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-10-24 04:59:15 +0000
committerTim Harder <radhermit@gentoo.org>2012-10-24 04:59:15 +0000
commit57813c323e53fed1398b8513e0d9428306dd529d (patch)
tree05d75bd69851f1263038676901754f78207db2b9
parentBump #439366 (diff)
downloadgentoo-2-57813c323e53fed1398b8513e0d9428306dd529d.tar.gz
gentoo-2-57813c323e53fed1398b8513e0d9428306dd529d.tar.bz2
gentoo-2-57813c323e53fed1398b8513e0d9428306dd529d.zip
Version bump. Add doc use flag to build sphinx docs.
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
-rw-r--r--dev-python/urwid/ChangeLog8
-rw-r--r--dev-python/urwid/files/urwid-1.1.0-sphinx.patch11
-rw-r--r--dev-python/urwid/urwid-1.1.0.ebuild52
3 files changed, 70 insertions, 1 deletions
diff --git a/dev-python/urwid/ChangeLog b/dev-python/urwid/ChangeLog
index cbfb72e16094..026b866d9026 100644
--- a/dev-python/urwid/ChangeLog
+++ b/dev-python/urwid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/urwid
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/ChangeLog,v 1.56 2012/10/22 11:12:23 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/ChangeLog,v 1.57 2012/10/24 04:59:15 radhermit Exp $
+
+*urwid-1.1.0 (24 Oct 2012)
+
+ 24 Oct 2012; Tim Harder <radhermit@gentoo.org> +urwid-1.1.0.ebuild,
+ +files/urwid-1.1.0-sphinx.patch:
+ Version bump. Add doc use flag to build sphinx docs.
22 Oct 2012; Tim Harder <radhermit@gentoo.org> -urwid-1.0.0.ebuild,
-urwid-1.0.1.ebuild:
diff --git a/dev-python/urwid/files/urwid-1.1.0-sphinx.patch b/dev-python/urwid/files/urwid-1.1.0-sphinx.patch
new file mode 100644
index 000000000000..442aeea67500
--- /dev/null
+++ b/dev-python/urwid/files/urwid-1.1.0-sphinx.patch
@@ -0,0 +1,11 @@
+--- urwid-1.1.0/docs/conf.py
++++ urwid-1.1.0/docs/conf.py
+@@ -46,7 +46,7 @@
+ # The version info for the project you're documenting, acts as replacement for
+ # |version| and |release|, also used in various other places throughout the
+ # built documents.
+-FILE_PATH = os.path.dirname(__file__).decode('utf-8')
++FILE_PATH = os.path.dirname(__file__)
+ VERSION_MODULE = os.path.abspath(os.path.join(FILE_PATH,
+ '../urwid/version.py'))
+ VERSION_VARS = {}
diff --git a/dev-python/urwid/urwid-1.1.0.ebuild b/dev-python/urwid/urwid-1.1.0.ebuild
new file mode 100644
index 000000000000..ec437a995de8
--- /dev/null
+++ b/dev-python/urwid/urwid-1.1.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/urwid-1.1.0.ebuild,v 1.1 2012/10/24 04:59:15 radhermit Exp $
+
+EAPI="4"
+PYTHON_USE_WITH="ncurses"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+PYTHON_TESTS_FAILURES_TOLERANT_ABIS="3.1"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils eutils
+
+DESCRIPTION="Urwid is a curses-based user interface library for Python"
+HOMEPAGE="http://excess.org/urwid/ http://pypi.python.org/pypi/urwid"
+SRC_URI="http://excess.org/urwid/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="doc examples"
+
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx )"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+src_prepare() {
+ distutils_src_prepare
+
+ epatch "${FILESDIR}"/${P}-sphinx.patch
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc ; then
+ cd docs
+ sphinx-build . _build || die
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ use doc && dohtml -r docs/_build/*
+
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}