summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-07-16 05:50:39 +0000
committerHans de Graaff <graaff@gentoo.org>2015-07-16 05:50:39 +0000
commit5f77ec771df8ad24f078f4a9765b0bf14a8105c0 (patch)
tree998a8823b5a3066fa19261a8d6a0d58bde65ee38
parentbup (diff)
downloadgentoo-2-5f77ec771df8ad24f078f4a9765b0bf14a8105c0.tar.gz
gentoo-2-5f77ec771df8ad24f078f4a9765b0bf14a8105c0.tar.bz2
gentoo-2-5f77ec771df8ad24f078f4a9765b0bf14a8105c0.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
-rw-r--r--dev-ruby/rspec-expectations/ChangeLog8
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-3.3.1.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-ruby/rspec-expectations/ChangeLog b/dev-ruby/rspec-expectations/ChangeLog
index 075a218a11a8..f853810d881b 100644
--- a/dev-ruby/rspec-expectations/ChangeLog
+++ b/dev-ruby/rspec-expectations/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rspec-expectations
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v 1.90 2015/06/28 06:00:17 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v 1.91 2015/07/16 05:50:39 graaff Exp $
+
+*rspec-expectations-3.3.1 (16 Jul 2015)
+
+ 16 Jul 2015; Hans de Graaff <graaff@gentoo.org>
+ +rspec-expectations-3.3.1.ebuild:
+ Version bump.
*rspec-expectations-3.3.0 (28 Jun 2015)
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-3.3.1.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-3.3.1.ebuild
new file mode 100644
index 000000000000..fd247c7fbd12
--- /dev/null
+++ b/dev-ruby/rspec-expectations/rspec-expectations-3.3.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/rspec-expectations-3.3.1.ebuild,v 1.1 2015/07/16 05:50:39 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="https://github.com/rspec/rspec-expectations"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+SUBVERSION="$(get_version_component_range 1-2)"
+
+ruby_add_rdepend ">=dev-ruby/diff-lcs-1.2.0 <dev-ruby/diff-lcs-2
+ =dev-ruby/rspec-support-${SUBVERSION}*"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rspec-mocks-3.2.0:3
+ )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm Gemfile || die
+
+ # fix up the gemspecs
+ sed -i \
+ -e '/git ls/d' \
+ -e '/add_development_dependency/d' \
+ "${RUBY_FAKEGEM_GEMSPEC}" || die
+
+ #
+ sed -i -e '1irequire "spec_helper"' spec/rspec/expectations/configuration_spec.rb || die
+
+ # Avoid a weird, and failing, test testing already installed code.
+ sed -e '/has an up-to-date caller_filter file/,/end/ s:^:#:' -i spec/rspec/expectations_spec.rb || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby22)
+ # The rubygems version bundled with ruby 2.2 causes warnings.
+ sed -i -e '/a library that issues no warnings when loaded/,/^ end/ s:^:#:' spec/rspec/expectations_spec.rb || die
+ ;;
+ esac
+}