summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-13 02:07:19 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-13 02:07:19 +0000
commit62dccfafd29964740107d122374062dfc0131248 (patch)
treed17b521cdce328fb7b1939a4162c8c401c655add
parentEAPI=2; add use-based deps (bug #209009); add alternate graphics support (diff)
downloadgentoo-2-62dccfafd29964740107d122374062dfc0131248.tar.gz
gentoo-2-62dccfafd29964740107d122374062dfc0131248.tar.bz2
gentoo-2-62dccfafd29964740107d122374062dfc0131248.zip
EAPI=2; add use-based dep (bug #207401)
(Portage version: 2.1.6.4/cvs/Linux 2.6.27.8 i686)
-rw-r--r--games-arcade/pacmanarena/ChangeLog8
-rw-r--r--games-arcade/pacmanarena/pacmanarena-0.15.ebuild9
2 files changed, 12 insertions, 5 deletions
diff --git a/games-arcade/pacmanarena/ChangeLog b/games-arcade/pacmanarena/ChangeLog
index 70c0bf31a063..e73712716846 100644
--- a/games-arcade/pacmanarena/ChangeLog
+++ b/games-arcade/pacmanarena/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/pacmanarena
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/pacmanarena/ChangeLog,v 1.13 2007/02/14 10:46:34 nyhm Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/pacmanarena/ChangeLog,v 1.14 2009/01/13 02:07:19 mr_bones_ Exp $
+
+ 13 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ pacmanarena-0.15.ebuild:
+ EAPI=2; add use-based dep (bug #207401)
14 Feb 2007; Tristan Heaven <nyhm@gentoo.org> pacmanarena-0.15.ebuild:
Install menu entry, bug #160241
diff --git a/games-arcade/pacmanarena/pacmanarena-0.15.ebuild b/games-arcade/pacmanarena/pacmanarena-0.15.ebuild
index 6b933d5ae4d1..fabe68bf2fda 100644
--- a/games-arcade/pacmanarena/pacmanarena-0.15.ebuild
+++ b/games-arcade/pacmanarena/pacmanarena-0.15.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/pacmanarena/pacmanarena-0.15.ebuild,v 1.13 2007/02/14 10:46:34 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/pacmanarena/pacmanarena-0.15.ebuild,v 1.14 2009/01/13 02:07:19 mr_bones_ Exp $
+EAPI=2
inherit eutils games
DESCRIPTION="a Pacman clone in full 3D with a few surprises. Rockets, bombs and explosions abound."
@@ -17,7 +18,7 @@ IUSE=""
RDEPEND="virtual/opengl
virtual/glu
media-libs/libsdl
- media-libs/sdl-mixer
+ media-libs/sdl-mixer[vorbis]
media-libs/sdl-net"
DEPEND="${RDEPEND}
app-arch/unzip"
@@ -28,7 +29,9 @@ src_unpack() {
unpack pacman-arena-${PV}.tar.bz2
cd "${S}"
unpack pacman-data-0.0.zip
+}
+src_prepare() {
sed -i \
-e "/^CFLAGS/ s:pacman:${PN}:" \
-e '1i CC=@CC@' \