summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2006-10-14 23:59:30 +0000
committerLance Albertson <ramereth@gentoo.org>2006-10-14 23:59:30 +0000
commit67d2567206fbd70dea95550cd50d4ca153efcb7c (patch)
tree7537a1f4b6878a8eb1a6c8e152b04c59cece815b
parentUpdate of the x264 compatibility patch to be compatible with media-libs/x264-... (diff)
downloadgentoo-2-67d2567206fbd70dea95550cd50d4ca153efcb7c.tar.gz
gentoo-2-67d2567206fbd70dea95550cd50d4ca153efcb7c.tar.bz2
gentoo-2-67d2567206fbd70dea95550cd50d4ca153efcb7c.zip
version bump, other misc fixes, bug #132038
(Portage version: 2.1.1-r1)
-rw-r--r--net-analyzer/cacti/ChangeLog9
-rw-r--r--net-analyzer/cacti/cacti-0.8.6i.ebuild88
-rw-r--r--net-analyzer/cacti/files/digest-cacti-0.8.6i3
3 files changed, 99 insertions, 1 deletions
diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index 269bafe12520..0299bff1877f 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/cacti
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.75 2006/06/01 21:26:12 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.76 2006/10/14 23:59:30 ramereth Exp $
+
+*cacti-0.8.6i (14 Oct 2006)
+
+ 14 Oct 2006; Lance Albertson <ramereth@gentoo.org> +cacti-0.8.6i.ebuild:
+ * Version bump
+ * Fix misc issues in bug #132038
+ * Fixed patching code to be more scalable
01 Jun 2006; Markus Ullmann <jokey@gentoo.org> files/postinstall-en.txt:
Adjusting postinstall instructions wrt bug #135082
diff --git a/net-analyzer/cacti/cacti-0.8.6i.ebuild b/net-analyzer/cacti/cacti-0.8.6i.ebuild
new file mode 100644
index 000000000000..1fa077f97579
--- /dev/null
+++ b/net-analyzer/cacti/cacti-0.8.6i.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6i.ebuild,v 1.1 2006/10/14 23:59:30 ramereth Exp $
+
+inherit eutils webapp depend.apache depend.php
+
+# (patched versions)
+MY_P=${P/_p*/}
+HAS_PATCHES=0
+
+DESCRIPTION="Cacti is a complete frontend to rrdtool"
+HOMEPAGE="http://www.cacti.net/"
+SRC_URI="http://www.cacti.net/downloads/${MY_P}.tar.gz"
+
+# patches
+if [ $HAS_PATCHES == 1 ] ; then
+ UPSTREAM_PATCHES=""
+ for i in $UPSTREAM_PATCHES ; do
+ SRC_URI="${SRC_URI} http://www.cacti.net/downloads/patches/${PV/_p*}/${i}.patch"
+ done
+fi
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="snmp"
+
+DEPEND=""
+
+want_apache
+need_php_cli
+need_php_httpd
+
+# alpha doesn't have lighttpd keyworded yet
+# sparc doesn't have a stable keyword for lighttpd yet
+RDEPEND="!alpha? ( !sparc? ( !apache? ( !apache2? ( www-servers/lighttpd ) ) ) )
+ snmp? ( net-analyzer/net-snmp )
+ net-analyzer/rrdtool
+ dev-db/mysql
+ virtual/cron"
+
+src_unpack() {
+ if [ $HAS_PATCHES == 1 ] ; then
+ unpack ${MY_P}.tar.gz ; mv ${MY_P} ${P}
+ # patches
+ for i in ${UPSTREAM_PATCHES} ; do
+ EPATCH_OPTS="-p1 -d ${S} -N" epatch ${DISTDIR}/${i}.patch
+ done ;
+ else
+ unpack ${MY_P}.tar.gz
+ fi
+}
+
+pkg_setup() {
+ webapp_pkg_setup
+ has_php
+ if [ $PHP_VERSION = 5 ] ; then
+ require_php_with_use cli mysql xml
+ elif [ $PHP_VERSION = 4 ] ; then
+ require_php_with_use cli mysql xml expat
+ fi
+}
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc LICENSE
+ rm LICENSE README
+
+ dodoc docs/{CHANGELOG,CONTRIB,INSTALL,README,REQUIREMENTS,UPGRADE}
+ rm -rf docs
+
+ edos2unix `find -type f -name '*.php'`
+
+ dodir ${MY_HTDOCSDIR}
+ cp -r . ${D}${MY_HTDOCSDIR}
+
+ webapp_serverowned ${MY_HTDOCSDIR}/rra
+ webapp_serverowned ${MY_HTDOCSDIR}/log/cacti.log
+ webapp_configfile ${MY_HTDOCSDIR}/include/config.php
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ webapp_src_install
+}
+
diff --git a/net-analyzer/cacti/files/digest-cacti-0.8.6i b/net-analyzer/cacti/files/digest-cacti-0.8.6i
new file mode 100644
index 000000000000..501a60d15644
--- /dev/null
+++ b/net-analyzer/cacti/files/digest-cacti-0.8.6i
@@ -0,0 +1,3 @@
+MD5 341b5828d95db91f81f5fbba65411d63 cacti-0.8.6i.tar.gz 1122700
+RMD160 2c5ea7dc594c455c710f8c253a25805883395a2f cacti-0.8.6i.tar.gz 1122700
+SHA256 3998dae625314309c58cea0fc1e48fb08cf4c2973013413f2726cdc5cf1ac6ac cacti-0.8.6i.tar.gz 1122700