summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Medinas <metalgod@gentoo.org>2006-10-30 04:25:48 +0000
committerLuis Medinas <metalgod@gentoo.org>2006-10-30 04:25:48 +0000
commit6ab13b19d215754a5a144a6cfb690caa92f15d97 (patch)
treebf499d29cd16cbbb13dbdc9132dc46b9367d9a07
parentStable on amd64 see bug #149851. (diff)
downloadgentoo-2-6ab13b19d215754a5a144a6cfb690caa92f15d97.tar.gz
gentoo-2-6ab13b19d215754a5a144a6cfb690caa92f15d97.tar.bz2
gentoo-2-6ab13b19d215754a5a144a6cfb690caa92f15d97.zip
Version Bump.
(Portage version: 2.1.2_rc1-r1)
-rw-r--r--net-im/tmsnc/ChangeLog9
-rw-r--r--net-im/tmsnc/files/digest-tmsnc-0.3.23
-rw-r--r--net-im/tmsnc/tmsnc-0.3.2.ebuild35
3 files changed, 45 insertions, 2 deletions
diff --git a/net-im/tmsnc/ChangeLog b/net-im/tmsnc/ChangeLog
index 215e207da0a9..bede90f85144 100644
--- a/net-im/tmsnc/ChangeLog
+++ b/net-im/tmsnc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/tmsnc
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/tmsnc/ChangeLog,v 1.5 2005/11/26 22:50:42 metalgod Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/tmsnc/ChangeLog,v 1.6 2006/10/30 04:25:47 metalgod Exp $
+
+*tmsnc-0.3.2 (30 Oct 2006)
+
+ 30 Oct 2006; Luis Medinas <metalgod@gentoo.org> +tmsnc-0.3.2.ebuild:
+ Version Bump.
*tmsnc-0.3.1 (26 Nov 2005)
diff --git a/net-im/tmsnc/files/digest-tmsnc-0.3.2 b/net-im/tmsnc/files/digest-tmsnc-0.3.2
new file mode 100644
index 000000000000..ade1b62e219f
--- /dev/null
+++ b/net-im/tmsnc/files/digest-tmsnc-0.3.2
@@ -0,0 +1,3 @@
+MD5 337dae91d4775e03b6681f61db56d2a7 tmsnc-0.3.2.tar.gz 200018
+RMD160 3beb8f7d7c2604d3866edc68423bf8afcfd2dfdb tmsnc-0.3.2.tar.gz 200018
+SHA256 7f54ba3974f45c0787b6d62d0d62ce352ddbf95419123b98b4969b97d3dfed23 tmsnc-0.3.2.tar.gz 200018
diff --git a/net-im/tmsnc/tmsnc-0.3.2.ebuild b/net-im/tmsnc/tmsnc-0.3.2.ebuild
new file mode 100644
index 000000000000..165e7457ac5d
--- /dev/null
+++ b/net-im/tmsnc/tmsnc-0.3.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/tmsnc/tmsnc-0.3.2.ebuild,v 1.1 2006/10/30 04:25:47 metalgod Exp $
+
+DESCRIPTION="TMSNC is a textbased MSN client written in C."
+HOMEPAGE="http://tmsnc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tmsnc/${P}.tar.gz"
+
+LICENSE="IRPDL"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="ssl talkfilters"
+
+DEPEND="virtual/libc
+ >=sys-libs/ncurses-5.4
+ ssl? ( >=dev-libs/openssl-0.9.7d )
+ talkfilters? ( >=app-text/talkfilters-2.3.4 )"
+
+src_compile() {
+ local myconf
+ use ssl \
+ || myconf="${myconf} --without-ssl"
+ use talkfilters \
+ || myconf="${myconf} --without-talkfilters"
+ econf ${myconf} || die "Configure failed"
+ emake || die "Make failed"
+}
+src_install() {
+ make DESTDIR=${D} install || die "Make install failed"
+ dodoc AUTHORS ChangeLog README NEWS
+}
+pkg_postinst() {
+ einfo "If you want talkfilters support you need to add"
+ einfo "USE=talkfilters to enable support in this package"
+}