summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2009-08-20 16:12:18 +0000
committerTony Vroon <chainsaw@gentoo.org>2009-08-20 16:12:18 +0000
commit6fb67777acd2685cda9fd1ede4561fe4bd53ea17 (patch)
treea4a4b4c125c2a4f920907751cafecc3ca194a1ee
parentTweak SRC_URI to include version (diff)
downloadgentoo-2-6fb67777acd2685cda9fd1ede4561fe4bd53ea17.tar.gz
gentoo-2-6fb67777acd2685cda9fd1ede4561fe4bd53ea17.tar.bz2
gentoo-2-6fb67777acd2685cda9fd1ede4561fe4bd53ea17.zip
With thanks to Ondrej Filip, the build system can now handle parallel make. This new release also improves portability and adds more-style paging to the client. The init-scripts have been reworked.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
-rw-r--r--net-misc/bird/ChangeLog11
-rw-r--r--net-misc/bird/bird-1.1.1.ebuild59
-rw-r--r--net-misc/bird/files/1.1.1-nostrip.patch15
-rw-r--r--net-misc/bird/files/initd-v4-bird-1.1.139
-rw-r--r--net-misc/bird/files/initd-v6-bird-1.1.139
5 files changed, 162 insertions, 1 deletions
diff --git a/net-misc/bird/ChangeLog b/net-misc/bird/ChangeLog
index bff206e1eca7..cd9fff9a7304 100644
--- a/net-misc/bird/ChangeLog
+++ b/net-misc/bird/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-misc/bird
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/bird/ChangeLog,v 1.3 2009/07/22 12:20:53 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bird/ChangeLog,v 1.4 2009/08/20 16:12:18 chainsaw Exp $
+
+*bird-1.1.1 (20 Aug 2009)
+
+ 20 Aug 2009; <chainsaw@gentoo.org> +files/1.1.1-nostrip.patch,
+ +files/initd-v4-bird-1.1.1, +files/initd-v6-bird-1.1.1,
+ +bird-1.1.1.ebuild:
+ With thanks to Ondrej Filip, the build system can now handle parallel
+ make. This new release also improves portability and adds more-style
+ paging to the client. The init-scripts have been reworked.
*bird-1.1.0 (22 Jul 2009)
diff --git a/net-misc/bird/bird-1.1.1.ebuild b/net-misc/bird/bird-1.1.1.ebuild
new file mode 100644
index 000000000000..bb7b1b9cb749
--- /dev/null
+++ b/net-misc/bird/bird-1.1.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bird/bird-1.1.1.ebuild,v 1.1 2009/08/20 16:12:18 chainsaw Exp $
+
+inherit eutils
+
+DESCRIPTION="A routing daemon implementing OSPF, RIPv2 & BGP for IPv4 or IPv6"
+HOMEPAGE="http://bird.network.cz"
+SRC_URI="ftp://bird.network.cz/pub/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug ipv6"
+
+RDEPEND="sys-libs/ncurses
+ sys-libs/readline
+ ${DEPEND}"
+DEPEND="sys-devel/flex
+ sys-devel/bison
+ sys-devel/m4"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-nostrip.patch"
+}
+
+src_compile() {
+ econf \
+ --enable-client \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ || die "Configuration stage failed"
+ emake || die "Compilation stage failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ if use ipv6; then
+ # The only thing worse then not supplying
+ # a sample configuration file to a user is
+ # wasting his/her time with a totally
+ # broken one.
+ rm "${D}/etc/bird6.conf"
+ newinitd "${FILESDIR}/initd-v6-${P}" bird6
+ else
+ newinitd "${FILESDIR}/initd-v4-${P}" bird
+ fi
+}
+
+pkg_postinst() {
+ if use ipv6; then
+ elog "Please note that only the IPv6 versions of the BIRD client & daemon have been installed."
+ else
+ elog "Please note that only the IPv4 versions of the BIRD client & daemon have been installed."
+ fi
+ elog "BIRDs build system is not currently suited to providing both."
+}
diff --git a/net-misc/bird/files/1.1.1-nostrip.patch b/net-misc/bird/files/1.1.1-nostrip.patch
new file mode 100644
index 000000000000..d3513ce90237
--- /dev/null
+++ b/net-misc/bird/files/1.1.1-nostrip.patch
@@ -0,0 +1,15 @@
+diff -uNr bird-1.1.1.ORIG/tools/Makefile.in bird-1.1.1/tools/Makefile.in
+--- bird-1.1.1.ORIG/tools/Makefile.in 2009-08-20 15:47:18.000000000 +0100
++++ bird-1.1.1/tools/Makefile.in 2009-08-20 15:47:40.000000000 +0100
+@@ -56,9 +56,9 @@
+
+ install: all
+ $(INSTALL) -d $(DESTDIR)/$(sbindir) $(DESTDIR)/$(sysconfdir) $(DESTDIR)/$(localstatedir)
+- $(INSTALL_PROGRAM) -s $(exedir)/bird $(DESTDIR)/$(sbindir)/bird@SUFFIX6@
++ $(INSTALL_PROGRAM) $(exedir)/bird $(DESTDIR)/$(sbindir)/bird@SUFFIX6@
+ if test -n "@CLIENT@" ; then \
+- $(INSTALL_PROGRAM) -s $(exedir)/birdc $(DESTDIR)/$(sbindir)/birdc@SUFFIX6@ ; \
++ $(INSTALL_PROGRAM) $(exedir)/birdc $(DESTDIR)/$(sbindir)/birdc@SUFFIX6@ ; \
+ fi
+ if ! test -f $(DESTDIR)/$(sysconfdir)/bird@SUFFIX6@.conf ; then \
+ $(INSTALL_DATA) $(srcdir)/doc/bird.conf.example $(DESTDIR)/$(sysconfdir)/bird@SUFFIX6@.conf ; \
diff --git a/net-misc/bird/files/initd-v4-bird-1.1.1 b/net-misc/bird/files/initd-v4-bird-1.1.1
new file mode 100644
index 000000000000..bb0f08f405b0
--- /dev/null
+++ b/net-misc/bird/files/initd-v4-bird-1.1.1
@@ -0,0 +1,39 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bird/files/initd-v4-bird-1.1.1,v 1.1 2009/08/20 16:12:18 chainsaw Exp $
+
+EXE=bird
+CLI=birdc
+SOCK="/var/lib/run/${EXE}.ctl"
+
+depend() {
+ need net
+ use logger
+}
+
+checkconfig() {
+ if [ ! -f "/etc/${EXE}.conf" ]; then
+ eerror "Please create /etc/${EXE}.conf"
+ return 1
+ fi
+ return 0
+}
+
+start() {
+ checkconfig || return $?
+
+ ebegin "Starting BIRD"
+ "/usr/sbin/${EXE}" -c "/etc/${EXE}.conf" -s "${SOCK}"
+ eend $? "Failed to start BIRD"
+}
+
+stop() {
+ ebegin "Stopping BIRD"
+ if [ -f "${SOCK}" ]; then
+ echo "down" | "/usr/sbin/${CLI}" -s "${SOCK}" &>/dev/null
+ eend $? "Failed to stop BIRD"
+ else
+ eend 0
+ fi
+}
diff --git a/net-misc/bird/files/initd-v6-bird-1.1.1 b/net-misc/bird/files/initd-v6-bird-1.1.1
new file mode 100644
index 000000000000..a74513b856f3
--- /dev/null
+++ b/net-misc/bird/files/initd-v6-bird-1.1.1
@@ -0,0 +1,39 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bird/files/initd-v6-bird-1.1.1,v 1.1 2009/08/20 16:12:18 chainsaw Exp $
+
+EXE=bird6
+CLI=birdc6
+SOCK="/var/lib/run/${EXE}.ctl"
+
+depend() {
+ need net
+ use logger
+}
+
+checkconfig() {
+ if [ ! -f "/etc/${EXE}.conf" ]; then
+ eerror "Please create /etc/${EXE}.conf"
+ return 1
+ fi
+ return 0
+}
+
+start() {
+ checkconfig || return $?
+
+ ebegin "Starting BIRD"
+ "/usr/sbin/${EXE}" -c "/etc/${EXE}.conf" -s "${SOCK}"
+ eend $? "Failed to start BIRD"
+}
+
+stop() {
+ ebegin "Stopping BIRD"
+ if [ -f "${SOCK}" ]; then
+ echo "down" | "/usr/sbin/${CLI}" -s "${SOCK}" &>/dev/null
+ eend $? "Failed to stop BIRD"
+ else
+ eend 0
+ fi
+}