summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-04-03 04:03:00 +0000
committerPeter Volkov <pva@gentoo.org>2008-04-03 04:03:00 +0000
commit715ba50c0d051f226ed88a32a0a393561e914643 (patch)
treec926bdc1297d4a31f45807b9708e6739066cc9cf
parentwhitespace (diff)
downloadgentoo-2-715ba50c0d051f226ed88a32a0a393561e914643.tar.gz
gentoo-2-715ba50c0d051f226ed88a32a0a393561e914643.tar.bz2
gentoo-2-715ba50c0d051f226ed88a32a0a393561e914643.zip
Fixed build with profile USE flag and -fomit-frame-pointer, bug #215806, thank Joel Thompson for report and Mikael Magnusson for solution.
(Portage version: 2.1.4.4)
-rw-r--r--net-analyzer/wireshark/ChangeLog6
-rw-r--r--net-analyzer/wireshark/wireshark-1.0.0.ebuild5
2 files changed, 9 insertions, 2 deletions
diff --git a/net-analyzer/wireshark/ChangeLog b/net-analyzer/wireshark/ChangeLog
index 8c4600026c70..07aaed9be587 100644
--- a/net-analyzer/wireshark/ChangeLog
+++ b/net-analyzer/wireshark/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/wireshark
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.97 2008/04/02 17:30:12 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.98 2008/04/03 04:03:00 pva Exp $
+
+ 03 Apr 2008; Peter Volkov <pva@gentoo.org> wireshark-1.0.0.ebuild:
+ Fixed build with profile USE flag and -fomit-frame-pointer, bug #215806,
+ thank Joel Thompson for report and Mikael Magnusson for solution.
02 Apr 2008; Markus Rothe <corsair@gentoo.org> wireshark-1.0.0.ebuild:
Stable on ppc64; bug #215276
diff --git a/net-analyzer/wireshark/wireshark-1.0.0.ebuild b/net-analyzer/wireshark/wireshark-1.0.0.ebuild
index 447933e35cdd..48a93e0f6d22 100644
--- a/net-analyzer/wireshark/wireshark-1.0.0.ebuild
+++ b/net-analyzer/wireshark/wireshark-1.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.0.0.ebuild,v 1.6 2008/04/02 17:30:12 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.0.0.ebuild,v 1.7 2008/04/03 04:03:00 pva Exp $
EAPI=1
WANT_AUTOMAKE="1.9"
@@ -84,6 +84,9 @@ src_compile() {
# our hardened toolchain bug
filter-flags -fstack-protector
+ # profile and -fomit-frame-pointer are incompatible, bug #215806
+ use profile && filter-flags -fomit-frame-pointer
+
local myconf
if use gtk; then
einfo "Building with gtk support"