summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-04-19 19:54:42 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-04-19 19:54:42 +0000
commit7a31b5804944168d0fe0d9a7b4922974e3c9efcf (patch)
treeef33f3d46783b9ac88d6a8eaffa9f58cda3260a3
parentAdd missing fdi matching rules to spec file. Implemented missing double match... (diff)
downloadgentoo-2-7a31b5804944168d0fe0d9a7b4922974e3c9efcf.tar.gz
gentoo-2-7a31b5804944168d0fe0d9a7b4922974e3c9efcf.tar.bz2
gentoo-2-7a31b5804944168d0fe0d9a7b4922974e3c9efcf.zip
Fix NOSHORTLANG variable, bug 175236
(Portage version: 2.1.2.4)
-rw-r--r--mail-client/mozilla-thunderbird-bin/ChangeLog6
-rw-r--r--mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-2.0.0.0.ebuild61
2 files changed, 40 insertions, 27 deletions
diff --git a/mail-client/mozilla-thunderbird-bin/ChangeLog b/mail-client/mozilla-thunderbird-bin/ChangeLog
index a97f1e27965d..f9e06b44f204 100644
--- a/mail-client/mozilla-thunderbird-bin/ChangeLog
+++ b/mail-client/mozilla-thunderbird-bin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-client/mozilla-thunderbird-bin
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird-bin/ChangeLog,v 1.70 2007/04/18 22:01:11 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird-bin/ChangeLog,v 1.71 2007/04/19 19:54:42 armin76 Exp $
+
+ 19 Apr 2007; Raúl Porcel <armin76@gentoo.org>
+ mozilla-thunderbird-bin-2.0.0.0.ebuild:
+ Fix NOSHORTLANG variable, bug 175236
*mozilla-thunderbird-bin-2.0.0.0 (18 Apr 2007)
diff --git a/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-2.0.0.0.ebuild b/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-2.0.0.0.ebuild
index e38d08f2d0d2..d1a831d7ed29 100644
--- a/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-2.0.0.0.ebuild
+++ b/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-2.0.0.0.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-2.0.0.0.ebuild,v 1.1 2007/04/18 22:01:11 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-2.0.0.0.ebuild,v 1.2 2007/04/19 19:54:42 armin76 Exp $
inherit eutils mozilla-launcher multilib mozextension
LANGS="be bg ca cs da de el en-GB es-AR es-ES eu fi fr ga-IE hu it ja lt mk nb-NO nl pa-IN pl pt-BR pt-PT ru sk sl sv-SE tr zh-CN zh-TW"
-SHORTLANGS="es-ES nb-NO pt-BR sv-SE zh-TW"
+NOSHORTLANGS="en-GB es-AR pt-BR zh-TW"
DESCRIPTION="The Mozilla Thunderbird Mail & News Reader"
SRC_URI="http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/${PV}/linux-i686/en-US/thunderbird-${PV}.tar.gz"
@@ -23,7 +23,7 @@ for X in ${LANGS} ; do
done
for X in ${SHORTLANGS} ; do
- SRC_URI="${SRC_URI} linguas_${X%%-*}? ( http://dev.gentooexperimental.org/~armin76/dist/${P/-bin}-xpi//${P/-bin}-${X}.xpi )"
+ SRC_URI="${SRC_URI} linguas_${X%%-*}? ( http://dev.gentooexperimental.org/~armin76/dist/${P/-bin}-xpi//${P/-bin/}-${X}.xpi )"
IUSE="${IUSE} linguas_${X%%-*}"
done
@@ -44,37 +44,46 @@ RDEPEND="x11-libs/libXrender
S=${WORKDIR}/thunderbird
+for X in ${LANGS} ; do
+ SRC_URI="${SRC_URI}
+ linguas_${X/-/_}? ( http://dev.gentooexperimental.org/~armin76/dist/${P}-xpi/${P/-bin/}-${X}.xpi )"
+ IUSE="${IUSE} linguas_${X/-/_}"
+ # english is handled internally
+ if [ "${#X}" == 5 ] && ! has ${X} ${NOSHORTLANGS}; then
+ SRC_URI="${SRC_URI}
+ linguas_${X%%-*}? ( http://dev.gentooexperimental.org/~armin76/dist/${P}-xpi/${P/-bin}-${X}.xpi )"
+ IUSE="${IUSE} linguas_${X%%-*}"
+ fi
+done
+
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
+
linguas() {
- linguas=
- local LANG
+ local LANG SLANG
for LANG in ${LINGUAS}; do
- if hasq ${LANG} en en_US; then
- hasq en ${linguas} || \
- linguas="${linguas:+"${linguas} "}en"
+ if has ${LANG} en en_US; then
+ has en ${linguas} || linguas="${linguas:+"${linguas} "}en"
continue
- elif hasq ${LANG} ${LANGS//-/_}; then
- hasq ${LANG//_/-} ${linguas} || \
- linguas="${linguas:+"${linguas} "}${LANG//_/-}"
+ elif has ${LANG} ${LANGS//-/_}; then
+ has ${LANG//_/-} ${linguas} || linguas="${linguas:+"${linguas} "}${LANG//_/-}"
continue
- else
- local SLANG
- for SLANG in ${SHORTLANGS}; do
- if [[ ${LANG} == ${SLANG%%-*} ]]; then
- hasq ${SLANG} ${linguas} || \
- linguas="${linguas:+"${linguas} "}${SLANG}"
+ elif [[ " ${LANGS} " == *" ${LANG}-"* ]]; then
+ for X in ${LANGS}; do
+ if [[ "${X}" == "${LANG}-"* ]] && \
+ [[ " ${NOSHORTLANGS} " != *" ${X} "* ]]; then
+ has ${X} ${linguas} || linguas="${linguas:+"${linguas} "}${X}"
continue 2
fi
done
fi
- ewarn "Sorry, but mozilla-thunderbird does not support the ${LANG} LINGUA"
+ ewarn "Sorry, but mozilla-firefox does not support the ${LANG} LINGUA"
done
-}
-
-pkg_setup() {
- # This is a binary x86 package => ABI=x86
- # Please keep this in future versions
- # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
- has_multilib_profile && ABI="x86"
+ einfo "Selected language packs (first will be default): $linguas"
}
src_unpack() {
@@ -146,4 +155,4 @@ pkg_postinst() {
pkg_postrm() {
update_mozilla_launcher_symlinks
-}
+} \ No newline at end of file