summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-02-18 16:53:40 +0000
committerWilliam Hubbs <williamh@gentoo.org>2015-02-18 16:53:40 +0000
commit7ad3c71f5d6916dc5cfee21296fc8396fa8f3466 (patch)
treeb9a78fd0d6ee01d6c687996afe93f423fb9d63d5
parentSync metadata (diff)
downloadgentoo-2-7ad3c71f5d6916dc5cfee21296fc8396fa8f3466.tar.gz
gentoo-2-7ad3c71f5d6916dc5cfee21296fc8396fa8f3466.tar.bz2
gentoo-2-7ad3c71f5d6916dc5cfee21296fc8396fa8f3466.zip
remove old versions
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 0x30C46538)
-rw-r--r--dev-lang/go/ChangeLog6
-rw-r--r--dev-lang/go/go-1.3.3.ebuild143
-rw-r--r--dev-lang/go/go-1.4.ebuild120
3 files changed, 5 insertions, 264 deletions
diff --git a/dev-lang/go/ChangeLog b/dev-lang/go/ChangeLog
index 043a5b199137..4c49a0f1922f 100644
--- a/dev-lang/go/ChangeLog
+++ b/dev-lang/go/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/go
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/ChangeLog,v 1.67 2015/02/17 21:03:49 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/ChangeLog,v 1.68 2015/02/18 16:53:40 williamh Exp $
+
+ 18 Feb 2015; William Hubbs <williamh@gentoo.org> -go-1.3.3.ebuild,
+ -go-1.4.ebuild:
+ remove old versions
17 Feb 2015; Markus Meier <maekke@gentoo.org> go-1.4.1.ebuild:
arm stable, bug #539280
diff --git a/dev-lang/go/go-1.3.3.ebuild b/dev-lang/go/go-1.3.3.ebuild
deleted file mode 100644
index 0789eba0a32d..000000000000
--- a/dev-lang/go/go-1.3.3.ebuild
+++ /dev/null
@@ -1,143 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-1.3.3.ebuild,v 1.8 2014/12/12 18:23:32 williamh Exp $
-
-EAPI=5
-
-export CTARGET=${CTARGET:-${CHOST}}
-
-inherit bash-completion-r1 elisp-common toolchain-funcs eutils
-
-if [[ ${PV} = 9999 ]]; then
- EHG_REPO_URI="https://go.googlecode.com/hg"
- inherit mercurial
-else
- SRC_URI="https://storage.googleapis.com/golang/go${PV}.src.tar.gz"
- # Upstream only supports go on amd64, arm and x86 architectures.
- KEYWORDS="-* amd64 arm x86 ~amd64-fbsd ~x86-fbsd ~x64-macos ~x86-macos"
-fi
-
-DESCRIPTION="A concurrent garbage collected and typesafe programming language"
-HOMEPAGE="http://www.golang.org"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="emacs vim-syntax zsh-completion"
-
-DEPEND=""
-RDEPEND="emacs? ( virtual/emacs )
- vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
- zsh-completion? ( app-shells/gentoo-zsh-completions )"
-
-# The tools in /usr/lib/go should not cause the multilib-strict check to fail.
-QA_MULTILIB_PATHS="usr/lib/go/pkg/tool/.*/.*"
-
-# The go language uses *.a files which are _NOT_ libraries and should not be
-# stripped.
-STRIP_MASK="/usr/lib/go/pkg/linux*/*.a /usr/lib/go/pkg/freebsd*/*.a /usr/lib/go/pkg/darwin*/*.a"
-
-if [[ ${PV} != 9999 ]]; then
- S="${WORKDIR}"/go
-fi
-
-src_prepare()
-{
- if [[ ${PV} != 9999 ]]; then
- epatch "${FILESDIR}"/${PN}-1.2-no-Werror.patch
- fi
- epatch_user
-}
-
-src_compile()
-{
- export GOROOT_FINAL="${EPREFIX}"/usr/lib/go
- export GOROOT="$(pwd)"
- export GOBIN="${GOROOT}/bin"
- if [[ $CTARGET = armv5* ]]
- then
- export GOARM=5
- fi
- tc-export CC
-
- cd src
- ./make.bash || die "build failed"
- cd ..
-
- if use emacs; then
- elisp-compile misc/emacs/*.el
- fi
-}
-
-src_test()
-{
- cd src
- PATH="${GOBIN}:${PATH}" \
- ./run.bash --no-rebuild --banner || die "tests failed"
-}
-
-src_install()
-{
- dobin bin/*
- dodoc AUTHORS CONTRIBUTORS PATENTS README
-
- dodir /usr/lib/go
- insinto /usr/lib/go
-
- # There is a known issue which requires the source tree to be installed [1].
- # Once this is fixed, we can consider using the doc use flag to control
- # installing the doc and src directories.
- # [1] https://golang.org/issue/2775
- doins -r doc include lib pkg src
-
- dobashcomp misc/bash/go
- bashcomp_alias go {5,6,8}{g,l} gccgo gofmt
-
- if use emacs; then
- elisp-install ${PN} misc/emacs/*.el misc/emacs/*.elc
- fi
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles
- doins -r misc/vim/ftdetect
- doins -r misc/vim/ftplugin
- doins -r misc/vim/syntax
- doins -r misc/vim/plugin
- doins -r misc/vim/indent
- fi
-
- if use zsh-completion; then
- insinto /usr/share/zsh/site-functions
- doins misc/zsh/go
- fi
-
- fperms -R +x /usr/lib/go/pkg/tool
-}
-
-pkg_postinst()
-{
- if use emacs; then
- elisp-site-regen
- fi
-
- # If the go tool sees a package file timestamped older than a dependancy it
- # will rebuild that file. So, in order to stop go from rebuilding lots of
- # packages for every build we need to fix the timestamps. The compiler and
- # linker are also checked - so we need to fix them too.
- ebegin "fixing timestamps to avoid unnecessary rebuilds"
- tref="usr/lib/go/pkg/*/runtime.a"
- find "${EROOT}"usr/lib/go -type f \
- -exec touch -r "${EROOT}"${tref} {} \;
- eend $?
-
- if [[ ${PV} != 9999 && -n ${REPLACING_VERSIONS} &&
- ${REPLACING_VERSIONS} != ${PV} ]]; then
- elog "Release notes are located at http://golang.org/doc/go${PV}"
- fi
-}
-
-pkg_postrm()
-{
- if use emacs; then
- elisp-site-regen
- fi
-}
diff --git a/dev-lang/go/go-1.4.ebuild b/dev-lang/go/go-1.4.ebuild
deleted file mode 100644
index 7209d14af984..000000000000
--- a/dev-lang/go/go-1.4.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-1.4.ebuild,v 1.5 2015/01/08 20:49:58 maekke Exp $
-
-EAPI=5
-
-export CTARGET=${CTARGET:-${CHOST}}
-
-inherit eutils toolchain-funcs
-
-if [[ ${PV} = 9999 ]]; then
- EHG_REPO_URI="https://go.googlecode.com/hg"
- inherit mercurial
-else
- SRC_URI="https://storage.googleapis.com/golang/go${PV}.src.tar.gz"
- # Upstream only supports go on amd64, arm and x86 architectures.
- KEYWORDS="-* amd64 arm ~x86 ~amd64-fbsd ~x86-fbsd ~x64-macos ~x86-macos"
-fi
-
-DESCRIPTION="A concurrent garbage collected and typesafe programming language"
-HOMEPAGE="http://www.golang.org"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-# The tools in /usr/lib/go should not cause the multilib-strict check to fail.
-QA_MULTILIB_PATHS="usr/lib/go/pkg/tool/.*/.*"
-
-# The go language uses *.a files which are _NOT_ libraries and should not be
-# stripped.
-STRIP_MASK="/usr/lib/go/pkg/linux*/*.a /usr/lib/go/pkg/freebsd*/*.a /usr/lib/go/pkg/darwin*/*.a"
-
-if [[ ${PV} != 9999 ]]; then
- S="${WORKDIR}"/go
-fi
-
-src_prepare()
-{
- if [[ ${PV} != 9999 ]]; then
- epatch "${FILESDIR}"/${PN}-1.2-no-Werror.patch
- fi
- epatch_user
-}
-
-src_compile()
-{
- export GOROOT_FINAL="${EPREFIX}"/usr/lib/go
- export GOROOT="$(pwd)"
- export GOBIN="${GOROOT}/bin"
- if [[ $CTARGET = armv5* ]]
- then
- export GOARM=5
- fi
- tc-export CC
-
- cd src
- ./make.bash || die "build failed"
-}
-
-src_test()
-{
- cd src
- PATH="${GOBIN}:${PATH}" \
- ./run.bash --no-rebuild --banner || die "tests failed"
-}
-
-src_install()
-{
- dobin bin/*
- dodoc AUTHORS CONTRIBUTORS PATENTS README
-
- dodir /usr/lib/go
- insinto /usr/lib/go
-
- # There is a known issue which requires the source tree to be installed [1].
- # Once this is fixed, we can consider using the doc use flag to control
- # installing the doc and src directories.
- # [1] https://golang.org/issue/2775
- doins -r doc include lib pkg src
- fperms -R +x /usr/lib/go/pkg/tool
-}
-
-pkg_preinst()
-{
- has_version '<dev-lang/go-1.4' &&
- export had_support_files=true ||
- export had_support_files=false
-}
-
-pkg_postinst()
-{
- # If the go tool sees a package file timestamped older than a dependancy it
- # will rebuild that file. So, in order to stop go from rebuilding lots of
- # packages for every build we need to fix the timestamps. The compiler and
- # linker are also checked - so we need to fix them too.
- ebegin "fixing timestamps to avoid unnecessary rebuilds"
- tref="usr/lib/go/pkg/*/runtime.a"
- find "${EROOT}"usr/lib/go -type f \
- -exec touch -r "${EROOT}"${tref} {} \;
- eend $?
-
- if [[ ${PV} != 9999 && -n ${REPLACING_VERSIONS} &&
- ${REPLACING_VERSIONS} != ${PV} ]]; then
- elog "Release notes are located at http://golang.org/doc/go${PV}"
- fi
-
- if $had_support_files; then
- ewarn
- ewarn "All editor support, IDE support, shell completion"
- ewarn "support, etc has been removed from the go package"
- ewarn "upstream."
- ewarn "For more information on which support is available, see"
- ewarn "the following URL:"
- ewarn "https://github.com/golang/go/wiki/IDEsAndTextEditorPlugins"
- fi
-}