summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-08-24 21:11:43 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-08-24 21:11:43 +0000
commit82b296ecfa80397c47d30a5ae98e647c944b34d4 (patch)
tree8a282c83cfdec26522423f79383931de93d7b31c
parentUpdate to Linux 2.6.17.11. Fix some ultrasparc issues. Fix alpha EV56 Kconfig... (diff)
downloadgentoo-2-82b296ecfa80397c47d30a5ae98e647c944b34d4.tar.gz
gentoo-2-82b296ecfa80397c47d30a5ae98e647c944b34d4.tar.bz2
gentoo-2-82b296ecfa80397c47d30a5ae98e647c944b34d4.zip
Version bump. This closes bug #144314.
(Portage version: 2.1.1_pre5-r3)
-rw-r--r--sci-libs/blas-atlas/ChangeLog9
-rw-r--r--sci-libs/blas-atlas/blas-atlas-3.7.15.ebuild136
-rw-r--r--sci-libs/blas-atlas/files/digest-blas-atlas-3.6.02
-rw-r--r--sci-libs/blas-atlas/files/digest-blas-atlas-3.7.156
4 files changed, 152 insertions, 1 deletions
diff --git a/sci-libs/blas-atlas/ChangeLog b/sci-libs/blas-atlas/ChangeLog
index 462674317563..f1d92dfaca32 100644
--- a/sci-libs/blas-atlas/ChangeLog
+++ b/sci-libs/blas-atlas/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/blas-atlas
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/ChangeLog,v 1.32 2006/08/20 22:51:02 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/ChangeLog,v 1.33 2006/08/24 21:11:43 markusle Exp $
+
+*blas-atlas-3.7.15 (22 Aug 2006)
+
+ 22 Aug 2006; Markus Dittrich <markusle@gentoo.org>
+ +blas-atlas-3.7.15.ebuild:
+ Version bump. Thanks much to Adam Piatyszek <ediap@et.put.poznan.pl>
+ for his ebuild and patches. This closes bug #144314.
20 Aug 2006; Donnie Berkholz <dberkholz@gentoo.org>;
-blas-atlas-3.7.10.ebuild:
diff --git a/sci-libs/blas-atlas/blas-atlas-3.7.15.ebuild b/sci-libs/blas-atlas/blas-atlas-3.7.15.ebuild
new file mode 100644
index 000000000000..21b2066432f3
--- /dev/null
+++ b/sci-libs/blas-atlas/blas-atlas-3.7.15.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.7.15.ebuild,v 1.1 2006/08/24 21:11:43 markusle Exp $
+
+inherit eutils toolchain-funcs fortran
+
+DESCRIPTION="Automatically Tuned Linear Algebra Software BLAS implementation"
+HOMEPAGE="http://math-atlas.sourceforge.net/"
+MY_PN=${PN/blas-/}
+SRC_URI="mirror://sourceforge/math-atlas/${MY_PN}${PV}.tar.bz2
+ mirror://gentoo/${MY_PN}-${PV}-shared-libs.patch.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+
+RDEPEND="app-admin/eselect-blas
+ app-admin/eselect-cblas"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-1.5"
+PROVIDE="virtual/blas"
+
+
+S="${WORKDIR}/ATLAS"
+BLD_DIR="${S}/gentoo-build"
+RPATH="${DESTTREE}/$(get_libdir)/blas"
+FORTRAN="g77 gfortran"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch "${DISTDIR}"/${MY_PN}-${PV}-shared-libs.patch.bz2
+
+ # make sure shared libs link against proper libraries
+ if [[ ${FORTRANC} == "gfortran" ]]; then
+ libs="${LDFLAGS} -lpthread -lgfortran"
+ else
+ libs="${LDFLAGS} -lpthread -lg2c"
+ fi
+ sed -e "s/SHRD_LNK/${libs}/g" -i Make.top || \
+ die "Failed to add addtional libs to shared object build"
+
+ mkdir ${BLD_DIR} || die "failed to generate build directory"
+ cp "${FILESDIR}"/war ${BLD_DIR} && chmod a+x ${BLD_DIR}/war || \
+ die "failed to install war"
+
+ cd ${BLD_DIR} && ../configure || die "configure failed"
+
+ sed -e "s:GENTOO_GCC:$(tc-getCC):" \
+ -e "s:GENTOO_FORTRAN:${FORTRANC}:" \
+ -e "s:GENTOO_CFLAGS:${CFLAGS}:" \
+ -e "s:GENTOO_FFLAGS:${FFLAGS}:" \
+ -i Make.inc || die "Failed to fix Make.inc"
+}
+
+src_compile() {
+ cd ${BLD_DIR}
+ make || die "make failed"
+
+ make shared-strip RPATH=${RPATH}/atlas || \
+ die "failed to build shared libraries"
+
+ # build shared libraries of threaded libraries if applicable
+ if [ -d gentoo/libptf77blas.a ]; then
+ make ptshared-strip RPATH=${RPATH}/threaded-atlas || \
+ die "failed to build threaded shared libraries"
+ fi
+}
+
+src_install () {
+ dodir "${RPATH}"/atlas
+ cd ${BLD_DIR}/gentoo/libs
+ cp -P libatlas* "${D}/${DESTTREE}/$(get_libdir)" || \
+ die "Failed to install libatlas"
+ cp -P *blas* "${D}/${RPATH}"/atlas || \
+ die "Failed to install blas/cblas"
+
+ eselect blas add $(get_libdir) ${FILESDIR}/eselect.blas atlas
+ eselect cblas add $(get_libdir) ${FILESDIR}/eselect.cblas atlas
+
+ if [ -d ${BLD_DIR}/gentoo/threaded-libs ]
+ then
+ dodir "${RPATH}"/threaded-atlas
+ cd ${BLD_DIR}/gentoo/threaded-libs
+ cp -P * "${D}/${RPATH}"/threaded-atlas || \
+ die "Failed to install threaded atlas"
+
+ eselect blas add $(get_libdir) ${FILESDIR}/eselect.blas-threaded threaded-atlas
+ eselect cblas add $(get_libdir) ${FILESDIR}/eselect.cblas-threaded threaded-atlas
+ fi
+
+ insinto "${DESTTREE}"/include/atlas
+ doins "${S}"/include/cblas.h "${S}"/include/atlas_misc.h \
+ "${S}"/include/atlas_enum.h || \
+ die "failed to install headers"
+
+ # These headers contain the architecture-specific
+ # optimizations determined by ATLAS. The atlas-lapack build
+ # is much shorter if they are available, so save them:
+ doins ${BLD_DIR}/include/*.h || \
+ die "failed to install timing headers"
+
+ #some docs
+ cd "${S}"
+ dodoc README doc/{AtlasCredits.txt,ChangeLog}
+ use doc && dodoc doc/*.ps
+}
+
+pkg_postinst() {
+ local THREADED
+
+ if [ -d "${RPATH}"/threaded-atlas ]
+ then
+ THREADED="threaded-"
+ fi
+ if [[ -z "$(eselect blas show)" ]]; then
+ eselect blas set ${THREADED}atlas
+ fi
+ if [[ -z "$(eselect cblas show)" ]]; then
+ eselect cblas set ${THREADED}atlas
+ fi
+
+ elog
+ elog "Fortran users link using -lblas"
+ elog
+ elog "C users compile against the header ${ROOT}usr/include/atlas/cblas.h and"
+ elog "link using -lcblas"
+ elog
+ elog "If using threaded ATLAS, you may also need to link with -lpthread."
+ elog
+ elog "Configuration now uses eselect rather than blas-config."
+}
diff --git a/sci-libs/blas-atlas/files/digest-blas-atlas-3.6.0 b/sci-libs/blas-atlas/files/digest-blas-atlas-3.6.0
index be47e7d9047e..fdb440936204 100644
--- a/sci-libs/blas-atlas/files/digest-blas-atlas-3.6.0
+++ b/sci-libs/blas-atlas/files/digest-blas-atlas-3.6.0
@@ -1,4 +1,6 @@
MD5 743b75ec473ab0f0edda6b649aa89060 atlas3.6.0-shared-libs.patch.bz2 5140
+RMD160 2c266377cd60b24b7710fcf1d6d4be9c32797d64 atlas3.6.0-shared-libs.patch.bz2 5140
+SHA256 6fd8281d42de14d34e4f1e25cb9f4b142f6e66c8dc1030763761f8033eb38e89 atlas3.6.0-shared-libs.patch.bz2 5140
MD5 df2ee2eb65d1c08ee93d04370172c262 atlas3.6.0.tar.bz2 1687723
RMD160 e7d40a6677ce7c4442df7152150aecf812020713 atlas3.6.0.tar.bz2 1687723
SHA256 1c2ad68fe3c66e261c012788fc1b6f74eada791f713848a3a6420c50fa35c8e8 atlas3.6.0.tar.bz2 1687723
diff --git a/sci-libs/blas-atlas/files/digest-blas-atlas-3.7.15 b/sci-libs/blas-atlas/files/digest-blas-atlas-3.7.15
new file mode 100644
index 000000000000..b84cc52e0464
--- /dev/null
+++ b/sci-libs/blas-atlas/files/digest-blas-atlas-3.7.15
@@ -0,0 +1,6 @@
+MD5 f5a15706c7d8ec415b3030883b091f32 atlas-3.7.15-shared-libs.patch.bz2 6709
+RMD160 222a6e4faad05392e7c92cb3378c006da55c52f7 atlas-3.7.15-shared-libs.patch.bz2 6709
+SHA256 115caaca8fda4c187893ba3ee9f7194eac0c6344dc186be4bf2789c1aa7a728e atlas-3.7.15-shared-libs.patch.bz2 6709
+MD5 6fdfd37faaed7047e7a781a09fd050e9 atlas3.7.15.tar.bz2 1728282
+RMD160 7965ee554d197ce07bca68805cd7ed126b5abb0a atlas3.7.15.tar.bz2 1728282
+SHA256 33c461a3e34b26e6b2aa7414d2fd52a1d7dc9e7f9ec5513969aeb36d80b3c27b atlas3.7.15.tar.bz2 1728282