summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2006-01-02 22:34:34 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2006-01-02 22:34:34 +0000
commit886a9a20453cdca85aceb3da0dde121b89208270 (patch)
treea079b0a37b237815ff8e708e52c6d39f36d8794a
parent1.0.9 stable sparc. Cleaned out old versions. (diff)
downloadgentoo-2-886a9a20453cdca85aceb3da0dde121b89208270.tar.gz
gentoo-2-886a9a20453cdca85aceb3da0dde121b89208270.tar.bz2
gentoo-2-886a9a20453cdca85aceb3da0dde121b89208270.zip
1.0.9b stable sparc. Removing old versions.
(Portage version: 2.0.53)
-rw-r--r--media-sound/alsa-driver/ChangeLog7
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.10_rc2.ebuild158
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.3.ebuild6
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.8.ebuild171
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.9b.ebuild6
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-1.0.10_rc21
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-1.0.81
7 files changed, 12 insertions, 338 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index 55e3a309fb85..80ff77dd3b1b 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.179 2006/01/02 13:57:45 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.180 2006/01/02 22:34:34 eradicator Exp $
+
+ 02 Jan 2006; Jeremy Huddleston <eradicator@gentoo.org>
+ alsa-driver-1.0.3.ebuild, -alsa-driver-1.0.8.ebuild,
+ alsa-driver-1.0.9b.ebuild, -alsa-driver-1.0.10_rc2.ebuild:
+ 1.0.9b stable sparc. Removing old versions.
*alsa-driver-1.0.11_rc2 (02 Jan 2006)
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.10_rc2.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.10_rc2.ebuild
deleted file mode 100644
index 791599fb54b4..000000000000
--- a/media-sound/alsa-driver/alsa-driver-1.0.10_rc2.ebuild
+++ /dev/null
@@ -1,158 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.10_rc2.ebuild,v 1.7 2005/11/15 11:22:45 flameeyes Exp $
-
-inherit linux-mod flag-o-matic eutils
-
-MY_P="${P/_rc/rc}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
-HOMEPAGE="http://www.alsa-project.org/"
-SRC_URI="mirror://alsaproject/driver/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-
-KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 x86"
-IUSE="oss doc"
-
-RDEPEND="virtual/modutils
- ~media-sound/alsa-headers-${PV}"
-DEPEND="${RDEPEND}
- virtual/linux-sources
- sparc? ( >=sys-devel/autoconf-2.50 )
- sys-apps/debianutils"
-
-PROVIDE="virtual/alsa"
-
-pkg_setup() {
- # By default, drivers for all supported cards will be compiled.
- # If you want to only compile for specific card(s), set ALSA_CARDS
- # environment to a space-separated list of drivers that you want to build.
- # For example:
- #
- # env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
- #
- ALSA_CARDS=${ALSA_CARDS:-all}
-
- # Which drivers need PNP
- local PNP_DRIVERS="interwave interwave-stb"
-
- CONFIG_CHECK="SOUND"
- SND_ERROR="ALSA is already compiled into the kernel."
- SOUND_ERROR="Your kernel doesn't have sound support enabled."
- SOUND_PRIME_ERROR="Your kernel is configured to use the deprecated OSS drivers. Please disable them and re-emerge alsa-driver."
- PNP_ERROR="Some of the drivers you selected require PNP in your kernel (${PNP_DRIVERS}). Either enable PNP in your kernel or trim which drivers get compiled using ALSA_CARDS in /etc/make.conf."
-
- if [[ "${ALSA_CARDS}" == "all" ]]; then
- CONFIG_CHECK="${CONFIG_CHECK} PNP"
- else
- for pnpdriver in ${PNP_DRIVERS}; do
- hasq ${pnpdriver} ${ALSA_CARDS} && CONFIG_CHECK="${CONFIG_CHECK} PNP"
- done
- fi
-
- linux-mod_pkg_setup
-
- if [[ ${PROFILE_ARCH} == "sparc64" ]] ; then
- CBUILD=${CBUILD-${CHOST}}
- CHOST="sparc64-unknown-linux-gnu"
- fi
-}
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
-
- epatch "${FILESDIR}"/${PN}-1.0.10_rc1-include.patch
- epatch "${FILESDIR}"/${P}-audigy2zs.patch
- convert_to_m ${S}/Makefile
- sed -i -e 's:\(.*depmod\):#\1:' ${S}/Makefile
-}
-
-src_compile() {
- # Should fix bug #46901
- is-flag "-malign-double" && filter-flags "-fomit-frame-pointer"
- append-flags "-I${KV_DIR}/arch/$(tc-arch-kernel)/include"
-
- econf $(use_with oss) \
- --with-kernel="${KV_DIR}" \
- --with-build="${KV_OUT_DIR}" \
- --with-isapnp=yes \
- --with-sequencer=yes \
- --with-cards="${ALSA_CARDS}" || die "econf failed"
-
- # linux-mod_src_compile doesn't work well with alsa
-
- # -j1 : see bug #71028
- ARCH=$(tc-arch-kernel)
- emake -j1 HOSTCC=$(tc-getBUILD_CC) CC=$(tc-getCC) || die "Make Failed"
- ARCH=$(tc-arch)
-
- if use doc;
- then
- ebegin "Building Documentation"
- cd ${S}/scripts
- emake || die Failed making docs in ${S}/scripts
-
- cd ${S}/doc/DocBook
- emake || die Failed making docs in ${S}/doc/DocBook
- eend $?
- fi
-}
-
-
-src_install() {
- make DESTDIR=${D} install-modules || die "make install failed"
-
- dodoc CARDS-STATUS FAQ README WARNING TODO
-
- if use doc; then
- docinto doc
- dodoc doc/*
- rm ${D}/usr/share/doc/${PF}/doc/Makefile.gz
-
- docinto DocBook
- dodoc doc/DocBook/*
- rm ${D}/usr/share/doc/${PF}/DocBook/Makefile.gz
-
- docinto Documentation
- dodoc sound/Documentation/*
- fi
-
- if kernel_is 2 6; then
- # mv the drivers somewhere they won't be killed by the kernel's make modules_install
- mv ${D}/lib/modules/${KV_FULL}/kernel/sound ${D}/lib/modules/${KV_FULL}/${PN}
- rmdir ${D}/lib/modules/${KV_FULL}/kernel &> /dev/null
- fi
-}
-
-pkg_postinst() {
- einfo
- einfo "The alsasound initscript and modules.d/alsa have now moved to alsa-utils"
- einfo
- einfo "Also, remember that all mixer channels will be MUTED by default."
- einfo "Use the 'alsamixer' program to unmute them."
- einfo
- einfo "Version 1.0.3 and above should work with version 2.6 kernels."
- einfo "If you experience problems, please report bugs to http://bugs.gentoo.org."
- einfo
-
- linux-mod_pkg_postinst
-
- einfo "Check out the ALSA installation guide availible at the following URL:"
- einfo "http://www.gentoo.org/doc/en/alsa-guide.xml"
-
- if kernel_is 2 6 && [ -e ${ROOT}/lib/modules/${KV_FULL}/kernel/sound ]; then
- # Cleanup if they had older alsa installed
- for file in $(find ${ROOT}/lib/modules/${KV_FULL}/${PN} -type f); do
- rm -f ${file//${KV_FULL}\/${PN}/${KV_FULL}\/kernel\/sound}
- done
-
- for dir in $(find ${ROOT}/lib/modules/${KV_FULL}/kernel/sound -type d | tac); do
- rmdir ${dir} &> /dev/null
- done
- fi
-}
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.3.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.3.ebuild
index 1c230275054b..f7d7296bbcf9 100644
--- a/media-sound/alsa-driver/alsa-driver-1.0.3.ebuild
+++ b/media-sound/alsa-driver/alsa-driver-1.0.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.3.ebuild,v 1.12 2005/11/07 10:29:31 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.3.ebuild,v 1.13 2006/01/02 22:34:34 eradicator Exp $
inherit eutils kernel-mod flag-o-matic
@@ -29,7 +29,7 @@ DEPEND="${RDEPEND}
PROVIDE="virtual/alsa"
SLOT="${KV}"
-KEYWORDS="x86 ~ppc -sparc ~amd64 alpha ia64 ~mips"
+KEYWORDS="ia64"
MY_P=${P/_rc/rc}
SRC_URI="mirror://alsaproject/driver/${P}.tar.bz2"
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.8.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.8.ebuild
deleted file mode 100644
index 76ecd7efff50..000000000000
--- a/media-sound/alsa-driver/alsa-driver-1.0.8.ebuild
+++ /dev/null
@@ -1,171 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.8.ebuild,v 1.17 2005/11/07 10:29:31 flameeyes Exp $
-
-IUSE="oss doc"
-inherit linux-mod flag-o-matic eutils
-
-MY_P=${P/_rc/rc}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
-HOMEPAGE="http://www.alsa-project.org/"
-SRC_URI="mirror://alsaproject/driver/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 ~ia64 ~mips ppc ppc64 sparc x86"
-
-RDEPEND="virtual/modutils
- ~media-sound/alsa-headers-${PV}"
-
-DEPEND="${RDEPEND}
- sys-devel/patch
- virtual/linux-sources
- >=sys-devel/autoconf-2.50
- sys-apps/debianutils"
-
-PROVIDE="virtual/alsa"
-
-pkg_setup() {
- # By default, drivers for all supported cards will be compiled.
- # If you want to only compile for specific card(s), set ALSA_CARDS
- # environment to a space-separated list of drivers that you want to build.
- # For example:
- #
- # env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
- #
- ALSA_CARDS=${ALSA_CARDS:-all}
-
- if [ "${PROFILE_ARCH}" == "xbox" ]; then
- ALSA_CARDS='intel8x0'
- fi
-
- # Which drivers need PNP
- local PNP_DRIVERS="interwave interwave-stb"
-
- CONFIG_CHECK="SOUND !SND !SOUND_PRIME"
- SND_ERROR="ALSA is already compiled into the kernel."
- SOUND_ERROR="Your kernel doesn't have sound support enabled."
- SOUND_PRIME_ERROR="Your kernel is configured to use the deprecated OSS drivers. Please disable them and re-emerge alsa-driver."
- PNP_ERROR="Some of the drivers you selected require PNP in your kernel (${PNP_DRIVERS}). Either enable PNP in your kernel or trim which drivers get compiled using ALSA_CARDS in /etc/make.conf."
-
- if [[ "${ALSA_CARDS}" == "all" ]]; then
- CONFIG_CHECK="${CONFIG_CHECK} PNP"
- else
- for pnpdriver in ${PNP_DRIVERS}; do
- hasq ${pnpdriver} ${ALSA_CARDS} && CONFIG_CHECK="${CONFIG_CHECK} PNP"
- done
- fi
-
- linux-mod_pkg_setup
-}
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
-
- #see #81666
- epatch ${FILESDIR}/${PV}-msi_audigyls.patch
-
- convert_to_m ${S}/Makefile
-
- if [ "${PROFILE_ARCH}" == "xbox" ]; then
- epatch ${FILESDIR}/xbox-1.0.8.patch
- fi
-}
-
-src_compile() {
- # Should fix bug #46901
- is-flag "-malign-double" && filter-flags "-fomit-frame-pointer"
-
- econf `use_with oss` \
- --with-kernel="${KV_DIR}" \
- --with-build="${KV_OUT_DIR}" \
- --with-isapnp=yes \
- --with-sequencer=yes \
- --with-cards="${ALSA_CARDS}" || die "econf failed"
-
- # linux-mod_src_compile doesn't work well with alsa
-
- # -j1 : see bug #71028
- ARCH=$(tc-arch-kernel)
- emake -j1 || die "Make Failed"
- ARCH=$(tc-arch)
-
- if use doc;
- then
- ebegin "Building Documentation"
- cd ${S}/scripts
- emake || die Failed making docs in ${S}/scripts
-
- cd ${S}/doc/DocBook
- emake || die Failed making docs in ${S}/doc/DocBook
- eend $?
- fi
-}
-
-
-src_install() {
- dodir /usr/include/sound
-
- make DESTDIR=${D} install || die
-
- # Provided by alsa-headers now
- rm -rf ${D}/usr/include/sound
-
- # We have our own scripts in alsa-utils
- test -e ${D}/etc/init.d/alsasound && rm ${D}/etc/init.d/alsasound
- test -e ${D}/etc/rc.d/init.d/alsasound && rm ${D}/etc/rc.d/init.d/alsasound
-
- dodoc CARDS-STATUS FAQ README WARNING TODO
-
- if use doc; then
- docinto doc
- dodoc doc/*
- rm ${D}/usr/share/doc/${PF}/doc/Makefile.gz
-
- docinto DocBook
- dodoc doc/DocBook/*
- rm ${D}/usr/share/doc/${PF}/DocBook/Makefile.gz
-
- docinto Documentation
- dodoc sound/Documentation/*
- fi
-
- if kernel_is 2 6; then
- # mv the drivers somewhere they won't be killed by the kernel's make modules_install
- mv ${D}/lib/modules/${KV_FULL}/kernel/sound ${D}/lib/modules/${KV_FULL}/${PN}
- rmdir ${D}/lib/modules/${KV_FULL}/kernel &> /dev/null
- fi
-}
-
-pkg_postinst() {
- einfo
- einfo "The alsasound initscript and modules.d/alsa have now moved to alsa-utils"
- einfo
- einfo "Also, remember that all mixer channels will be MUTED by default."
- einfo "Use the 'alsamixer' program to unmute them."
- einfo
- einfo "Version 1.0.3 and above should work with version 2.6 kernels."
- einfo "If you experience problems, please report bugs to http://bugs.gentoo.org."
- einfo
-
-
- linux-mod_pkg_postinst
-
- einfo "Check out the ALSA installation guide availible at the following URL:"
- einfo "http://www.gentoo.org/doc/en/alsa-guide.xml"
-
- if kernel_is 2 6 && [ -e ${ROOT}/lib/modules/${KV_FULL}/kernel/sound ]; then
- # Cleanup if they had older alsa installed
- for file in $(find ${ROOT}/lib/modules/${KV_FULL}/${PN} -type f); do
- rm -f ${file//${KV_FULL}\/${PN}/${KV_FULL}\/kernel\/sound}
- done
-
- for dir in $(find ${ROOT}/lib/modules/${KV_FULL}/kernel/sound -type d | tac); do
- rmdir ${dir} &> /dev/null
- done
- fi
-}
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.9b.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.9b.ebuild
index 4269067f0d18..cdc52145fd7d 100644
--- a/media-sound/alsa-driver/alsa-driver-1.0.9b.ebuild
+++ b/media-sound/alsa-driver/alsa-driver-1.0.9b.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.9b.ebuild,v 1.10 2005/11/07 10:29:31 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.9b.ebuild,v 1.11 2006/01/02 22:34:34 eradicator Exp $
inherit linux-mod flag-o-matic eutils
@@ -11,7 +11,7 @@ SRC_URI="mirror://alsaproject/driver/${P}.tar.bz2"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-KEYWORDS="alpha amd64 ~ia64 ~mips ppc ppc64 ~sparc x86"
+KEYWORDS="alpha amd64 ~ia64 ~mips ppc ppc64 sparc x86"
IUSE="oss doc"
RDEPEND="virtual/modutils
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.10_rc2 b/media-sound/alsa-driver/files/digest-alsa-driver-1.0.10_rc2
deleted file mode 100644
index 32b974c8214f..000000000000
--- a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.10_rc2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 e708ffa88884a13a59515180be9fc9ed alsa-driver-1.0.10rc2.tar.bz2 2174386
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.8 b/media-sound/alsa-driver/files/digest-alsa-driver-1.0.8
deleted file mode 100644
index 5bf8372e0f45..000000000000
--- a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.8
+++ /dev/null
@@ -1 +0,0 @@
-MD5 97d11d734baedd8686d4284eb8273629 alsa-driver-1.0.8.tar.bz2 1926689