summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-03 04:09:45 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-03 04:09:45 +0000
commit88d1b701097234be45fb29ca8dc32bf5e1423a2a (patch)
treeb434d0f809021447a1247986bd564169e4feb56d
parent$DEBUG -> use debug (diff)
downloadgentoo-2-88d1b701097234be45fb29ca8dc32bf5e1423a2a.tar.gz
gentoo-2-88d1b701097234be45fb29ca8dc32bf5e1423a2a.tar.bz2
gentoo-2-88d1b701097234be45fb29ca8dc32bf5e1423a2a.zip
$DEBUG -> use debug
-rw-r--r--net-misc/dante/ChangeLog7
-rw-r--r--net-misc/dante/dante-1.1.13.ebuild7
-rw-r--r--net-misc/dante/dante-1.1.14.ebuild48
-rw-r--r--net-misc/dante/files/digest-dante-1.1.141
-rw-r--r--net-misc/wget/files/digest-wget-1.8.22
-rw-r--r--net-misc/wget/files/digest-wget-1.8.2-r13
-rw-r--r--net-misc/wget/wget-1.8.2-r1.ebuild61
-rw-r--r--net-misc/wget/wget-1.8.2-r2.ebuild24
-rw-r--r--net-misc/wget/wget-1.8.2.ebuild52
-rw-r--r--net-nds/openldap/openldap-2.0.27.ebuild12
10 files changed, 71 insertions, 146 deletions
diff --git a/net-misc/dante/ChangeLog b/net-misc/dante/ChangeLog
index 74b75dd83bf1..05258152c84a 100644
--- a/net-misc/dante/ChangeLog
+++ b/net-misc/dante/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/dante
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dante/ChangeLog,v 1.14 2003/03/13 22:42:19 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dante/ChangeLog,v 1.15 2003/08/03 04:05:49 vapier Exp $
+
+*dante-1.1.14 (03 Aug 2003)
+
+ 03 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bumpage.
*dante-1.1.13 (15 Jul 2002)
diff --git a/net-misc/dante/dante-1.1.13.ebuild b/net-misc/dante/dante-1.1.13.ebuild
index 098b75ebea51..dd0f92972708 100644
--- a/net-misc/dante/dante-1.1.13.ebuild
+++ b/net-misc/dante/dante-1.1.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dante/dante-1.1.13.ebuild,v 1.14 2003/03/13 22:42:19 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dante/dante-1.1.13.ebuild,v 1.15 2003/08/03 04:05:49 vapier Exp $
inherit gcc
@@ -11,7 +11,7 @@ HOMEPAGE="http://www.inet.no/dante/"
LICENSE="BSD"
KEYWORDS="x86 ppc sparc alpha hppa"
SLOT="0"
-IUSE="tcpd"
+IUSE="tcpd debug"
RDEPEND="virtual/glibc
sys-libs/pam
@@ -24,8 +24,7 @@ src_compile() {
local myconf
use tcpd || myconf="--disable-libwrap"
- [ -n "$DEBUGBUILD" ] || myconf="${myconf} --disable-debug"
- einfo "myconf is $myconf"
+ [ `use debug` ] || myconf="${myconf} --disable-debug"
./configure \
--prefix=/usr \
--mandir=/usr/share/man \
diff --git a/net-misc/dante/dante-1.1.14.ebuild b/net-misc/dante/dante-1.1.14.ebuild
new file mode 100644
index 000000000000..f33208ef4bf9
--- /dev/null
+++ b/net-misc/dante/dante-1.1.14.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dante/dante-1.1.14.ebuild,v 1.1 2003/08/03 04:05:49 vapier Exp $
+
+inherit gcc
+
+DESCRIPTION="A free socks4,5 and msproxy implemetation"
+HOMEPAGE="http://www.inet.no/dante/"
+SRC_URI="ftp://ftp.inet.no/pub/socks/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa"
+IUSE="tcpd debug"
+
+DEPEND="virtual/glibc
+ sys-libs/pam
+ tcpd? ( sys-apps/tcp-wrappers )"
+
+src_compile() {
+ econf \
+ `use_enable debug` \
+ `use_enable tcpd libwrap` \
+ --with-socks-conf=/etc/socks/socks.conf \
+ --with-sockd-conf=/etc/socks/sockd.conf \
+ ${myconf} \
+ || die "bad ./configure"
+ emake || die "compile problem"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ # Line 99 in socks.h conflicts with stuff in line 333 of
+ # /usr/include/netinet/in.h this is a not-too-cool way of fix0ring that
+ dosed "s:^int Rbindresvport://int Rbindresvport:" /usr/include/socks.h
+ # bor: comment libdl.so out it seems to work just fine without it
+ dosed 's:libdl\.so::' /usr/bin/socksify
+ dodir /etc/socks
+ dodoc BUGS CREDITS LICENSE NEWS README SUPPORT TODO VERSION
+ docinto txt
+ cd doc
+ dodoc README* *.txt SOCKS4.*
+ docinto example
+ cd ../example
+ dodoc *.conf
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/dante-sockd-init dante-sockd
+}
diff --git a/net-misc/dante/files/digest-dante-1.1.14 b/net-misc/dante/files/digest-dante-1.1.14
new file mode 100644
index 000000000000..67e51bafd3c6
--- /dev/null
+++ b/net-misc/dante/files/digest-dante-1.1.14
@@ -0,0 +1 @@
+MD5 465c2c615c1aa64afd328feee97ba007 dante-1.1.14.tar.gz 804081
diff --git a/net-misc/wget/files/digest-wget-1.8.2 b/net-misc/wget/files/digest-wget-1.8.2
deleted file mode 100644
index e9052aefd4bc..000000000000
--- a/net-misc/wget/files/digest-wget-1.8.2
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 a2473d7a53ebaf0a1bdb06f17059e8f1 wget-1.8.2.tar.gz 1154648
-MD5 8da1e4f2991384ddbd575f4109c2ab4a wget-new-percentage-cvs-20011209.tar.gz 12196
diff --git a/net-misc/wget/files/digest-wget-1.8.2-r1 b/net-misc/wget/files/digest-wget-1.8.2-r1
deleted file mode 100644
index 39c3be4eb0af..000000000000
--- a/net-misc/wget/files/digest-wget-1.8.2-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 a2473d7a53ebaf0a1bdb06f17059e8f1 wget-1.8.2.tar.gz 1154648
-MD5 8da1e4f2991384ddbd575f4109c2ab4a wget-new-percentage-cvs-20011209.tar.gz 12196
-MD5 06e82e110d99480c8c81a7c3531c8ca5 wget-1.8.2-ipv6-debian.patch.bz2 8353
diff --git a/net-misc/wget/wget-1.8.2-r1.ebuild b/net-misc/wget/wget-1.8.2-r1.ebuild
deleted file mode 100644
index 66b9c50be725..000000000000
--- a/net-misc/wget/wget-1.8.2-r1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.8.2-r1.ebuild,v 1.9 2003/07/16 14:30:41 pvdabeel Exp $
-
-IUSE="ssl nls static ipv6"
-
-NPVER=20011209
-S=${WORKDIR}/${P}
-DESCRIPTION="Network utility to retrieve files from the WWW"
-HOMEPAGE="http://wget.sunsite.dk"
-SRC_URI="mirror://gnu/wget/${P}.tar.gz
- http://www.biscom.net/~cade/away/wget-new-percentage/wget-new-percentage-cvs-${NPVER}.tar.gz
- ipv6? mirror://gentoo/${P}-ipv6-debian.patch.bz2"
-
-RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )"
-DEPEND="nls? ( sys-devel/gettext )"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ppc ~sparc ~alpha"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}/src
- patch -p0 < ${WORKDIR}/wget-new-percentage/wnp-20011208-2.diff || die
-
- if use ipv6
- then
- cd ${S}
- patch -p1 < ${WORKDIR}/${P}-ipv6-debian.patch || die
- fi
-}
-
-src_compile() {
- local myconf
- use nls || myconf="--disable-nls"
- use ssl && myconf="${myconf} --with-ssl"
- use ssl || myconf="${myconf} --without-ssl --disable-opie --disable-digest"
- [ -z "$DEBUG" ] && myconf="${myconf} --disable-debug"
- use ssl && CFLAGS="${CFLAGS} -I/usr/include/openssl"
- ./configure --prefix=/usr --sysconfdir=/etc/wget \
- --infodir=/usr/share/info --mandir=usr/share/man $myconf || die
- if use static; then
- make LDFLAGS="--static" || die
- else
- make || die
- fi
-}
-
-src_install() {
- if use build; then
- insinto /usr
- dobin ${S}/src/wget
- return
- fi
- make prefix=${D}/usr sysconfdir=${D}/etc/wget \
- mandir=${D}/usr/share/man infodir=${D}/usr/share/info install || die
- dodoc AUTHORS COPYING ChangeLog MACHINES MAILING-LIST NEWS README TODO
- dodoc doc/sample.wgetrc
-}
diff --git a/net-misc/wget/wget-1.8.2-r2.ebuild b/net-misc/wget/wget-1.8.2-r2.ebuild
index 555478377bae..2854be0316d7 100644
--- a/net-misc/wget/wget-1.8.2-r2.ebuild
+++ b/net-misc/wget/wget-1.8.2-r2.ebuild
@@ -1,45 +1,41 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.8.2-r2.ebuild,v 1.8 2003/07/06 09:13:30 kumba Exp $
-
-
-IUSE="ssl nls static ipv6"
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.8.2-r2.ebuild,v 1.9 2003/08/03 04:08:19 vapier Exp $
inherit gnuconfig
NPVER=20011209
-S=${WORKDIR}/${P}
DESCRIPTION="Network utility to retrieve files from the WWW"
HOMEPAGE="http://www.cg.tuwien.ac.at/~prikryl/wget.html"
SRC_URI="mirror://gnu/wget/${P}.tar.gz
http://www.biscom.net/~cade/away/wget-new-percentage/wget-new-percentage-cvs-${NPVER}.tar.gz
ipv6? mirror://gentoo/${P}-ipv6-debian.patch.bz2"
-RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )"
-DEPEND="nls? ( sys-devel/gettext )"
-
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="amd64 x86 ppc sparc alpha hppa arm mips"
+IUSE="ssl nls static ipv6 debug"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )"
+DEPEND="nls? ( sys-devel/gettext )"
src_unpack() {
unpack ${A}
cd ${S}
- patch -p1 < ${FILESDIR}/${PF}-gentoo.diff || die
+ epatch ${FILESDIR}/${PF}-gentoo.diff
cd ${S}/src
- patch -p0 < ${WORKDIR}/wget-new-percentage/wnp-20011208-2.diff || die
+ epatch ${WORKDIR}/wget-new-percentage/wnp-20011208-2.diff
if use ipv6
then
cd ${S}
- patch -p1 < ${WORKDIR}/${P}-ipv6-debian.patch || die
+ epatch ${WORKDIR}/${P}-ipv6-debian.patch
fi
}
src_compile() {
-
# Make wget use up-to-date configure scripts
gnuconfig_update
@@ -47,7 +43,7 @@ src_compile() {
use nls || myconf="--disable-nls"
use ssl && myconf="${myconf} --with-ssl"
use ssl || myconf="${myconf} --without-ssl --disable-opie --disable-digest"
- [ -z "$DEBUG" ] && myconf="${myconf} --disable-debug"
+ use debug && myconf="${myconf} --disable-debug"
use ssl && CFLAGS="${CFLAGS} -I/usr/include/openssl"
./configure --prefix=/usr --sysconfdir=/etc/wget \
--infodir=/usr/share/info --mandir=usr/share/man $myconf || die
diff --git a/net-misc/wget/wget-1.8.2.ebuild b/net-misc/wget/wget-1.8.2.ebuild
deleted file mode 100644
index b2ce4cfca3e0..000000000000
--- a/net-misc/wget/wget-1.8.2.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.8.2.ebuild,v 1.13 2003/02/13 15:11:12 vapier Exp $
-
-IUSE="ssl nls static"
-
-NPVER=20011209
-S=${WORKDIR}/${P}
-DESCRIPTION="Network utility to retrieve files from the WWW"
-SRC_URI="mirror://gnu/wget/${P}.tar.gz
- http://www.biscom.net/~cade/away/wget-new-percentage/wget-new-percentage-cvs-${NPVER}.tar.gz"
-HOMEPAGE="http://wget.sunsite.dk"
-RDEPEND="virtual/glibc ssl? ( >=dev-libs/openssl-0.9.6b )"
-DEPEND="$RDEPEND nls? ( sys-devel/gettext )"
-KEYWORDS="x86 ppc sparc alpha mips"
-LICENSE="GPL-2"
-SLOT="0"
-
-src_unpack() {
- unpack ${P}.tar.gz
- unpack wget-new-percentage-cvs-${NPVER}.tar.gz
- cd ${S}/src
- patch -p0 < ${WORKDIR}/wget-new-percentage/wnp-20011208-2.diff || die
-}
-
-src_compile() {
- local myconf
- use nls || myconf="--disable-nls"
- use ssl && myconf="${myconf} --with-ssl"
- use ssl || myconf="${myconf} --without-ssl --disable-opie --disable-digest"
- [ -z "$DEBUG" ] && myconf="${myconf} --disable-debug"
- use ssl && CFLAGS="${CFLAGS} -I/usr/include/openssl"
- ./configure --prefix=/usr --sysconfdir=/etc/wget \
- --infodir=/usr/share/info --mandir=usr/share/man $myconf || die
- if use static; then
- make LDFLAGS="--static" || die
- else
- make || die
- fi
-}
-
-src_install() {
- if use build; then
- insinto /usr
- dobin ${S}/src/wget
- return
- fi
- make prefix=${D}/usr sysconfdir=${D}/etc/wget \
- mandir=${D}/usr/share/man infodir=${D}/usr/share/info install || die
- dodoc AUTHORS COPYING ChangeLog MACHINES MAILING-LIST NEWS README TODO
- dodoc doc/sample.wgetrc
-}
diff --git a/net-nds/openldap/openldap-2.0.27.ebuild b/net-nds/openldap/openldap-2.0.27.ebuild
index 1030fe09fb8f..7afa0c18d43d 100644
--- a/net-nds/openldap/openldap-2.0.27.ebuild
+++ b/net-nds/openldap/openldap-2.0.27.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.0.27.ebuild,v 1.10 2003/06/21 15:59:02 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.0.27.ebuild,v 1.11 2003/08/03 04:09:45 vapier Exp $
DESCRIPTION="LDAP suite of application and development tools"
SRC_URI="ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/${P}.tgz"
@@ -9,7 +9,7 @@ HOMEPAGE="http://www.OpenLDAP.org/"
SLOT="0"
KEYWORDS="x86 ppc sparc alpha"
LICENSE="OPENLDAP"
-IUSE="ssl tcpd readline ipv6 gdbm ldap kerberos odbc"
+IUSE="ssl tcpd readline ipv6 gdbm ldap kerberos odbc debug"
DEPEND="virtual/glibc
>=sys-libs/ncurses-5.1
@@ -26,13 +26,7 @@ RDEPEND="virtual/glibc
gdbm? ( >=sys-libs/gdbm-1.8.0 )"
src_compile() {
- local myconf
-
- if [ -n "$DEBUG" ]; then
- myconf="--enable-debug"
- else
- myconf="--disable-debug"
- fi
+ local myconf="`use_enable debug`"
use kerberos \
&& myconf="${myconf} --with-kerberos --enable-kpasswd" \