summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-09-14 23:15:34 +0000
committerTim Harder <radhermit@gentoo.org>2011-09-14 23:15:34 +0000
commit891a0ff157903006a9f50e34ec217e8cc6cd0279 (patch)
treef1398912d24028b8c2589f103361fb7b5fb11e7a
parentVersion bump. (diff)
downloadgentoo-2-891a0ff157903006a9f50e34ec217e8cc6cd0279.tar.gz
gentoo-2-891a0ff157903006a9f50e34ec217e8cc6cd0279.tar.bz2
gentoo-2-891a0ff157903006a9f50e34ec217e8cc6cd0279.zip
Version bump.
(Portage version: 2.2.0_alpha55/cvs/Linux x86_64)
-rw-r--r--app-vim/easytags/ChangeLog7
-rw-r--r--app-vim/easytags/easytags-2.5.7.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/app-vim/easytags/ChangeLog b/app-vim/easytags/ChangeLog
index 724fbc068306..e7d014c63ef1 100644
--- a/app-vim/easytags/ChangeLog
+++ b/app-vim/easytags/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/easytags
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/easytags/ChangeLog,v 1.6 2011/09/05 04:42:44 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/easytags/ChangeLog,v 1.7 2011/09/14 23:15:34 radhermit Exp $
+
+*easytags-2.5.7 (14 Sep 2011)
+
+ 14 Sep 2011; Tim Harder <radhermit@gentoo.org> +easytags-2.5.7.ebuild:
+ Version bump.
*easytags-2.5.4 (05 Sep 2011)
diff --git a/app-vim/easytags/easytags-2.5.7.ebuild b/app-vim/easytags/easytags-2.5.7.ebuild
new file mode 100644
index 000000000000..6e5ee97689e7
--- /dev/null
+++ b/app-vim/easytags/easytags-2.5.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/easytags/easytags-2.5.7.ebuild,v 1.1 2011/09/14 23:15:34 radhermit Exp $
+
+EAPI=4
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: automated tag file generation and syntax highlighting"
+HOMEPAGE="http://peterodding.com/code/vim/easytags/"
+SRC_URI="https://github.com/xolox/vim-${PN}/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( dev-lang/python:2.7 dev-lang/python:2.6 )
+ >=app-vim/xolox-misc-20110904
+ dev-util/ctags"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${PN}-* "${S}"
+}
+
+src_prepare() {
+ # Remove unnecessary files
+ rm INSTALL.md README.md || die
+ rm -r autoload/xolox/misc || die
+}
+
+src_install() {
+ vim-plugin_src_install
+
+ # Make scripts executable
+ fperms 755 /usr/share/vim/vimfiles/misc/easytags/{normalize-tags,why-so-slow}.py
+}