summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-07-03 05:56:00 +0000
committerHans de Graaff <graaff@gentoo.org>2012-07-03 05:56:00 +0000
commit8f019c80ea496382ce1c8447333a28d0da03b756 (patch)
treef69b30a349d5f61fc56f6eebd43eb3335dc1479f
parentBump (diff)
downloadgentoo-2-8f019c80ea496382ce1c8447333a28d0da03b756.tar.gz
gentoo-2-8f019c80ea496382ce1c8447333a28d0da03b756.tar.bz2
gentoo-2-8f019c80ea496382ce1c8447333a28d0da03b756.zip
Version bump. Move hpricot to the test dependencies since it is an optional dependency. This matches the upstream gemspec.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
-rw-r--r--dev-ruby/haml/ChangeLog9
-rw-r--r--dev-ruby/haml/files/haml-3.1.6-sass.patch20
-rw-r--r--dev-ruby/haml/haml-3.1.6.ebuild55
3 files changed, 83 insertions, 1 deletions
diff --git a/dev-ruby/haml/ChangeLog b/dev-ruby/haml/ChangeLog
index ccb3a8be2531..1a59ce9d93ed 100644
--- a/dev-ruby/haml/ChangeLog
+++ b/dev-ruby/haml/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/haml
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.75 2012/05/17 10:59:29 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.76 2012/07/03 05:56:00 graaff Exp $
+
+*haml-3.1.6 (03 Jul 2012)
+
+ 03 Jul 2012; Hans de Graaff <graaff@gentoo.org> +haml-3.1.6.ebuild,
+ +files/haml-3.1.6-sass.patch:
+ Version bump. Move hpricot to the test dependencies since it is an optional
+ dependency. This matches the upstream gemspec.
17 May 2012; Thomas Kahle <tomka@gentoo.org> haml-3.1.4-r3.ebuild:
marked ~x86 per bug 396547
diff --git a/dev-ruby/haml/files/haml-3.1.6-sass.patch b/dev-ruby/haml/files/haml-3.1.6-sass.patch
new file mode 100644
index 000000000000..6837f10f825d
--- /dev/null
+++ b/dev-ruby/haml/files/haml-3.1.6-sass.patch
@@ -0,0 +1,20 @@
+--- metadata.orig 2012-07-03 07:46:35.000000000 +0200
++++ metadata 2012-07-03 07:51:30.917926913 +0200
+@@ -14,6 +14,17 @@
+ date: 2012-05-16 00:00:00.000000000 Z
+ dependencies:
+ - !ruby/object:Gem::Dependency
++ name: sass
++ prerelease: false
++ requirement: &id003 !ruby/object:Gem::Requirement
++ none: false
++ requirements:
++ - - "~>"
++ - !ruby/object:Gem::Version
++ version: 3.1.11
++ type: :runtime
++ version_requirements: *id003
++- !ruby/object:Gem::Dependency
+ name: yard
+ requirement: !ruby/object:Gem::Requirement
+ none: false
diff --git a/dev-ruby/haml/haml-3.1.6.ebuild b/dev-ruby/haml/haml-3.1.6.ebuild
new file mode 100644
index 000000000000..25484e6828c5
--- /dev/null
+++ b/dev-ruby/haml/haml-3.1.6.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/haml-3.1.6.ebuild,v 1.1 2012/07/03 05:56:00 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+RUBY_FAKEGEM_TASK_DOC="doc"
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING README.md"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb rails VERSION VERSION_NAME"
+
+inherit ruby-fakegem
+
+DESCRIPTION="HAML - a ruby web page templating engine"
+HOMEPAGE="http://haml-lang.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# TODO: haml has some emacs modes that it could be installing, in case
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/sass"
+
+# It could use merb during testing as well, but it's not mandatory
+ruby_add_bdepend "
+ test? (
+ dev-ruby/hpricot
+ dev-ruby/erubis
+ dev-ruby/rails
+ dev-ruby/ruby_parser
+ )
+ doc? (
+ dev-ruby/yard
+ dev-ruby/maruku
+ )"
+
+all_ruby_prepare() {
+ # unbundle sass; remove dependency over fssm and add one over sass
+ # itself.
+ rm -r vendor/ || die
+
+ pushd .. &>/dev/null
+ epatch "${FILESDIR}"/${P}-sass.patch
+ sed -i \
+ -e '/vendor\//d' \
+ metadata || die
+ popd &>/dev/null
+}