summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-12-22 12:45:09 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-12-22 12:45:09 +0000
commit97596b23ccd578ab76ab63f9ab6822ceae5228ae (patch)
tree19ea2d24edb160801900a5159ffcd465b635f3e4
parentStable for ppc64, wrt bug #467186 (diff)
downloadgentoo-2-97596b23ccd578ab76ab63f9ab6822ceae5228ae.tar.gz
gentoo-2-97596b23ccd578ab76ab63f9ab6822ceae5228ae.tar.bz2
gentoo-2-97596b23ccd578ab76ab63f9ab6822ceae5228ae.zip
Version bump to 1.0_rc2.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
-rw-r--r--sys-apps/epoch/ChangeLog8
-rw-r--r--sys-apps/epoch/epoch-1.0_rc2.ebuild74
2 files changed, 81 insertions, 1 deletions
diff --git a/sys-apps/epoch/ChangeLog b/sys-apps/epoch/ChangeLog
index 5b63307d493d..07cd037f5bd2 100644
--- a/sys-apps/epoch/ChangeLog
+++ b/sys-apps/epoch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/epoch
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/epoch/ChangeLog,v 1.2 2013/12/07 21:17:40 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/epoch/ChangeLog,v 1.3 2013/12/22 12:45:09 tomwij Exp $
+
+*epoch-1.0_rc2 (22 Dec 2013)
+
+ 22 Dec 2013; Tom Wijsman <TomWij@gentoo.org> +epoch-1.0_rc2.ebuild,
+ epoch-1.0_rc1.ebuild:
+ Version bump to 1.0_rc2.
07 Dec 2013; Tom Wijsman <TomWij@gentoo.org> epoch-1.0_rc1.ebuild,
epoch-9999.ebuild:
diff --git a/sys-apps/epoch/epoch-1.0_rc2.ebuild b/sys-apps/epoch/epoch-1.0_rc2.ebuild
new file mode 100644
index 000000000000..1b6461b1eee8
--- /dev/null
+++ b/sys-apps/epoch/epoch-1.0_rc2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/epoch/epoch-1.0_rc2.ebuild,v 1.1 2013/12/22 12:45:09 tomwij Exp $
+
+EAPI="5"
+
+inherit eutils linux-info
+
+MY_PV="${PV/rc/RC}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="An init system, a /sbin/init replacement; designed for simplicity."
+HOMEPAGE="http://universe2.us/epoch.html"
+SRC_URI="https://github.com/Subsentient/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ local CONFIG_CHECK="~PROC_FS"
+
+ [[ ${MERGE_TYPE} != buildonly ]] && check_extra_config
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0_rc1-fix-CFLAGS.patch
+}
+
+src_compile() {
+ NEED_EMPTY_CFLAGS=1 sh ./buildepoch.sh || die "Cannot build epoch."
+}
+
+newepochins() {
+ local type="$1"
+
+ cd ${type} || die "Cannot change directory."
+ for file in * ; do
+ if [[ "${file}" != "epoch" ]] ; then
+ new${type} ${file} epoch-${file}
+ fi
+ done
+ cd .. || die "Cannot change directory."
+}
+
+src_install() {
+ cd built || die "Cannot change directory."
+
+ dosbin sbin/epoch
+
+ # For now, rename to epoch-* until we can blend in with a standard approach.
+ newepochins bin
+ newepochins sbin
+
+ insinto /etc/epoch/
+ newins "${FILESDIR}"/${PN}-1.0_rc1-epoch.conf epoch.conf
+}
+
+pkg_postinst() {
+ elog "Make sure to provide /run and /tmp tmpfs mounts using /etc/fstab."
+ elog ""
+ elog "An example epoch configuration is provided at /etc/epoch/epoch.conf"
+ elog "which starts a minimal needed to use Gentoo."
+ elog ""
+ elog "To use epoch, add this kernel parameter: init=/usr/sbin/epoch-init"
+ elog ""
+ elog "Additional information about epoch is available at"
+ elog "${HOMEPAGE} and configuration documentation at"
+ elog "http://universe2.us/epochconfig.html which is useful reading material."
+ elog ""
+ elog "Its author Subsentient can be contacted at #epoch on irc.freenode.net."
+}