summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Gabert <pappy@gentoo.org>2003-11-11 19:42:42 +0000
committerAlexander Gabert <pappy@gentoo.org>2003-11-11 19:42:42 +0000
commit98770b14944902cb0289cbd294390b62c4202e18 (patch)
treedaf8836c8e62687fae14d1b0c2264ce969d0d561
parentadded ghc-6.0.1 bugfix from ghc-5.04.3-r1 bug30789 (diff)
downloadgentoo-2-98770b14944902cb0289cbd294390b62c4202e18.tar.gz
gentoo-2-98770b14944902cb0289cbd294390b62c4202e18.tar.bz2
gentoo-2-98770b14944902cb0289cbd294390b62c4202e18.zip
added ghc-6.0.1 bugfix from ghc-5.04.3-r1 bug30789
-rw-r--r--dev-lang/ghc/ChangeLog6
-rw-r--r--dev-lang/ghc/Manifest6
-rw-r--r--dev-lang/ghc/ghc-5.04.3-r1.ebuild12
-rw-r--r--dev-lang/ghc/ghc-6.0.1.ebuild12
4 files changed, 30 insertions, 6 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index cae430beda69..4d32cd522e3c 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ghc
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.21 2003/10/22 12:34:49 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.22 2003/11/11 19:42:36 pappy Exp $
+
+ 11 Nov 2003; Alexander Gabert <pappy@gentoo.org> ghc-5.04.3-r1.ebuild,
+ ghc-6.0.1.ebuild:
+ added ghc-6.0.1 bugfix from ghc-5.04.3-r1 bug30789
22 Oct 2003; Andres Loeh <kosmikus@gentoo.org> ghc-5.04.3-r1.ebuild,
ghc-6.0.1.ebuild, ghc-6.0.ebuild:
diff --git a/dev-lang/ghc/Manifest b/dev-lang/ghc/Manifest
index f6e0d8647014..3aca8769520b 100644
--- a/dev-lang/ghc/Manifest
+++ b/dev-lang/ghc/Manifest
@@ -1,11 +1,11 @@
MD5 53cadcab720c08f0d03fced644adc7ce ghc-5.04.3.ebuild 4536
-MD5 520bc1d5771d253372b78c11fb692da9 ghc-5.04.3-r1.ebuild 7368
+MD5 70fd3ed422514576f84000daa3c1313b ghc-5.04.3-r1.ebuild 7365
MD5 6c6a8a53a1d8079dc9b280bd7481fc55 ghc-5.04.ebuild 6945
MD5 e6cb655b6e491861cde72bf8695c53eb ghc-6.0.ebuild 4282
MD5 4e310a2cb7f0093cd85d9a366f2337cc ghc-5.04.2.ebuild 4536
MD5 42b857369c2e24507f00520e99fdaf5a ghc-5.02.3.ebuild 7646
-MD5 96fb00b59913d6bd37e51227a83d83b3 ghc-6.0.1.ebuild 4783
-MD5 8b81c91b070ddf3d701e005400796997 ChangeLog 5460
+MD5 b25c07c97e4a2be6d7a6ea7fd4ab4b12 ghc-6.0.1.ebuild 4780
+MD5 854e49c94227ac7f9a1b94a162e2abe3 ChangeLog 5457
MD5 a769ecfcd1cdd2d40986627df7dfb249 metadata.xml 224
MD5 9da9270be8ac4d92d6a5c23fd519cc3c files/lndir.c 8050
MD5 cc8947705ec2b2a685edb4eefddeebc2 files/ghc-5.02.3-gentoo.patch.bz2 14489
diff --git a/dev-lang/ghc/ghc-5.04.3-r1.ebuild b/dev-lang/ghc/ghc-5.04.3-r1.ebuild
index fb6c9bdc3919..3e2995e458c2 100644
--- a/dev-lang/ghc/ghc-5.04.3-r1.ebuild
+++ b/dev-lang/ghc/ghc-5.04.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-5.04.3-r1.ebuild,v 1.7 2003/10/22 12:34:49 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-5.04.3-r1.ebuild,v 1.8 2003/11/11 19:42:36 pappy Exp $
#Some explanation of bootstrap logic:
#
@@ -127,6 +127,16 @@ src_compile() {
mkdir ${STAGE2_B} || die
${LNDIR} ${S} ${STAGE2_B} || die
+# disable the automatic PIC building which is considered as Prologue Junk by the Haskell Compiler
+ if has_version "sys-devel/hardened-gcc"
+ then
+ # fix proposed by Peter simons according to bug #30789
+ echo "SRC_CC_OPTS+=-yet_exec -yno_propolice" >> ${STAGE1_B}/mk/build.mk
+ echo "SRC_HC_OPTS+=-optc-yet_exec -optc-yno_propolice" >> ${STAGE1_B}/mk/build.mk
+ echo "SRC_CC_OPTS+=-yet_exec -yno_propolice" >> ${STAGE2_B}/mk/build.mk
+ echo "SRC_HC_OPTS+=-optc-yet_exec -optc-yno_propolice" >> ${STAGE2_B}/mk/build.mk
+ fi
+
use opengl && myconf="--enable-hopengl" || myconf="--disable-hopengl"
if test x$need_stage1 = xyes; then
diff --git a/dev-lang/ghc/ghc-6.0.1.ebuild b/dev-lang/ghc/ghc-6.0.1.ebuild
index c5d06937e519..704f1f93450f 100644
--- a/dev-lang/ghc/ghc-6.0.1.ebuild
+++ b/dev-lang/ghc/ghc-6.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.0.1.ebuild,v 1.2 2003/10/22 12:34:49 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.0.1.ebuild,v 1.3 2003/11/11 19:42:36 pappy Exp $
#Some explanation of bootstrap logic:
#
@@ -84,6 +84,16 @@ src_compile() {
myconf="--enable-hopengl"
fi
+ # disable the automatic PIC building which is considered as Prologue Junk by the Haskell Compiler
+ # thanks to Peter Simons for finding this and giving notice on bugs.gentoo.org
+ if has_version "sys-devel/hardened-gcc"
+ then
+ echo "SRC_CC_OPTS+=-yet_exec -yno_propolice" >> mk/build.mk
+ echo "SRC_HC_OPTS+=-optc-yet_exec -optc-yno_propolice" >> mk/build.mk
+ echo "SRC_CC_OPTS+=-yet_exec -yno_propolice" >> mk/build.mk
+ echo "SRC_HC_OPTS+=-optc-yet_exec -optc-yno_propolice" >> mk/build.mk
+ fi
+
# unset SGML_CATALOG_FILES because documentation installation
# breaks otherwise ...
PATH="${GHCPATH}" SGML_CATALOG_FILES="" econf \