summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-20 23:25:16 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-20 23:25:16 +0000
commit9a8a03b8043b29575727f398e5fec3bdb9e80267 (patch)
tree86751ea5cb052afd52822966d9870f1744a37c0a
parentVersion bump to KDE 3.5.9. (diff)
downloadgentoo-2-9a8a03b8043b29575727f398e5fec3bdb9e80267.tar.gz
gentoo-2-9a8a03b8043b29575727f398e5fec3bdb9e80267.tar.bz2
gentoo-2-9a8a03b8043b29575727f398e5fec3bdb9e80267.zip
Version bump to KDE 3.5.9.
(Portage version: 2.1.4.4)
-rw-r--r--kde-base/kttsd/ChangeLog7
-rw-r--r--kde-base/kttsd/kttsd-3.5.9.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/kde-base/kttsd/ChangeLog b/kde-base/kttsd/ChangeLog
index cdde4a0c6ceb..696fdd486904 100644
--- a/kde-base/kttsd/ChangeLog
+++ b/kde-base/kttsd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kttsd
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kttsd/ChangeLog,v 1.84 2008/02/17 02:07:39 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kttsd/ChangeLog,v 1.85 2008/02/20 23:25:16 philantrop Exp $
+
+*kttsd-3.5.9 (20 Feb 2008)
+
+ 20 Feb 2008; Wulf C. Krueger <philantrop@gentoo.org> +kttsd-3.5.9.ebuild:
+ Version bump to KDE 3.5.9.
16 Feb 2008; Ingmar Vanhassel <ingmar@gentoo.org> -kttsd-3.5.5.ebuild,
-kttsd-3.5.6.ebuild, -kttsd-3.5.7.ebuild, -kttsd-4.0.0.ebuild:
diff --git a/kde-base/kttsd/kttsd-3.5.9.ebuild b/kde-base/kttsd/kttsd-3.5.9.ebuild
new file mode 100644
index 000000000000..00833dca9557
--- /dev/null
+++ b/kde-base/kttsd/kttsd-3.5.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kttsd/kttsd-3.5.9.ebuild,v 1.1 2008/02/20 23:25:16 philantrop Exp $
+KMNAME=kdeaccessibility
+EAPI="1"
+inherit kde-meta
+
+DESCRIPTION="KDE text-to-speech subsystem"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="akode alsa"
+
+DEPEND="akode? ( media-libs/akode )
+ alsa? ( media-libs/alsa-lib )
+ >=kde-base/kcontrol-${PV}:${SLOT}
+ !arts? ( !alsa? ( media-libs/akode ) )"
+RDEPEND="${DEPEND}
+ || ( app-accessibility/festival
+ app-accessibility/epos
+ app-accessibility/flite
+ app-accessibility/freetts )"
+
+pkg_setup() {
+ kde_pkg_setup
+ if ! use arts && ! use alsa && ! use akode ; then
+ ewarn "No audio backend chosen. Defaulting to media-libs/akode."
+ fi
+}
+
+src_unpack() {
+ kde-meta_src_unpack
+
+ sed -i -e "s:^MimeTypes=::" "${S}/kttsd/kttsmgr/kttsmgr.desktop" \
+ || die "sed to fix the desktop file failed"
+}
+
+src_compile() {
+ local myconf="$(use_with alsa) --without-gstreamer"
+
+ if ! use arts && ! use alsa ; then
+ myconf="${myconf} --with-akokde"
+ else
+ myconf="${myconf} $(use_with akode)"
+ fi
+
+ kde-meta_src_compile
+}