summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2003-03-06 18:38:12 +0000
committerArcady Genkin <agenkin@gentoo.org>2003-03-06 18:38:12 +0000
commit9f87b326698be376e9cab799307dad13e22a1904 (patch)
treed4c4c262a241b01f8b85055d96453cab2340caa8
parentversion bump, removed old versions (diff)
downloadgentoo-2-9f87b326698be376e9cab799307dad13e22a1904.tar.gz
gentoo-2-9f87b326698be376e9cab799307dad13e22a1904.tar.bz2
gentoo-2-9f87b326698be376e9cab799307dad13e22a1904.zip
Update to 0.9.0rc8b.
-rw-r--r--media-sound/alsa-driver/ChangeLog8
-rw-r--r--media-sound/alsa-driver/alsa-driver-0.9.0_rc8-r1.ebuild95
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_rc8-r11
3 files changed, 103 insertions, 1 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index 03ae7c09445a..e7302de8894c 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.27 2003/03/05 00:26:42 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.28 2003/03/06 18:38:12 agenkin Exp $
+
+*alsa-driver-0.9.0_rc8-r1 (03 Mar 2003)
+
+ 04 Mar 2003; Arcady Genkin <agenkin@gentoo.org> :
+ Update to version 0.9.0rc8b.
+ Replaced "emake" with "make".
*alsa-driver-0.9.0_rc8 (03 Mar 2003)
diff --git a/media-sound/alsa-driver/alsa-driver-0.9.0_rc8-r1.ebuild b/media-sound/alsa-driver/alsa-driver-0.9.0_rc8-r1.ebuild
new file mode 100644
index 000000000000..e5b47129cf82
--- /dev/null
+++ b/media-sound/alsa-driver/alsa-driver-0.9.0_rc8-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-0.9.0_rc8-r1.ebuild,v 1.1 2003/03/06 18:38:12 agenkin Exp $
+
+DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+LICENSE="GPL-2 LGPL-2.1"
+
+# By default, drivers for all supported cards will be compiled.
+# If you want to only compile for specific card(s), set ALSA_CARDS
+# environment to a space-separated list of drivers that you want to build.
+# For example:
+#
+# env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
+#
+[ x"${ALSA_CARDS}" = x ] && ALSA_CARDS=all
+
+# Need the baselayout 1.7.9 or newer for the init script to work correctly.
+DEPEND="sys-devel/autoconf
+ virtual/glibc
+ >=sys-apps/portage-1.9.10
+ >=sys-apps/baselayout-1.7.9"
+PROVIDE="virtual/alsa"
+
+SLOT="0.9"
+KEYWORDS="~x86"
+
+# Those letter bugfix versions are a pain. Hardcoding the letter "b" for
+# this revision.
+SRC_URI="ftp://ftp.alsa-project.org/pub/driver/${P/_rc/rc}b.tar.bz2"
+S=${WORKDIR}/${P/_rc/rc}b
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Some *broken* Gentoo packages install stuff in /etc/rc.d/init.d
+ # instead of /etc/init.d. However, this causes alsa's installer
+ # to do the same foolish thing. This *hack* inibits the problem.
+ # I filed a bug report about this with the ALSA people:
+ # http://sourceforge.net/tracker/?func=detail&aid=551668&group_id=27464&atid=390601
+ # Arcady Genkin <agenkin@thpoon.com>
+ sed -e 's:/etc/rc.d/init.d:/etc/init.d:' < Makefile > Makefile.hacked
+ mv Makefile.hacked Makefile
+
+}
+
+
+src_compile() {
+ # Portage should determine the version of the kernel sources
+ check_KV
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --with-kernel="${ROOT}usr/src/linux" \
+ --with-isapnp=yes \
+ --with-sequencer=yes \
+ --with-oss=yes \
+ --with-cards="${ALSA_CARDS}" \
+ || die "./configure failed"
+
+ make || die "Parallel Make Failed"
+}
+
+
+src_install() {
+ dodir /usr/include/sound
+ dodir /etc/init.d
+ make DESTDIR=${D} install || die
+
+ dodoc CARDS-STATUS COPYING FAQ INSTALL README WARNING TODO doc/*
+
+ insinto /etc/modules.d
+ newins ${FILESDIR}/alsa-modules.conf-rc alsa
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/alsasound
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = / ]
+ then
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+ fi
+
+ einfo
+ einfo "You need to edit file /etc/modules.d/alsa according to your"
+ einfo "hardware configuration."
+ einfo
+ einfo "If you are going to be using the 'alsasound' init script, make sure"
+ einfo "that you add it to the 'boot' runlevel (not 'default')."
+ einfo
+ einfo "Also, remember that all mixer channels will be MUTED by default."
+ einfo "Use 'alsamixer' program to unmute them."
+ einfo
+}
+
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_rc8-r1 b/media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_rc8-r1
new file mode 100644
index 000000000000..4f624e0764a9
--- /dev/null
+++ b/media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_rc8-r1
@@ -0,0 +1 @@
+MD5 addd62be335ccec2a4882a38b1354330 alsa-driver-0.9.0rc8b.tar.bz2 1625856