summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-11-12 18:28:29 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-11-12 18:28:29 +0000
commita4300ed37b774569e8d1922bd6ea25d3664aabd1 (patch)
tree4a9d44106a32ba9b2f94c67d7dc6b6de5c13e272
parentDropped conditional on firebird versions that switched paths from /opt to /usr. (diff)
downloadgentoo-2-a4300ed37b774569e8d1922bd6ea25d3664aabd1.tar.gz
gentoo-2-a4300ed37b774569e8d1922bd6ea25d3664aabd1.tar.bz2
gentoo-2-a4300ed37b774569e8d1922bd6ea25d3664aabd1.zip
Fixed build without nls (bug #198720) and propagate some flags in the command line Makefile.
(Portage version: 2.1.3.16)
-rw-r--r--sci-mathematics/gretl/ChangeLog8
-rw-r--r--sci-mathematics/gretl/files/gretl-1.6.5-cli.patch38
-rw-r--r--sci-mathematics/gretl/files/gretl-1.6.5-nls.patch17
-rw-r--r--sci-mathematics/gretl/gretl-1.6.5.ebuild11
4 files changed, 72 insertions, 2 deletions
diff --git a/sci-mathematics/gretl/ChangeLog b/sci-mathematics/gretl/ChangeLog
index 93433417be79..5825f8a004c8 100644
--- a/sci-mathematics/gretl/ChangeLog
+++ b/sci-mathematics/gretl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/gretl
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/ChangeLog,v 1.1 2007/11/07 09:13:18 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/ChangeLog,v 1.2 2007/11/12 18:28:28 bicatali Exp $
+
+ 12 Nov 2007; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/gretl-1.6.5-cli.patch, +files/gretl-1.6.5-nls.patch,
+ gretl-1.6.5.ebuild:
+ Fixed build without nls (bug #198720) and propagate some flags in the
+ command line Makefile.
*gretl-1.6.5 (07 Nov 2007)
diff --git a/sci-mathematics/gretl/files/gretl-1.6.5-cli.patch b/sci-mathematics/gretl/files/gretl-1.6.5-cli.patch
new file mode 100644
index 000000000000..e7b2516bf8bb
--- /dev/null
+++ b/sci-mathematics/gretl/files/gretl-1.6.5-cli.patch
@@ -0,0 +1,38 @@
+--- cli/Makefile.in.orig 2007-03-09 02:04:36.000000000 +0000
++++ cli/Makefile.in 2007-11-12 18:21:33.174356459 +0000
+@@ -10,12 +10,16 @@
+ exec_prefix = @exec_prefix@
+ bindir = @bindir@
+ datadir = @datadir@
+-localedir = $(datadir)/locale
++localedir = $(prefix)/share/locale
+
+ have_readline = @have_readline@
+ READLINE_LIBS = @READLINE_LIBS@
+ READLINE_CFLAGS = @READLINE_CFLAGS@
+
++CPPFLAGS = @CPPFLAGS@
++LDFLAGS = @LDFLAGS@
++INTL_LIBS = @LTLIBINTL@
++
+ ifeq ($(CC),)
+ CC = gcc
+ endif
+@@ -41,7 +45,7 @@
+
+ DEFS = -DLOCALEDIR=\"$(localedir)\" -DHAVE_CONFIG_H
+
+-override CFLAGS += -I.. -I$(topsrc) -I$(libsrc) $(READLINE_CFLAGS) $(DEFS)
++override CFLAGS += -I.. -I$(topsrc) -I$(libsrc) $(READLINE_CFLAGS) $(DEFS) $(CPPFLAGS)
+
+ CLI = gretlcli
+ LIBTOOL = ../libtool
+@@ -51,7 +55,7 @@
+ $(CC) $(CFLAGS) -MM $< > .deps/$*.d
+
+ $(CLI): .deps $(OBJS)
+- $(LIBTOOL) --mode=link $(CC) -o $@ $(OBJS) $(GRETLLIB) $(READLINE_LIBS)
++ $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o $@ $(OBJS) $(GRETLLIB) $(READLINE_LIBS) $(INTL_LIBS)
+
+ .deps:
+ mkdir $@
diff --git a/sci-mathematics/gretl/files/gretl-1.6.5-nls.patch b/sci-mathematics/gretl/files/gretl-1.6.5-nls.patch
new file mode 100644
index 000000000000..7776c17d6ba7
--- /dev/null
+++ b/sci-mathematics/gretl/files/gretl-1.6.5-nls.patch
@@ -0,0 +1,17 @@
+--- lib/src/interact.c.orig 2007-11-12 17:38:54.708866419 +0000
++++ lib/src/interact.c 2007-11-12 17:40:04.540845917 +0000
+@@ -2443,11 +2443,13 @@
+ #ifdef ENABLE_NLS
+ if (!strcmp(s, "-e") || !strncmp(s, "--english", 9)) {
+ *force_lang = ENGLISH;
++ continue;
+ } else if (!strcmp(s, "-q") || !strncmp(s, "--basque", 8)) {
+ *force_lang = BASQUE;
++ continue;
+ }
+ #endif
+- else if (!strcmp(s, "-b") || !strncmp(s, "--batch", 7)) {
++ if (!strcmp(s, "-b") || !strncmp(s, "--batch", 7)) {
+ opt = OPT_BATCH;
+ } else if (!strcmp(s, "-h") || !strcmp(s, "--help")) {
+ opt = OPT_HELP;
diff --git a/sci-mathematics/gretl/gretl-1.6.5.ebuild b/sci-mathematics/gretl/gretl-1.6.5.ebuild
index 522c6c5e835b..ca97a9327647 100644
--- a/sci-mathematics/gretl/gretl-1.6.5.ebuild
+++ b/sci-mathematics/gretl/gretl-1.6.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/gretl-1.6.5.ebuild,v 1.1 2007/11/07 09:13:18 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/gretl-1.6.5.ebuild,v 1.2 2007/11/12 18:28:28 bicatali Exp $
inherit eutils gnome2
@@ -34,6 +34,15 @@ RDEPEND="dev-libs/libxml2
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # fix when nls not selected (bug #198720)
+ epatch "${FILESDIR}"/${P}-nls.patch
+ # makefile in cli not propagating flags
+ epatch "${FILESDIR}"/${P}-cli.patch
+}
+
src_compile() {
local myconf