summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2007-06-17 13:19:57 +0000
committerSven Wegener <swegener@gentoo.org>2007-06-17 13:19:57 +0000
commita554ac8e89c3c7716a7b338986bb7a311da28c25 (patch)
tree72d06c9f4f4d4021a04986fc5cc785741f444c77
parentStable on amd64 wrt bug 181721 (diff)
downloadgentoo-2-a554ac8e89c3c7716a7b338986bb7a311da28c25.tar.gz
gentoo-2-a554ac8e89c3c7716a7b338986bb7a311da28c25.tar.bz2
gentoo-2-a554ac8e89c3c7716a7b338986bb7a311da28c25.zip
Add a patch to make cfv work with bittorrent-5. Thanks to Kalidarn in bug #169228.
(Portage version: 2.1.3_rc3)
-rw-r--r--app-arch/cfv/ChangeLog9
-rw-r--r--app-arch/cfv/cfv-1.18.1.ebuild17
-rw-r--r--app-arch/cfv/files/cfv-1.18.1-modulefix.patch21
3 files changed, 43 insertions, 4 deletions
diff --git a/app-arch/cfv/ChangeLog b/app-arch/cfv/ChangeLog
index b074cdf5c8a1..b99d1d21bcb5 100644
--- a/app-arch/cfv/ChangeLog
+++ b/app-arch/cfv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/cfv
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cfv/ChangeLog,v 1.25 2006/11/27 22:28:24 drizzt Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cfv/ChangeLog,v 1.26 2007/06/17 13:19:57 swegener Exp $
+
+ 17 Jun 2007; Sven Wegener <swegener@gentoo.org>
+ +files/cfv-1.18.1-modulefix.patch, cfv-1.18.1.ebuild:
+ Add a patch to make cfv work with bittorrent-5. Thanks to Kalidarn in bug
+ #169228.
27 Nov 2006; Timothy Redaelli <drizzt@gentoo.org> cfv-1.18.1.ebuild:
Added ~x86-fbsd keyword.
diff --git a/app-arch/cfv/cfv-1.18.1.ebuild b/app-arch/cfv/cfv-1.18.1.ebuild
index f5f237ef279e..b1505acd381b 100644
--- a/app-arch/cfv/cfv-1.18.1.ebuild
+++ b/app-arch/cfv/cfv-1.18.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cfv/cfv-1.18.1.ebuild,v 1.7 2006/11/27 22:28:24 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cfv/cfv-1.18.1.ebuild,v 1.8 2007/06/17 13:19:57 swegener Exp $
+
+inherit eutils
DESCRIPTION="Utility to test and create .sfv, .csv, .crc and md5sum files"
HOMEPAGE="http://cfv.sourceforge.net/"
@@ -15,6 +17,17 @@ DEPEND=""
RDEPEND="dev-lang/python
dev-python/python-fchksum"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-modulefix.patch
+}
+
+src_compile() {
+ true
+}
+
src_install() {
dobin cfv || die "dobin failed"
doman cfv.1 || die "doman failed"
diff --git a/app-arch/cfv/files/cfv-1.18.1-modulefix.patch b/app-arch/cfv/files/cfv-1.18.1-modulefix.patch
new file mode 100644
index 000000000000..a415a3afc8bb
--- /dev/null
+++ b/app-arch/cfv/files/cfv-1.18.1-modulefix.patch
@@ -0,0 +1,21 @@
+--- branches/cfv-1_x-branch/cfv/cfv 2006/03/28 07:29:01 340
++++ branches/cfv-1_x-branch/cfv/cfv 2007/03/04 01:57:56 401
+@@ -1360,12 +1360,15 @@
+ #---------- .torrent ----------
+ _btimporterror = None
+ try:
+- from BitTorrent import bencode, btformats
++ from BTL import bencode, btformats
+ except ImportError, e1:
+ try:
+- from BitTornado import bencode; from BitTornado.BT1 import btformats
++ from BitTorrent import bencode, btformats
+ except ImportError, e2:
+- _btimporterror = '%s and %s'%(e1,e2)
++ try:
++ from BitTornado import bencode; from BitTornado.BT1 import btformats
++ except ImportError, e3:
++ _btimporterror = '%s and %s and %s'%(e1,e2,e3)
+
+ class Torrent(ChksumType):
+ description = 'BitTorrent metainfo'