summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-09-20 18:24:21 +0000
committerUlrich Müller <ulm@gentoo.org>2010-09-20 18:24:21 +0000
commita5f925c7060d5ac6f27e9e05bac895b0ca51aaa7 (patch)
tree3f6cfc9c9fa125d6d47e396bb70831da2fe7b2b5
parentold (diff)
downloadgentoo-2-a5f925c7060d5ac6f27e9e05bac895b0ca51aaa7.tar.gz
gentoo-2-a5f925c7060d5ac6f27e9e05bac895b0ca51aaa7.tar.bz2
gentoo-2-a5f925c7060d5ac6f27e9e05bac895b0ca51aaa7.zip
Version bump.
(Portage version: 2.2_rc85/cvs/Linux x86_64)
-rw-r--r--app-emacs/emacs-daemon/ChangeLog7
-rw-r--r--app-emacs/emacs-daemon/emacs-daemon-0.18.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/app-emacs/emacs-daemon/ChangeLog b/app-emacs/emacs-daemon/ChangeLog
index 4ba5d76bf9f9..0a537442e7b3 100644
--- a/app-emacs/emacs-daemon/ChangeLog
+++ b/app-emacs/emacs-daemon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/emacs-daemon
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-daemon/ChangeLog,v 1.39 2010/08/13 07:27:36 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-daemon/ChangeLog,v 1.40 2010/09/20 18:24:21 ulm Exp $
+
+*emacs-daemon-0.18 (20 Sep 2010)
+
+ 20 Sep 2010; Ulrich Mueller <ulm@gentoo.org> +emacs-daemon-0.18.ebuild:
+ Version bump. Install example stop script, bug 337829.
12 Aug 2010; Ulrich Mueller <ulm@gentoo.org> emacs-daemon-0.17.ebuild:
Don't create subdir of /var/run.
diff --git a/app-emacs/emacs-daemon/emacs-daemon-0.18.ebuild b/app-emacs/emacs-daemon/emacs-daemon-0.18.ebuild
new file mode 100644
index 000000000000..ffc34553013b
--- /dev/null
+++ b/app-emacs/emacs-daemon/emacs-daemon-0.18.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-daemon/emacs-daemon-0.18.ebuild,v 1.1 2010/09/20 18:24:21 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Gentoo support for Emacs running as a server in the background"
+HOMEPAGE="http://www.gentoo.org/proj/en/lisp/emacs/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=virtual/emacs-23"
+RDEPEND="${DEPEND}"
+
+SITEFILE="10${PN}-gentoo.el"
+
+pkg_setup() {
+ local has_daemon=$(${EMACS} ${EMACSFLAGS} \
+ --eval "(princ (fboundp 'daemonp))")
+ if [ "${has_daemon}" != t ]; then
+ ewarn "Your current Emacs version does not support running as a daemon"
+ ewarn "which is required for ${CATEGORY}/${PN}."
+ ewarn "Use \"eselect emacs\" to select an Emacs version >= 23."
+ fi
+}
+
+src_compile() { :; }
+
+src_install() {
+ newinitd emacs.rc emacs || die
+ newconfd emacs.conf emacs || die
+ exeinto /usr/libexec/emacs
+ doexe emacs-wrapper.sh emacs-stop.sh || die
+ elisp-site-file-install "${SITEFILE}" || die
+ dodoc README ChangeLog || die
+}