summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-04 13:13:38 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-04 13:13:38 +0000
commita6f7a7164d5536af6eb9ea80325f6d0fa64404cf (patch)
tree181afc30518df6eaa266b574b562fcb5dd6d04a9
parentFix autotools handling (pretty broken before). Patch mostly by Jakub Moc in b... (diff)
downloadgentoo-2-a6f7a7164d5536af6eb9ea80325f6d0fa64404cf.tar.gz
gentoo-2-a6f7a7164d5536af6eb9ea80325f6d0fa64404cf.tar.bz2
gentoo-2-a6f7a7164d5536af6eb9ea80325f6d0fa64404cf.zip
Fix autotools handling, patch by Jakub Moc in bug #152215.
(Portage version: 2.1.2_rc4-r5)
-rw-r--r--app-text/vilistextum/ChangeLog8
-rw-r--r--app-text/vilistextum/files/digest-vilistextum-2.6.72
-rw-r--r--app-text/vilistextum/vilistextum-2.6.7.ebuild24
3 files changed, 21 insertions, 13 deletions
diff --git a/app-text/vilistextum/ChangeLog b/app-text/vilistextum/ChangeLog
index 960ae2db74ef..0aebd5db802c 100644
--- a/app-text/vilistextum/ChangeLog
+++ b/app-text/vilistextum/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/vilistextum
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/vilistextum/ChangeLog,v 1.21 2005/10/29 15:20:29 grobian Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/vilistextum/ChangeLog,v 1.22 2007/01/04 13:13:38 flameeyes Exp $
+
+ 04 Jan 2007; Diego Pettenò <flameeyes@gentoo.org>
+ vilistextum-2.6.7.ebuild:
+ Fix autotools handling, patch by Jakub Moc in bug #152215.
29 Oct 2005; Fabian Groffen <grobian@gentoo.org> vilistextum-2.6.7.ebuild:
Marked ~ppc-macos (bug #109438)
diff --git a/app-text/vilistextum/files/digest-vilistextum-2.6.7 b/app-text/vilistextum/files/digest-vilistextum-2.6.7
index aff7f696f042..b07ece9d06dc 100644
--- a/app-text/vilistextum/files/digest-vilistextum-2.6.7
+++ b/app-text/vilistextum/files/digest-vilistextum-2.6.7
@@ -1 +1,3 @@
MD5 e35ae3d99d1f90dd78a2a87adf1db8cf vilistextum-2.6.7.tar.bz2 144815
+RMD160 b12efbf5b2cfc7313ac0406cb4c471f93a791912 vilistextum-2.6.7.tar.bz2 144815
+SHA256 b91746536631530a51150bf4ac6b053659e109b411932065b8a153737498ebf3 vilistextum-2.6.7.tar.bz2 144815
diff --git a/app-text/vilistextum/vilistextum-2.6.7.ebuild b/app-text/vilistextum/vilistextum-2.6.7.ebuild
index 5965c26e76f7..39870fa37d9e 100644
--- a/app-text/vilistextum/vilistextum-2.6.7.ebuild
+++ b/app-text/vilistextum/vilistextum-2.6.7.ebuild
@@ -1,8 +1,11 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/vilistextum/vilistextum-2.6.7.ebuild,v 1.8 2005/10/29 15:20:29 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/vilistextum/vilistextum-2.6.7.ebuild,v 1.9 2007/01/04 13:13:38 flameeyes Exp $
-inherit eutils
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit eutils autotools
DESCRIPTION="Vilistextum is a html to ascii converter specifically programmed to get the best out of incorrect html."
HOMEPAGE="http://bhaak.dyndns.org/vilistextum/"
@@ -14,21 +17,20 @@ SLOT="0"
IUSE="unicode"
KEYWORDS="amd64 ppc ~ppc-macos sparc x86"
-DEPEND="virtual/libc"
+DEPEND=""
# KDE support will be available once a version of kaptain in stable
-# kde? ( kde-misc/kaptain )"
+# kde? ( kde-misc/kaptain )"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-gentoo.diff
- epatch ${FILESDIR}/${P}-use-glibc-iconv.diff
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gentoo.diff"
+ epatch "${FILESDIR}/${P}-use-glibc-iconv.diff"
+
+ eautoreconf
}
src_compile() {
- einfo "Running autoreconf"
- autoreconf -f -i || die "autoreconf failed"
-
econf \
$(use_enable unicode multibyte) \
|| die "econf failed"