summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-01-06 14:37:18 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-01-06 14:37:18 +0000
commitafb5251a71471de3cf3f0b755d29bbb25aeca09e (patch)
tree47563de95642e56dbddcdef9e1b2b6c070957ac6
parentUpdated DESCRIPTION var (diff)
downloadgentoo-2-afb5251a71471de3cf3f0b755d29bbb25aeca09e.tar.gz
gentoo-2-afb5251a71471de3cf3f0b755d29bbb25aeca09e.tar.bz2
gentoo-2-afb5251a71471de3cf3f0b755d29bbb25aeca09e.zip
version bump
(Portage version: 2.2_rc20/cvs/Linux 2.6.27.10 x86_64)
-rw-r--r--net-misc/wicd/ChangeLog12
-rw-r--r--net-misc/wicd/wicd-1.5.8.ebuild54
2 files changed, 64 insertions, 2 deletions
diff --git a/net-misc/wicd/ChangeLog b/net-misc/wicd/ChangeLog
index f8d8a01e81c5..b3ed4928c993 100644
--- a/net-misc/wicd/ChangeLog
+++ b/net-misc/wicd/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/wicd
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/ChangeLog,v 1.29 2008/12/26 17:43:12 darkside Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/ChangeLog,v 1.30 2009/01/06 14:37:18 darkside Exp $
+
+*wicd-1.5.8 (06 Jan 2009)
+
+ 06 Jan 2009; Jeremy Olexa <darkside@gentoo.org> +wicd-1.5.8.ebuild:
+ Version bump:
+ 1.5.8
+ * Improved pm-utils support
+ * Improved UTF-8 support
26 Dec 2008; Jeremy Olexa <darkside@gentoo.org> wicd-1.5.7-r1.ebuild:
Drop pm-utils dep down to >=pm-utils-1.1.1, bug #252306
diff --git a/net-misc/wicd/wicd-1.5.8.ebuild b/net-misc/wicd/wicd-1.5.8.ebuild
new file mode 100644
index 000000000000..b41acdfd69aa
--- /dev/null
+++ b/net-misc/wicd/wicd-1.5.8.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/wicd-1.5.8.ebuild,v 1.1 2009/01/06 14:37:18 darkside Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="A lightweight wired and wireless network manager for Linux"
+HOMEPAGE="http://wicd.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-python/dbus-python
+ dev-python/pygtk
+ || (
+ net-misc/dhcpcd
+ net-misc/dhcp
+ net-misc/pump
+ )
+ net-wireless/wireless-tools
+ net-wireless/wpa_supplicant
+ || (
+ sys-apps/net-tools
+ sys-apps/ethtool
+ )
+ || ( x11-misc/ktsuss x11-libs/gksu kde-base/kdesu )
+ >=sys-power/pm-utils-1.1.1"
+
+src_compile() {
+ ${python} ./setup.py configure --no-install-init --no-install-docs --resume=/usr/share/wicd/scripts/ --suspend=/usr/share/wicd/scripts/ --verbose
+ distutils_src_compile
+}
+
+src_install() {
+ DOCS="CHANGES"
+ distutils_src_install
+ newinitd "${FILESDIR}/wicd-init.d" wicd || die "newinitd failed"
+ keepdir /var/lib/wicd/configurations || die "keepdir failed, critical for this app"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog "You may need to restart the dbus service after upgrading wicd."
+ echo
+ elog "To start wicd at boot, add /etc/init.d/wicd to a runlevel and:"
+ elog "- Remove all net.* initscripts (except for net.lo) from all runlevels"
+ elog "- Add these scripts to the RC_PLUG_SERVICES line in /etc/conf.d/rc"
+ elog "(For example, RC_PLUG_SERVICES=\"!net.eth0 !net.wlan0\")"
+}