summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2011-12-26 13:22:55 +0000
committerPatrick Lauer <patrick@gentoo.org>2011-12-26 13:22:55 +0000
commitb9f5c633f93908e76eafda6876429b0eef67b1cf (patch)
treef1fceee3dc13c95353ffcfff02a38e37d26c1125
parentCleaned old (diff)
downloadgentoo-2-b9f5c633f93908e76eafda6876429b0eef67b1cf.tar.gz
gentoo-2-b9f5c633f93908e76eafda6876429b0eef67b1cf.tar.bz2
gentoo-2-b9f5c633f93908e76eafda6876429b0eef67b1cf.zip
Bump for #389639
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
-rw-r--r--dev-python/mwlib/ChangeLog9
-rw-r--r--dev-python/mwlib/mwlib-0.12.17.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/dev-python/mwlib/ChangeLog b/dev-python/mwlib/ChangeLog
index 1a76928c560d..f8fa4fa2e0dd 100644
--- a/dev-python/mwlib/ChangeLog
+++ b/dev-python/mwlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/mwlib
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mwlib/ChangeLog,v 1.8 2010/10/30 05:20:00 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mwlib/ChangeLog,v 1.9 2011/12/26 13:22:55 patrick Exp $
+
+*mwlib-0.12.17 (26 Dec 2011)
+
+ 26 Dec 2011; Patrick Lauer <patrick@gentoo.org> +mwlib-0.12.17.ebuild:
+ Bump for #389639
30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
mwlib-0.12.13.ebuild:
diff --git a/dev-python/mwlib/mwlib-0.12.17.ebuild b/dev-python/mwlib/mwlib-0.12.17.ebuild
new file mode 100644
index 000000000000..75a17ecbfa5b
--- /dev/null
+++ b/dev-python/mwlib/mwlib-0.12.17.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mwlib/mwlib-0.12.17.ebuild,v 1.1 2011/12/26 13:22:55 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+inherit distutils
+
+DESCRIPTION="Tools for parsing Mediawiki content to other formats"
+HOMEPAGE="http://code.pediapress.com/wiki/wiki http://pypi.python.org/pypi/mwlib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ >=dev-python/flup-1.0
+ dev-python/imaging
+ >=dev-python/lockfile-0.8
+ dev-python/lxml
+ =dev-python/odfpy-0.9*
+ >=dev-python/pyPdf-1.12
+ >=dev-python/pyparsing-1.4.11
+ >=dev-python/timelib-0.2
+ >=dev-python/twisted-9.0.0-r1
+ >=dev-python/twisted-web-9.0.0
+ >=dev-python/webob-0.9
+ virtual/latex-base
+ || ( dev-lang/python:2.7 dev-lang/python:2.6 >=dev-python/simplejson-1.3 )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")