summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-10-22 21:10:42 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-10-22 21:10:42 +0000
commitbaf6694ce57c9ddb9ac4723f0dd22ee03a926a3e (patch)
tree2dbcc0c3a1ff3921e18197b933ce819987601a22
parentFix quoting, re-fix bug #238727 (diff)
downloadgentoo-2-baf6694ce57c9ddb9ac4723f0dd22ee03a926a3e.tar.gz
gentoo-2-baf6694ce57c9ddb9ac4723f0dd22ee03a926a3e.tar.bz2
gentoo-2-baf6694ce57c9ddb9ac4723f0dd22ee03a926a3e.zip
Bump to 0.24.1, updated icons and translations.
(Portage version: 2.2_rc12/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
-rw-r--r--net-irc/xchat-gnome/ChangeLog8
-rw-r--r--net-irc/xchat-gnome/xchat-gnome-0.24.1.ebuild65
2 files changed, 72 insertions, 1 deletions
diff --git a/net-irc/xchat-gnome/ChangeLog b/net-irc/xchat-gnome/ChangeLog
index c1f9e5730de8..acb182b304b0 100644
--- a/net-irc/xchat-gnome/ChangeLog
+++ b/net-irc/xchat-gnome/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/xchat-gnome
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-gnome/ChangeLog,v 1.38 2008/10/15 21:17:52 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-gnome/ChangeLog,v 1.39 2008/10/22 21:10:42 eva Exp $
+
+*xchat-gnome-0.24.1 (22 Oct 2008)
+
+ 22 Oct 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +xchat-gnome-0.24.1.ebuild:
+ Bump to 0.24.1, updated icons and translations.
*xchat-gnome-0.24.0 (15 Oct 2008)
diff --git a/net-irc/xchat-gnome/xchat-gnome-0.24.1.ebuild b/net-irc/xchat-gnome/xchat-gnome-0.24.1.ebuild
new file mode 100644
index 000000000000..a25a9d1801d1
--- /dev/null
+++ b/net-irc/xchat-gnome/xchat-gnome-0.24.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-gnome/xchat-gnome-0.24.1.ebuild,v 1.1 2008/10/22 21:10:42 eva Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="GNOME frontend for the popular X-Chat IRC client"
+HOMEPAGE="http://xchat-gnome.navi.cx/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="dbus ipv6 libnotify mmx nls perl python sound spell ssl tcl"
+
+RDEPEND=">=dev-libs/glib-2.18.0
+ >=gnome-base/libgnome-2.16.0
+ >=gnome-base/gconf-2.8.0
+ >=gnome-base/libgnomeui-2.16.0
+ >=gnome-base/libglade-2.3.2
+ >=x11-libs/gtk+-2.14.0
+ spell? ( app-text/enchant )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ python? ( dev-lang/python )
+ tcl? ( dev-lang/tcl )
+ dbus? ( >=sys-apps/dbus-0.60 )
+ >=x11-libs/libsexy-0.1.11
+ libnotify? ( >=x11-libs/libnotify-0.3.2 )
+ sound? ( >=media-libs/libcanberra-0.3 )
+ x11-libs/libX11"
+
+DEPEND="${RDEPEND}
+ gnome-base/gnome-common
+ >=dev-util/pkgconfig-0.7
+ >=app-text/gnome-doc-utils-0.3.2
+ nls? ( sys-devel/gettext )"
+
+# gnome-base/gnome-common is temporarily needed for re-creating configure
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-gnomefe
+ --enable-shm
+ --disable-schemas-install
+ --disable-scrollkeeper
+ $(use_enable ssl openssl)
+ $(use_enable perl)
+ $(use_enable python)
+ $(use_enable tcl)
+ $(use_enable mmx)
+ $(use_enable ipv6)
+ $(use_enable dbus)
+ $(use_enable nls)
+ $(use_enable libnotify notification)"
+}
+
+src_install() {
+ gnome2_src_install
+
+ # install plugin development header
+ insinto /usr/include/xchat-gnome
+ doins src/common/xchat-plugin.h || die "doins failed"
+
+ dodoc AUTHORS ChangeLog NEWS || die "dodoc failed"
+}