summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2013-02-02 12:39:58 +0000
committerDaniel Pielmeier <billie@gentoo.org>2013-02-02 12:39:58 +0000
commitc1fc2b9a2a4db9667f805c92086717864841fb8d (patch)
tree515141f150a4a9ae03d550081879046d768ffadb
parentDrop old (diff)
downloadgentoo-2-c1fc2b9a2a4db9667f805c92086717864841fb8d.tar.gz
gentoo-2-c1fc2b9a2a4db9667f805c92086717864841fb8d.tar.bz2
gentoo-2-c1fc2b9a2a4db9667f805c92086717864841fb8d.zip
Revison bump. Switch to EAPI 5 and distutils-r1.
(Portage version: 2.1.11.31/cvs/Linux i686, signed Manifest commit with key 215AD14D)
-rw-r--r--app-portage/pfl/ChangeLog9
-rw-r--r--app-portage/pfl/pfl-2.3-r1.ebuild4
-rw-r--r--app-portage/pfl/pfl-2.3-r2.ebuild43
-rw-r--r--app-portage/pfl/pfl-2.3.ebuild4
4 files changed, 54 insertions, 6 deletions
diff --git a/app-portage/pfl/ChangeLog b/app-portage/pfl/ChangeLog
index f2e0585e0bcc..0d0141f61fed 100644
--- a/app-portage/pfl/ChangeLog
+++ b/app-portage/pfl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/pfl
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/pfl/ChangeLog,v 1.45 2012/08/05 14:09:15 ryao Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/pfl/ChangeLog,v 1.46 2013/02/02 12:39:57 billie Exp $
+
+*pfl-2.3-r2 (02 Feb 2013)
+
+ 02 Feb 2013; Daniel Pielmeier <billie@gentoo.org> +pfl-2.3-r2.ebuild:
+ Revison bump. Switch to EAPI 5 and distutils-r1.
05 Aug 2012; Richard Yao <ryao@gentoo.org> pfl-2.3-r1.ebuild:
Keyword ~x64-freebsd
diff --git a/app-portage/pfl/pfl-2.3-r1.ebuild b/app-portage/pfl/pfl-2.3-r1.ebuild
index cdefe4e32329..3592cc819953 100644
--- a/app-portage/pfl/pfl-2.3-r1.ebuild
+++ b/app-portage/pfl/pfl-2.3-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/pfl/pfl-2.3-r1.ebuild,v 1.4 2012/08/05 14:09:15 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/pfl/pfl-2.3-r1.ebuild,v 1.5 2013/02/02 12:39:57 billie Exp $
EAPI=4
diff --git a/app-portage/pfl/pfl-2.3-r2.ebuild b/app-portage/pfl/pfl-2.3-r2.ebuild
new file mode 100644
index 000000000000..ab26bf0c8251
--- /dev/null
+++ b/app-portage/pfl/pfl-2.3-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/pfl/pfl-2.3-r2.ebuild,v 1.1 2013/02/02 12:39:57 billie Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1
+
+DESCRIPTION="Searchable online file/package database for Gentoo"
+HOMEPAGE="http://www.portagefilelist.de"
+SRC_URI="http://files.portagefilelist.de/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86 ~amd64-fbsd ~x64-freebsd"
+IUSE="+network-cron"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ net-misc/curl
+ sys-apps/portage"
+
+src_install() {
+ distutils-r1_src_install
+
+ if use network-cron ; then
+ exeinto /etc/cron.weekly
+ doexe cron/pfl
+ fi
+
+ keepdir /var/lib/${PN}
+}
+
+pkg_postinst() {
+ if [[ ! -e "${EROOT%/}/var/lib/${PN}/pfl.info" ]]; then
+ touch "${EROOT%/}/var/lib/${PN}/pfl.info"
+ chown -R 0:portage "${EROOT%/}/var/lib/${PN}"
+ chmod 775 "${EROOT%/}/var/lib/${PN}"
+ fi
+}
diff --git a/app-portage/pfl/pfl-2.3.ebuild b/app-portage/pfl/pfl-2.3.ebuild
index d70dbc8c3bbe..22b5d0aec6a6 100644
--- a/app-portage/pfl/pfl-2.3.ebuild
+++ b/app-portage/pfl/pfl-2.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/pfl/pfl-2.3.ebuild,v 1.7 2012/03/18 15:19:04 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/pfl/pfl-2.3.ebuild,v 1.8 2013/02/02 12:39:58 billie Exp $
EAPI=4