summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-07-06 20:10:00 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-07-06 20:10:00 +0000
commitc31483f05923c2de4da84c7a104e68d3c1455373 (patch)
treedb49d0fb9594d8a370e27e70edd0c1b3ce1758ef
parentVersion bump. (diff)
downloadgentoo-2-c31483f05923c2de4da84c7a104e68d3c1455373.tar.gz
gentoo-2-c31483f05923c2de4da84c7a104e68d3c1455373.tar.bz2
gentoo-2-c31483f05923c2de4da84c7a104e68d3c1455373.zip
Revbump with patch for libmtp-0.3.0 API change
(Portage version: 2.2_rc1/cvs/Linux 2.6.25.8 i686)
-rw-r--r--media-sound/rhythmbox/ChangeLog9
-rw-r--r--media-sound/rhythmbox/files/rhythmbox-0.11.5-libmtp-0.3.0-API.patch11
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.11.5-r1.ebuild145
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.11.5.ebuild4
4 files changed, 166 insertions, 3 deletions
diff --git a/media-sound/rhythmbox/ChangeLog b/media-sound/rhythmbox/ChangeLog
index 71695bad30fa..a1a813cbdc0c 100644
--- a/media-sound/rhythmbox/ChangeLog
+++ b/media-sound/rhythmbox/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/rhythmbox
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.126 2008/05/29 17:20:54 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.127 2008/07/06 20:10:00 loki_val Exp $
+
+*rhythmbox-0.11.5-r1 (06 Jul 2008)
+
+ 06 Jul 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/rhythmbox-0.11.5-libmtp-0.3.0-API.patch, rhythmbox-0.11.5.ebuild,
+ +rhythmbox-0.11.5-r1.ebuild:
+ Revbump with patch for libmtp-0.3.0 API change
29 May 2008; Ali Polatel <hawking@gentoo.org> rhythmbox-0.11.5.ebuild:
python_mod_optimize is ROOT aware.
diff --git a/media-sound/rhythmbox/files/rhythmbox-0.11.5-libmtp-0.3.0-API.patch b/media-sound/rhythmbox/files/rhythmbox-0.11.5-libmtp-0.3.0-API.patch
new file mode 100644
index 000000000000..523c9c2e21a0
--- /dev/null
+++ b/media-sound/rhythmbox/files/rhythmbox-0.11.5-libmtp-0.3.0-API.patch
@@ -0,0 +1,11 @@
+--- plugins/mtpdevice/rb-mtp-source.c
++++ plugins/mtpdevice/rb-mtp-source.c
+@@ -681,7 +681,7 @@
+ trackmeta->filetype = mimetype_to_filetype (mimetype);
+ }
+
+- if (LIBMTP_Send_Track_From_File (device, filename, trackmeta, NULL, NULL, 0) != 0) {
++ if (LIBMTP_Send_Track_From_File (device, filename, trackmeta, NULL, NULL) != 0) {
+ LIBMTP_destroy_track_t (trackmeta);
+ rb_debug ("Tracktransfer failed\n");
+ return NULL;
diff --git a/media-sound/rhythmbox/rhythmbox-0.11.5-r1.ebuild b/media-sound/rhythmbox/rhythmbox-0.11.5-r1.ebuild
new file mode 100644
index 000000000000..a97816b6c2a5
--- /dev/null
+++ b/media-sound/rhythmbox/rhythmbox-0.11.5-r1.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.11.5-r1.ebuild,v 1.1 2008/07/06 20:10:00 loki_val Exp $
+
+EAPI="1"
+
+inherit gnome2 eutils python autotools
+
+DESCRIPTION="Music management and playback software for GNOME"
+HOMEPAGE="http://www.rhythmbox.org/"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
+IUSE="daap dbus doc hal ipod gnome-keyring libnotify lirc musicbrainz mtp python tagwriting"
+
+# I want tagwriting to be on by default in the future. It is just a local flag
+# now because it is still considered experimental by upstream and doesn't work
+# well with all formats due to gstreamer limitation.
+
+# FIXME: double check what to do with fm-radio plugin an itunes browser
+
+SLOT="0"
+
+RDEPEND=">=x11-libs/gtk+-2.8
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libglade-2
+ >=gnome-base/gnome-vfs-2.8
+ >=dev-libs/totem-pl-parser-2.21.4
+ >=gnome-extra/nautilus-cd-burner-2.13
+ >=x11-libs/libsexy-0.1.5
+ >=gnome-extra/gnome-media-2.14.0
+ gnome-keyring? ( >=gnome-base/gnome-keyring-0.4.9 )
+ musicbrainz? ( >=media-libs/musicbrainz-2.1:1 )
+ >=net-libs/libsoup-2.4:2.4
+ lirc? ( app-misc/lirc )
+ hal? (
+ ipod? ( >=media-libs/libgpod-0.4 )
+ mtp? ( >=media-libs/libmtp-0.3.0 )
+ >=sys-apps/hal-0.5
+ )
+ daap? ( >=net-dns/avahi-0.6 )
+ dbus? ( >=dev-libs/dbus-glib-0.71 )
+ >=media-libs/gst-plugins-base-0.10.12
+ >=media-plugins/gst-plugins-gnomevfs-0.10
+ || (
+ >=media-plugins/gst-plugins-cdparanoia-0.10
+ >=media-plugins/gst-plugins-cdio-0.10
+ )
+ >=media-plugins/gst-plugins-meta-0.10-r2:0.10
+ libnotify? ( >=x11-libs/libnotify-0.3.2 )
+ tagwriting? ( >=media-plugins/gst-plugins-taglib-0.10.6 )
+ python? (
+ >=dev-lang/python-2.4.2
+ >=dev-python/pygtk-2.8
+ >=dev-python/gnome-python-2.12
+ >=dev-python/gst-python-0.10.8
+ )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35
+ app-text/scrollkeeper
+ app-text/gnome-doc-utils
+ doc? ( >=dev-util/gtk-doc-1.4 )"
+
+DOCS="AUTHORS ChangeLog DOCUMENTERS INTERNALS \
+ MAINTAINERS NEWS README README.iPod THANKS TODO"
+
+pkg_setup() {
+
+ if ! use hal && use ipod; then
+ ewarn "ipod support requires hal support. Please"
+ ewarn "re-emerge with USE=hal to enable ipod support"
+ fi
+
+ if ! use hal && use mtp; then
+ ewarn "MTP support requires hal support. Please"
+ ewarn "re-emerge with USE=hal to enable MTP support"
+ fi
+
+ if use daap ; then
+ G2CONF="${G2CONF} --enable-daap --with-mdns=avahi"
+ else
+ G2CONF="${G2CONF} --disable-daap"
+ fi
+
+ G2CONF="${G2CONF}
+ $(use_enable tagwriting tag-writing)
+ $(use_with ipod)
+ $(use_enable ipod ipod-writing)
+ $(use_enable musicbrainz)
+ $(use_with dbus)
+ $(use_enable python)
+ $(use_enable libnotify)
+ $(use_enable lirc)
+ $(use_with gnome-keyring)
+ --with-playback=gstreamer-0-10
+ --with-cd-burning
+ --enable-mmkeys
+ --enable-audioscrobbler
+ --enable-track-transfer
+ --with-metadata-helper
+ --disable-scrollkeeper
+ --disable-schemas-install"
+
+ export GST_INSPECT=/bin/true
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # backport from svn HEAD, 0.11.6 shouldn't need it
+ epatch "${FILESDIR}/${PN}-0.11.5-fix_gtk_doc.patch"
+ #Fix for libmtp-0.3.0 API change
+ epatch "${FILESDIR}/${P}-libmtp-0.3.0-API.patch"
+ eautomake
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+src_compile() {
+ addpredict "$(unset HOME; echo ~)/.gconf"
+ addpredict "$(unset HOME; echo ~)/.gconfd"
+ gnome2_src_compile
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ use python && python_mod_optimize /usr/$(get_libdir)/rhythmbox/plugins
+
+ ewarn
+ ewarn "If ${PN} doesn't play some music format, please check your"
+ ewarn "USE flags on media-plugins/gst-plugins-meta"
+ ewarn
+
+ elog "The aac flag has been removed from rhythmbox."
+ elog "This is due to stabilization issues with any gst-bad plugins."
+ elog "Please emerge gst-plugins-bad and gst-plugins-faad to be able to play m4a files"
+ elog "See bug #159538 for more information"
+}
+pkg_postrm() {
+ gnome2_pkg_postrm
+ use python && python_mod_cleanup /usr/$(get_libdir)/rhythmbox/plugins
+}
diff --git a/media-sound/rhythmbox/rhythmbox-0.11.5.ebuild b/media-sound/rhythmbox/rhythmbox-0.11.5.ebuild
index 202e41c87b03..798d8c765cf0 100644
--- a/media-sound/rhythmbox/rhythmbox-0.11.5.ebuild
+++ b/media-sound/rhythmbox/rhythmbox-0.11.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.11.5.ebuild,v 1.8 2008/05/29 17:20:54 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.11.5.ebuild,v 1.9 2008/07/06 20:10:00 loki_val Exp $
EAPI="1"
@@ -34,7 +34,7 @@ RDEPEND=">=x11-libs/gtk+-2.8
lirc? ( app-misc/lirc )
hal? (
ipod? ( >=media-libs/libgpod-0.4 )
- mtp? ( media-libs/libmtp )
+ mtp? ( <media-libs/libmtp-0.3.0 )
>=sys-apps/hal-0.5
)
daap? ( >=net-dns/avahi-0.6 )