summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-05-25 23:52:37 +0000
committerJeroen Roovers <jer@gentoo.org>2014-05-25 23:52:37 +0000
commitc4f2052a45d3b4ecb8c896937cc9180c7e3fda55 (patch)
tree5d2c19b46274da117001fbff5e4474405099ade8
parentVersion bump (diff)
downloadgentoo-2-c4f2052a45d3b4ecb8c896937cc9180c7e3fda55.tar.gz
gentoo-2-c4f2052a45d3b4ecb8c896937cc9180c7e3fda55.tar.bz2
gentoo-2-c4f2052a45d3b4ecb8c896937cc9180c7e3fda55.zip
Old.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
-rw-r--r--app-arch/dpkg/ChangeLog8
-rw-r--r--app-arch/dpkg/dpkg-1.16.12-r1.ebuild96
-rw-r--r--app-arch/dpkg/dpkg-1.17.4.ebuild95
-rw-r--r--app-arch/dpkg/dpkg-1.17.5.ebuild95
-rw-r--r--app-arch/dpkg/dpkg-1.17.6.ebuild95
-rw-r--r--app-arch/dpkg/dpkg-1.17.7.ebuild96
-rw-r--r--app-arch/dpkg/dpkg-1.17.8.ebuild96
-rw-r--r--app-arch/dpkg/files/dpkg-1.16.4.2-gzip-rsyncable.patch11
8 files changed, 7 insertions, 585 deletions
diff --git a/app-arch/dpkg/ChangeLog b/app-arch/dpkg/ChangeLog
index f0b11253a389..aded6843b63f 100644
--- a/app-arch/dpkg/ChangeLog
+++ b/app-arch/dpkg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/dpkg
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.270 2014/05/25 18:49:56 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.271 2014/05/25 23:52:36 jer Exp $
+
+ 25 May 2014; Jeroen Roovers <jer@gentoo.org> -dpkg-1.16.12-r1.ebuild,
+ -dpkg-1.17.4.ebuild, -dpkg-1.17.5.ebuild, -dpkg-1.17.6.ebuild,
+ -dpkg-1.17.7.ebuild, -dpkg-1.17.8.ebuild,
+ -files/dpkg-1.16.4.2-gzip-rsyncable.patch:
+ Old.
25 May 2014; Markus Meier <maekke@gentoo.org> dpkg-1.17.9.ebuild:
arm stable, bug #509018
diff --git a/app-arch/dpkg/dpkg-1.16.12-r1.ebuild b/app-arch/dpkg/dpkg-1.16.12-r1.ebuild
deleted file mode 100644
index df8b85ef0c2d..000000000000
--- a/app-arch/dpkg/dpkg-1.16.12-r1.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.16.12-r1.ebuild,v 1.10 2014/01/18 19:56:07 ago Exp $
-
-EAPI=4
-inherit eutils multilib autotools toolchain-funcs
-
-DESCRIPTION="Package maintenance system for Debian"
-HOMEPAGE="http://packages.qa.debian.org/dpkg"
-SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
-IUSE="bzip2 dselect nls test unicode zlib"
-
-LANGS="
- ast bs ca cs da de dz el eo es et eu fr gl hu id it ja km ko ku lt mr nb ne
- nl nn pa pl pt_BR pt ro ru sk sv th tl vi zh_CN zh_TW
-"
-
-for X in ${LANGS} ; do
- IUSE="${IUSE} linguas_${X}"
-done
-
-RDEPEND=">=dev-lang/perl-5.6.0
- dev-perl/TimeDate
- >=sys-libs/ncurses-5.2-r7
- zlib? ( >=sys-libs/zlib-1.1.4 )
- bzip2? ( app-arch/bzip2 )"
-DEPEND="${RDEPEND}
- app-arch/xz-utils
- nls? ( app-text/po4a )
- sys-devel/flex
- virtual/pkgconfig
- test? (
- dev-perl/DateTime-Format-DateParse
- dev-perl/IO-String
- dev-perl/Test-Pod
- )"
-REQUIRED_USE="dselect? ( nls )"
-
-src_prepare() {
- # do not expect Debian's gzip --rsyncable extension
- epatch "${FILESDIR}"/${PN}-1.16.4.2-gzip-rsyncable.patch
-
- epatch "${FILESDIR}"/${PN}-1.17.1-flags.patch
-
- # Force the use of the running bash for get-version (this file is never
- # installed, so no need to worry about hardcoding a temporary bash)
- sed -i -e '1c\#!'"${BASH}" get-version || die
-
- # this test depends on a Debian only gzip extension that adds --rsyncable
- # which will therefore always fail on Gentoo. (bug #310847).
- sed -i scripts/Makefile.am \
- -e '/850_Dpkg_Compression.t/d' \
- || die "sed failed"
-
- # test fails (bug #414095)
- sed -i utils/Makefile.am \
- -e '/^test_cases/d;/100_update_alternatives/d' || die
-
- eautoreconf
-}
-
-src_configure() {
- tc-export CC
- econf \
- $(use_enable dselect) \
- $(use_enable unicode) \
- $(use_with bzip2 bz2) \
- $(use_with zlib) \
- ${myconf} \
- --disable-compiler-warnings \
- --disable-silent-rules \
- --disable-start-stop-daemon \
- --localstatedir="${EPREFIX}"/var \
- --without-selinux
-}
-
-src_compile() {
- emake AR=$(tc-getAR)
-}
-
-src_install() {
- strip-linguas ${LANGS}
- if [ -z "${LINGUAS}" ] ; then
- LINGUAS=none
- fi
-
- emake DESTDIR="${D}" LINGUAS="${LINGUAS}" install
- rm "${ED}"/usr/sbin/install-info || die "rm install-info failed"
- dodoc ChangeLog THANKS TODO
- keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
- keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
-}
diff --git a/app-arch/dpkg/dpkg-1.17.4.ebuild b/app-arch/dpkg/dpkg-1.17.4.ebuild
deleted file mode 100644
index e72af097006b..000000000000
--- a/app-arch/dpkg/dpkg-1.17.4.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.17.4.ebuild,v 1.1 2013/12/07 13:38:39 jer Exp $
-
-EAPI=5
-inherit eutils multilib autotools toolchain-funcs
-
-DESCRIPTION="Package maintenance system for Debian"
-HOMEPAGE="http://packages.qa.debian.org/dpkg"
-SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
-IUSE="+bzip2 dselect +lzma nls test unicode +update-alternatives +zlib"
-REQUIRED_USE="dselect? ( nls )"
-
-RDEPEND="
- >=dev-lang/perl-5.6.0
- dev-perl/TimeDate
- >=sys-libs/ncurses-5.2-r7
- lzma? ( app-arch/xz-utils )
- zlib? ( >=sys-libs/zlib-1.1.4 )
- bzip2? ( app-arch/bzip2 )
-"
-DEPEND="
- ${RDEPEND}
- app-arch/xz-utils
- sys-devel/flex
- virtual/pkgconfig
- nls? (
- app-text/po4a
- >=sys-devel/gettext-0.18.2
- )
- test? (
- dev-perl/DateTime-Format-DateParse
- dev-perl/IO-String
- dev-perl/Test-Pod
- )
-"
-
-DOCS=( ChangeLog THANKS TODO )
-
-src_prepare() {
- # do not expect Debian's gzip --rsyncable extension
- epatch "${FILESDIR}"/${PN}-1.17.0-gzip-rsyncable.patch
-
- epatch "${FILESDIR}"/${PN}-1.17.1-flags.patch
-
- # Force the use of the running bash for get-version (this file is never
- # installed, so no need to worry about hardcoding a temporary bash)
- sed -i -e '1c\#!'"${BASH}" get-version || die
-
- # this test depends on a Debian only gzip extension that adds --rsyncable
- # which will therefore always fail on Gentoo. (bug #310847).
- sed -i scripts/Makefile.am \
- -e '/850_Dpkg_Compression.t/d' \
- || die "sed failed"
-
- # test fails (bug #414095)
- sed -i utils/Makefile.am \
- -e '/^test_cases/d;/100_update_alternatives/d' || die
-
- use nls && strip-linguas -i po
-
- eautoreconf
-}
-
-src_configure() {
- tc-export CC
- econf \
- $(use_enable dselect) \
- $(use_enable nls) \
- $(use_enable unicode) \
- $(use_enable update-alternatives) \
- $(use_with bzip2 bz2) \
- $(use_with zlib) \
- $(use_with lzma liblzma) \
- --disable-compiler-warnings \
- --disable-silent-rules \
- --disable-start-stop-daemon \
- --localstatedir="${EPREFIX}"/var \
- --without-selinux
-}
-
-src_compile() {
- emake AR=$(tc-getAR)
-}
-
-src_install() {
- default
-
- keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
- keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
-}
diff --git a/app-arch/dpkg/dpkg-1.17.5.ebuild b/app-arch/dpkg/dpkg-1.17.5.ebuild
deleted file mode 100644
index aa656e60e4c7..000000000000
--- a/app-arch/dpkg/dpkg-1.17.5.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.17.5.ebuild,v 1.1 2013/12/12 15:25:25 jer Exp $
-
-EAPI=5
-inherit eutils multilib autotools toolchain-funcs
-
-DESCRIPTION="Package maintenance system for Debian"
-HOMEPAGE="http://packages.qa.debian.org/dpkg"
-SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
-IUSE="+bzip2 dselect +lzma nls test unicode +update-alternatives +zlib"
-REQUIRED_USE="dselect? ( nls )"
-
-RDEPEND="
- >=dev-lang/perl-5.6.0
- dev-perl/TimeDate
- >=sys-libs/ncurses-5.2-r7
- lzma? ( app-arch/xz-utils )
- zlib? ( >=sys-libs/zlib-1.1.4 )
- bzip2? ( app-arch/bzip2 )
-"
-DEPEND="
- ${RDEPEND}
- app-arch/xz-utils
- sys-devel/flex
- virtual/pkgconfig
- nls? (
- app-text/po4a
- >=sys-devel/gettext-0.18.2
- )
- test? (
- dev-perl/DateTime-Format-DateParse
- dev-perl/IO-String
- dev-perl/Test-Pod
- )
-"
-
-DOCS=( ChangeLog THANKS TODO )
-
-src_prepare() {
- # do not expect Debian's gzip --rsyncable extension
- epatch "${FILESDIR}"/${PN}-1.17.0-gzip-rsyncable.patch
-
- epatch "${FILESDIR}"/${PN}-1.17.1-flags.patch
-
- # Force the use of the running bash for get-version (this file is never
- # installed, so no need to worry about hardcoding a temporary bash)
- sed -i -e '1c\#!'"${BASH}" get-version || die
-
- # this test depends on a Debian only gzip extension that adds --rsyncable
- # which will therefore always fail on Gentoo. (bug #310847).
- sed -i scripts/Makefile.am \
- -e '/850_Dpkg_Compression.t/d' \
- || die "sed failed"
-
- # test fails (bug #414095)
- sed -i utils/Makefile.am \
- -e '/^test_cases/d;/100_update_alternatives/d' || die
-
- use nls && strip-linguas -i po
-
- eautoreconf
-}
-
-src_configure() {
- tc-export CC
- econf \
- $(use_enable dselect) \
- $(use_enable nls) \
- $(use_enable unicode) \
- $(use_enable update-alternatives) \
- $(use_with bzip2 bz2) \
- $(use_with zlib) \
- $(use_with lzma liblzma) \
- --disable-compiler-warnings \
- --disable-silent-rules \
- --disable-start-stop-daemon \
- --localstatedir="${EPREFIX}"/var \
- --without-selinux
-}
-
-src_compile() {
- emake AR=$(tc-getAR)
-}
-
-src_install() {
- default
-
- keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
- keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
-}
diff --git a/app-arch/dpkg/dpkg-1.17.6.ebuild b/app-arch/dpkg/dpkg-1.17.6.ebuild
deleted file mode 100644
index 5eb0da34cc46..000000000000
--- a/app-arch/dpkg/dpkg-1.17.6.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.17.6.ebuild,v 1.3 2014/04/02 18:55:22 maekke Exp $
-
-EAPI=5
-inherit eutils multilib autotools toolchain-funcs
-
-DESCRIPTION="Package maintenance system for Debian"
-HOMEPAGE="http://packages.qa.debian.org/dpkg"
-SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 arm hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
-IUSE="+bzip2 dselect +lzma nls test unicode +update-alternatives +zlib"
-REQUIRED_USE="dselect? ( nls )"
-
-RDEPEND="
- >=dev-lang/perl-5.6.0
- dev-perl/TimeDate
- >=sys-libs/ncurses-5.2-r7
- lzma? ( app-arch/xz-utils )
- zlib? ( >=sys-libs/zlib-1.1.4 )
- bzip2? ( app-arch/bzip2 )
-"
-DEPEND="
- ${RDEPEND}
- app-arch/xz-utils
- sys-devel/flex
- virtual/pkgconfig
- nls? (
- app-text/po4a
- >=sys-devel/gettext-0.18.2
- )
- test? (
- dev-perl/DateTime-Format-DateParse
- dev-perl/IO-String
- dev-perl/Test-Pod
- )
-"
-
-DOCS=( ChangeLog THANKS TODO )
-
-src_prepare() {
- # do not expect Debian's gzip --rsyncable extension
- epatch "${FILESDIR}"/${PN}-1.17.0-gzip-rsyncable.patch
-
- epatch "${FILESDIR}"/${PN}-1.17.1-flags.patch
-
- # Force the use of the running bash for get-version (this file is never
- # installed, so no need to worry about hardcoding a temporary bash)
- sed -i -e '1c\#!'"${BASH}" get-version || die
-
- # this test depends on a Debian only gzip extension that adds --rsyncable
- # which will therefore always fail on Gentoo. (bug #310847).
- sed -i scripts/Makefile.am \
- -e '/850_Dpkg_Compression.t/d' \
- || die "sed failed"
-
- # test fails (bug #414095)
- sed -i utils/Makefile.am \
- -e '/^test_cases/d;/100_update_alternatives/d' || die
-
- use nls && strip-linguas -i po
-
- eautoreconf
-}
-
-src_configure() {
- tc-export CC
- econf \
- $(use_enable dselect) \
- $(use_enable nls) \
- $(use_enable unicode) \
- $(use_enable update-alternatives) \
- $(use_with bzip2 bz2) \
- $(use_with zlib) \
- $(use_with lzma liblzma) \
- --disable-compiler-warnings \
- --disable-silent-rules \
- --disable-start-stop-daemon \
- --localstatedir="${EPREFIX}"/var \
- --without-selinux
-}
-
-src_compile() {
- emake AR=$(tc-getAR)
-}
-
-src_install() {
- default
-
- keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
- keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
-}
diff --git a/app-arch/dpkg/dpkg-1.17.7.ebuild b/app-arch/dpkg/dpkg-1.17.7.ebuild
deleted file mode 100644
index e12679e1b5d5..000000000000
--- a/app-arch/dpkg/dpkg-1.17.7.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.17.7.ebuild,v 1.1 2014/04/22 15:08:55 jer Exp $
-
-EAPI=5
-inherit eutils multilib autotools toolchain-funcs
-
-DESCRIPTION="Package maintenance system for Debian"
-HOMEPAGE="http://packages.qa.debian.org/dpkg"
-SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
-IUSE="+bzip2 dselect +lzma nls test unicode +update-alternatives +zlib"
-REQUIRED_USE="dselect? ( nls )"
-
-RDEPEND="
- >=dev-lang/perl-5.6.0
- dev-perl/TimeDate
- >=sys-libs/ncurses-5.2-r7
- lzma? ( app-arch/xz-utils )
- zlib? ( >=sys-libs/zlib-1.1.4 )
- bzip2? ( app-arch/bzip2 )
-"
-DEPEND="
- ${RDEPEND}
- app-arch/xz-utils
- sys-devel/flex
- virtual/pkgconfig
- nls? (
- app-text/po4a
- >=sys-devel/gettext-0.18.2
- )
- test? (
- dev-perl/DateTime-Format-DateParse
- dev-perl/IO-String
- dev-perl/Test-Pod
- virtual/perl-Test-Harness
- )
-"
-
-DOCS=( ChangeLog THANKS TODO )
-
-src_prepare() {
- # do not expect Debian's gzip --rsyncable extension
- epatch "${FILESDIR}"/${PN}-1.17.0-gzip-rsyncable.patch
-
- epatch "${FILESDIR}"/${PN}-1.17.1-flags.patch
-
- # Force the use of the running bash for get-version (this file is never
- # installed, so no need to worry about hardcoding a temporary bash)
- sed -i -e '1c\#!'"${BASH}" get-version || die
-
- # this test depends on a Debian only gzip extension that adds --rsyncable
- # which will therefore always fail on Gentoo. (bug #310847).
- sed -i scripts/Makefile.am \
- -e '/850_Dpkg_Compression.t/d' \
- || die "sed failed"
-
- # test fails (bug #414095)
- sed -i utils/Makefile.am \
- -e '/^test_cases/d;/100_update_alternatives/d' || die
-
- use nls && strip-linguas -i po
-
- eautoreconf
-}
-
-src_configure() {
- tc-export CC
- econf \
- $(use_enable dselect) \
- $(use_enable nls) \
- $(use_enable unicode) \
- $(use_enable update-alternatives) \
- $(use_with bzip2 bz2) \
- $(use_with zlib) \
- $(use_with lzma liblzma) \
- --disable-compiler-warnings \
- --disable-silent-rules \
- --disable-start-stop-daemon \
- --localstatedir="${EPREFIX}"/var \
- --without-selinux
-}
-
-src_compile() {
- emake AR=$(tc-getAR)
-}
-
-src_install() {
- default
-
- keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
- keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
-}
diff --git a/app-arch/dpkg/dpkg-1.17.8.ebuild b/app-arch/dpkg/dpkg-1.17.8.ebuild
deleted file mode 100644
index c543e7f1b720..000000000000
--- a/app-arch/dpkg/dpkg-1.17.8.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.17.8.ebuild,v 1.5 2014/05/03 14:17:16 maekke Exp $
-
-EAPI=5
-inherit eutils multilib autotools toolchain-funcs
-
-DESCRIPTION="Package maintenance system for Debian"
-HOMEPAGE="http://packages.qa.debian.org/dpkg"
-SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
-IUSE="+bzip2 dselect +lzma nls test unicode +update-alternatives +zlib"
-REQUIRED_USE="dselect? ( nls )"
-
-RDEPEND="
- >=dev-lang/perl-5.6.0
- dev-perl/TimeDate
- >=sys-libs/ncurses-5.2-r7
- lzma? ( app-arch/xz-utils )
- zlib? ( >=sys-libs/zlib-1.1.4 )
- bzip2? ( app-arch/bzip2 )
-"
-DEPEND="
- ${RDEPEND}
- app-arch/xz-utils
- sys-devel/flex
- virtual/pkgconfig
- nls? (
- app-text/po4a
- >=sys-devel/gettext-0.18.2
- )
- test? (
- dev-perl/DateTime-Format-DateParse
- dev-perl/IO-String
- dev-perl/Test-Pod
- virtual/perl-Test-Harness
- )
-"
-
-DOCS=( ChangeLog THANKS TODO )
-
-src_prepare() {
- # do not expect Debian's gzip --rsyncable extension
- epatch "${FILESDIR}"/${PN}-1.17.0-gzip-rsyncable.patch
-
- epatch "${FILESDIR}"/${PN}-1.17.1-flags.patch
-
- # Force the use of the running bash for get-version (this file is never
- # installed, so no need to worry about hardcoding a temporary bash)
- sed -i -e '1c\#!'"${BASH}" get-version || die
-
- # this test depends on a Debian only gzip extension that adds --rsyncable
- # which will therefore always fail on Gentoo. (bug #310847).
- sed -i scripts/Makefile.am \
- -e '/850_Dpkg_Compression.t/d' \
- || die "sed failed"
-
- # test fails (bug #414095)
- sed -i utils/Makefile.am \
- -e '/^test_cases/d;/100_update_alternatives/d' || die
-
- use nls && strip-linguas -i po
-
- eautoreconf
-}
-
-src_configure() {
- tc-export CC
- econf \
- $(use_enable dselect) \
- $(use_enable nls) \
- $(use_enable unicode) \
- $(use_enable update-alternatives) \
- $(use_with bzip2 bz2) \
- $(use_with zlib) \
- $(use_with lzma liblzma) \
- --disable-compiler-warnings \
- --disable-silent-rules \
- --disable-start-stop-daemon \
- --localstatedir="${EPREFIX}"/var \
- --without-selinux
-}
-
-src_compile() {
- emake AR=$(tc-getAR)
-}
-
-src_install() {
- default
-
- keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
- keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
-}
diff --git a/app-arch/dpkg/files/dpkg-1.16.4.2-gzip-rsyncable.patch b/app-arch/dpkg/files/dpkg-1.16.4.2-gzip-rsyncable.patch
deleted file mode 100644
index 36610228c555..000000000000
--- a/app-arch/dpkg/files/dpkg-1.16.4.2-gzip-rsyncable.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/scripts/Dpkg/Compression.pm
-+++ b/scripts/Dpkg/Compression.pm
-@@ -52,7 +52,7 @@
- my $COMP = {
- "gzip" => {
- "file_ext" => "gz",
-- "comp_prog" => [ "gzip", "--no-name", "--rsyncable" ],
-+ "comp_prog" => [ "gzip", "--no-name"],
- "decomp_prog" => [ "gunzip" ],
- "default_level" => 9,
- },