summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-03-19 18:33:37 +0000
committerFabian Groffen <grobian@gentoo.org>2010-03-19 18:33:37 +0000
commitc6821d81f152968d505b564b7270c7948c8be286 (patch)
tree070a1288727318ab778726a9110dce7570173437
parentx86 stable wrt bug #310013 (diff)
downloadgentoo-2-c6821d81f152968d505b564b7270c7948c8be286.tar.gz
gentoo-2-c6821d81f152968d505b564b7270c7948c8be286.tar.bz2
gentoo-2-c6821d81f152968d505b564b7270c7948c8be286.zip
Fix compilation on older Mac OS X systems by disabling new locking methods that require features from Snow Leopard (10.6)
(Portage version: 2.2.00.15819-prefix/cvs/Darwin powerpc)
-rw-r--r--dev-db/sqlite/ChangeLog6
-rw-r--r--dev-db/sqlite/sqlite-3.6.23.ebuild12
2 files changed, 16 insertions, 2 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index 3c2c110cb81b..cc04b0bc9e8e 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/sqlite
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.331 2010/03/14 16:47:43 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.332 2010/03/19 18:33:37 grobian Exp $
+
+ 19 Mar 2010; Fabian Groffen <grobian@gentoo.org> sqlite-3.6.23.ebuild:
+ Fix compilation on older Mac OS X systems by disabling new locking methods
+ that require features from Snow Leopard (10.6)
14 Mar 2010; Raúl Porcel <armin76@gentoo.org> sqlite-3.6.21.ebuild,
sqlite-3.6.22-r2.ebuild:
diff --git a/dev-db/sqlite/sqlite-3.6.23.ebuild b/dev-db/sqlite/sqlite-3.6.23.ebuild
index be280b001b9e..c6e316b0d872 100644
--- a/dev-db/sqlite/sqlite-3.6.23.ebuild
+++ b/dev-db/sqlite/sqlite-3.6.23.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.6.23.ebuild,v 1.1 2010/03/13 14:23:15 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.6.23.ebuild,v 1.2 2010/03/19 18:33:37 grobian Exp $
EAPI="3"
@@ -95,6 +95,16 @@ src_configure() {
extensions_option="dynamic-extensions"
fi
+ # Starting from 3.6.23, SQLite has locking strategies that are specific to
+ # OSX. By default they are enabled, and use semantics that only make sense
+ # on OSX. However, they require gethostuuid() function for that, which is
+ # only available on OSX starting from 10.6 (Snow Leopard). For earlier
+ # versions of OSX we have to disable all this nifty locking options, as
+ # suggested by upstream.
+ if [[ ${CHOST} == *-darwin[56789] ]] ; then
+ append-cppflags -DSQLITE_ENABLE_LOCKING_STYLE=0
+ fi
+
# `configure` from amalgamation tarball doesn't support
# --with-readline-inc and --(enable|disable)-tcl options.
econf \