summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2006-10-10 18:48:34 +0000
committerBryan Østergaard <kloeri@gentoo.org>2006-10-10 18:48:34 +0000
commitd40f083b565c1b688919df8e29639ebc4fdb8cda (patch)
tree49dc07391ece7dc4fccb80a750effde6baffcd36
parentAdded ~ppc wrt bug 150688 (diff)
downloadgentoo-2-d40f083b565c1b688919df8e29639ebc4fdb8cda.tar.gz
gentoo-2-d40f083b565c1b688919df8e29639ebc4fdb8cda.tar.bz2
gentoo-2-d40f083b565c1b688919df8e29639ebc4fdb8cda.zip
Modular X + gcc-4.1 fixes.
(Portage version: 2.1.2_pre2-r6)
-rw-r--r--x11-plugins/asclock/ChangeLog10
-rw-r--r--x11-plugins/asclock/asclock-2.0.12-r1.ebuild62
-rw-r--r--x11-plugins/asclock/files/asclock-gcc41.patch44
-rw-r--r--x11-plugins/asclock/files/digest-asclock-2.0.122
-rw-r--r--x11-plugins/asclock/files/digest-asclock-2.0.12-r13
5 files changed, 119 insertions, 2 deletions
diff --git a/x11-plugins/asclock/ChangeLog b/x11-plugins/asclock/ChangeLog
index 0aeed532da66..1878afe4f753 100644
--- a/x11-plugins/asclock/ChangeLog
+++ b/x11-plugins/asclock/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/asclock
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/asclock/ChangeLog,v 1.12 2006/01/02 10:53:52 s4t4n Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/asclock/ChangeLog,v 1.13 2006/10/10 18:48:34 kloeri Exp $
+
+*asclock-2.0.12-r1 (10 Oct 2006)
+
+ 10 Oct 2006; Bryan Østergaard <kloeri@gentoo.org>
+ +files/asclock-gcc41.patch, +asclock-2.0.12-r1.ebuild:
+ Modular X + gcc-4.1 fixes.
02 Jan 2006; Michele Noberasco <s4t4n@gentoo.org> asclock-2.0.12.ebuild:
removed COPYING and INSTALL from dodoc.
diff --git a/x11-plugins/asclock/asclock-2.0.12-r1.ebuild b/x11-plugins/asclock/asclock-2.0.12-r1.ebuild
new file mode 100644
index 000000000000..839066d7eb01
--- /dev/null
+++ b/x11-plugins/asclock/asclock-2.0.12-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/asclock/asclock-2.0.12-r1.ebuild,v 1.1 2006/10/10 18:48:34 kloeri Exp $
+
+inherit eutils toolchain-funcs
+
+IUSE=""
+DESCRIPTION="Clock applet for AfterStep"
+SRC_URI="http://www.tigr.net/afterstep/download/asclock/${P}.tar.gz"
+HOMEPAGE="http://www.tigr.net/afterstep/list.pl"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~mips"
+
+DEPEND="x11-libs/libXpm"
+RDEPEND="${DEPEND}
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-gcc41.patch
+ ln -s themes/classic default_theme
+}
+
+src_compile() {
+ local x
+ for x in asclock parser symbols config
+ do
+ $(tc-getCC) \
+ ${CFLAGS} \
+ -I/usr/include \
+ -Dlinux -D__i386__ \
+ -D_POSIX_C_SOURCE=199309L \
+ -D_POSIX_SOURCE \
+ -D_XOPEN_SOURCE \
+ -D_BSD_SOURCE \
+ -D_SVID_SOURCE \
+ -DFUNCPROTO=15 \
+ -DNARROWPROTO \
+ -c -o ${x}.o ${x}.c || die "compile failed"
+ done
+ $(tc-getCC) \
+ ${CFLAGS} \
+ -o asclock \
+ asclock.o parser.o symbols.o config.o \
+ -L/usr/lib \
+ -L/usr/lib/X11 \
+ -lXpm -lXext -lX11 || die "compile asclock failed"
+}
+
+src_install() {
+ dobin asclock
+ local themesdir="/usr/share/${PN}/themes"
+ insinto ${themesdir}
+ doins -r themes/*
+ dodoc README README.THEMES TODO
+ cd ${D}/${themesdir}
+ rm -f Freeamp/Makefile{,.*}
+ ln -s classic default_theme
+}
diff --git a/x11-plugins/asclock/files/asclock-gcc41.patch b/x11-plugins/asclock/files/asclock-gcc41.patch
new file mode 100644
index 000000000000..5a5291219ee5
--- /dev/null
+++ b/x11-plugins/asclock/files/asclock-gcc41.patch
@@ -0,0 +1,44 @@
+diff -ur asclock-2.0.12-orig/asclock.h asclock-2.0.12/asclock.h
+--- asclock-2.0.12-orig/asclock.h 2006-06-03 15:31:58.000000000 -0400
++++ asclock-2.0.12/asclock.h 2006-06-03 15:35:51.000000000 -0400
+@@ -38,15 +38,15 @@
+ #define INT_TYPE 0;
+
+ /* the xpm data */
+-extern char *clock_xpm[];
+-extern char *month_xpm[];
+-extern char *weekday_xpm[];
+-extern char *led_xpm[];
+-extern char *date_xpm[];
+-extern char *hour_xpm[];
+-extern char *minute_xpm[];
+-extern char *second_xpm[];
+-extern char *beats_xpm[];
++static char *clock_xpm[];
++static char *month_xpm[];
++static char *weekday_xpm[];
++static char *led_xpm[];
++static char *date_xpm[];
++static char *hour_xpm[];
++static char *minute_xpm[];
++static char *second_xpm[];
++static char *beats_xpm[];
+
+ /* the filenames */
+ extern char clock_xpm_fn[MAX_PATH_LEN];
+diff -ur asclock-2.0.12-orig/themes/classic/beats.xpm asclock-2.0.12/themes/classic/beats.xpm
+--- asclock-2.0.12-orig/themes/classic/beats.xpm 2006-06-03 15:31:58.000000000 -0400
++++ asclock-2.0.12/themes/classic/beats.xpm 2006-06-03 15:37:04.000000000 -0400
+@@ -1 +1 @@
+-char *beats_xpm[] = { NULL };
++static char *beats_xpm[] = { NULL };
+diff -ur asclock-2.0.12-orig/themes/classic/led.xpm asclock-2.0.12/themes/classic/led.xpm
+--- asclock-2.0.12-orig/themes/classic/led.xpm 2006-06-03 15:31:58.000000000 -0400
++++ asclock-2.0.12/themes/classic/led.xpm 2006-06-03 15:36:53.000000000 -0400
+@@ -1,5 +1,5 @@
+ /* XPM */
+-char * led_xpm[] = {
++static char * led_xpm[] = {
+ "135 11 3 1",
+ " c #282828",
+ "O c #00df00",
diff --git a/x11-plugins/asclock/files/digest-asclock-2.0.12 b/x11-plugins/asclock/files/digest-asclock-2.0.12
index e3c7be5c5b9c..23ba1be22b1d 100644
--- a/x11-plugins/asclock/files/digest-asclock-2.0.12
+++ b/x11-plugins/asclock/files/digest-asclock-2.0.12
@@ -1 +1,3 @@
MD5 99cb6491358bb0044e9b75b2e06b043b asclock-2.0.12.tar.gz 111858
+RMD160 c3673329c5bcf5be097abb770e861502e20f77ca asclock-2.0.12.tar.gz 111858
+SHA256 70df9bd991bc707c0fdf76ea1acbeff5924e9ae0b0704feb46afa591030704e6 asclock-2.0.12.tar.gz 111858
diff --git a/x11-plugins/asclock/files/digest-asclock-2.0.12-r1 b/x11-plugins/asclock/files/digest-asclock-2.0.12-r1
new file mode 100644
index 000000000000..23ba1be22b1d
--- /dev/null
+++ b/x11-plugins/asclock/files/digest-asclock-2.0.12-r1
@@ -0,0 +1,3 @@
+MD5 99cb6491358bb0044e9b75b2e06b043b asclock-2.0.12.tar.gz 111858
+RMD160 c3673329c5bcf5be097abb770e861502e20f77ca asclock-2.0.12.tar.gz 111858
+SHA256 70df9bd991bc707c0fdf76ea1acbeff5924e9ae0b0704feb46afa591030704e6 asclock-2.0.12.tar.gz 111858