summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-15 14:41:39 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-15 14:41:39 +0000
commitd4f88f49e4c100a4b483487b4e284e8dd9f620b5 (patch)
tree7e1cb61e878912b8dc303f7e68594a6c863f01ee
parentold (diff)
downloadgentoo-2-d4f88f49e4c100a4b483487b4e284e8dd9f620b5.tar.gz
gentoo-2-d4f88f49e4c100a4b483487b4e284e8dd9f620b5.tar.bz2
gentoo-2-d4f88f49e4c100a4b483487b4e284e8dd9f620b5.zip
built_with_use, old
(Portage version: 2.2_rc38/cvs/Linux x86_64)
-rw-r--r--media-sound/qsynth/qsynth-0.3.2.ebuild54
-rw-r--r--media-sound/qsynth/qsynth-0.3.3-r1.ebuild58
-rw-r--r--media-sound/qsynth/qsynth-0.3.3-r2.ebuild61
-rw-r--r--media-sound/qsynth/qsynth-0.3.3.ebuild83
4 files changed, 12 insertions, 244 deletions
diff --git a/media-sound/qsynth/qsynth-0.3.2.ebuild b/media-sound/qsynth/qsynth-0.3.2.ebuild
index 7ab5f09cf2a4..c360079be5d4 100644
--- a/media-sound/qsynth/qsynth-0.3.2.ebuild
+++ b/media-sound/qsynth/qsynth-0.3.2.ebuild
@@ -1,53 +1,25 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qsynth/qsynth-0.3.2.ebuild,v 1.6 2008/07/27 01:10:38 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qsynth/qsynth-0.3.2.ebuild,v 1.7 2009/08/15 14:41:39 ssuominen Exp $
-EAPI=1
-
-inherit qt4 eutils flag-o-matic
+EAPI=2
+inherit eutils flag-o-matic qt4
DESCRIPTION="A Qt application to control FluidSynth"
HOMEPAGE="http://qsynth.sourceforge.net/"
SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
-IUSE="debug jack alsa"
KEYWORDS="amd64 ppc sparc x86"
+IUSE="alsa debug jack"
-DEPEND="
- || ( (
- x11-libs/qt-core:4
- x11-libs/qt-gui:4
- ) =x11-libs/qt-4.3*:4 )
- >=media-sound/fluidsynth-1.0.7a"
-
-pkg_setup() {
- if use jack; then
- if ! built_with_use media-sound/fluidsynth jack; then
- eerror "To use Qsynth with JACK, you need to build media-sound/fluidsynth"
- eerror "with the jack USE flag enabled."
- die "Missing jack USE flag on media-sound/fluidsynth"
- fi
- einfo "Enabling default JACK output."
- elif use alsa; then
- if ! built_with_use media-sound/fluidsynth alsa; then
- eerror "To use Qsynth with ALSA, you need to build media-sound/fluidsynth"
- eerror "with the alsa USE flag enabled."
- die "Missing alsa USE flag on media-sound/fluidsynth"
- fi
- einfo "Enabling non-default ALSA output."
- else
- if ! built_with_use media-sound/fluidsynth oss; then
- eerror "If you don't want to use either JACK or ALSA on Qsynth"
- eerror "you need to enable the oss USE flag on media-sound/fluidsynth"
- die "Missing oss USE flag on media-sound/fluidsynth"
- fi
- einfo "Enabling non-default OSS output."
- fi
-}
+RDEPEND="x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ >=media-sound/fluidsynth-1.0.7a[alsa?,jack?]"
+DEPEND="${RDEPEND}"
-src_compile() {
+src_configure() {
# Stupidly, qsynth's configure does *not* use pkg-config to
# discover the presence of Qt4, but uses fixed paths; as they
# don't really work that well for our case, let's just use this
@@ -57,9 +29,7 @@ src_compile() {
append-ldflags -L/usr/$(get_libdir)/qt4
econf \
- $(use_enable debug) \
- || die "econf failed"
- emake || die "emake failed"
+ $(use_enable debug)
}
src_install () {
diff --git a/media-sound/qsynth/qsynth-0.3.3-r1.ebuild b/media-sound/qsynth/qsynth-0.3.3-r1.ebuild
deleted file mode 100644
index ac8f88dce407..000000000000
--- a/media-sound/qsynth/qsynth-0.3.3-r1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qsynth/qsynth-0.3.3-r1.ebuild,v 1.1 2008/10/10 12:29:34 flameeyes Exp $
-
-EAPI=2
-
-inherit qt4 eutils flag-o-matic
-
-DESCRIPTION="A Qt application to control FluidSynth"
-HOMEPAGE="http://qsynth.sourceforge.net/"
-SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
-LICENSE="GPL-2"
-
-SLOT="0"
-IUSE="debug jack alsa"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-
-DEPEND="
- || ( (
- x11-libs/qt-core:4
- x11-libs/qt-gui:4
- ) =x11-libs/qt-4.3*:4 )
- >=media-sound/fluidsynth-1.0.7a[jack?,alsa?]
- !jack? ( !alsa? ( >=media-sound/fluidsynth-1.0.7a[oss] ) )"
-
-src_configure() {
- # Stupidly, qsynth's configure does *not* use pkg-config to
- # discover the presence of Qt4, but uses fixed paths; as they
- # don't really work that well for our case, let's just use this
- # nasty hack and be done with it. *NOTE*: this hinders
- # cross-compile.
- append-flags -I/usr/include/qt4
- append-ldflags -L/usr/$(get_libdir)/qt4
-
- econf \
- $(use_enable debug) \
- || die "econf failed"
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog README TODO
-
- # The desktop file is invalid, and we also change the command
- # depending on useflags
- rm -rf "${D}/usr/share/applications/qsynth.desktop"
-
- local cmd
- if use jack; then
- cmd="qsynth"
- elif use alsa; then
- cmd="qsynth -a alsa"
- else
- cmd="qsynth -a oss"
- fi
-
- make_desktop_entry "${cmd}" Qsynth qsynth
-}
diff --git a/media-sound/qsynth/qsynth-0.3.3-r2.ebuild b/media-sound/qsynth/qsynth-0.3.3-r2.ebuild
deleted file mode 100644
index 6f829df44865..000000000000
--- a/media-sound/qsynth/qsynth-0.3.3-r2.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qsynth/qsynth-0.3.3-r2.ebuild,v 1.1 2009/04/15 20:02:37 flameeyes Exp $
-
-EAPI=2
-
-inherit qt4 eutils flag-o-matic
-
-DESCRIPTION="A Qt application to control FluidSynth"
-HOMEPAGE="http://qsynth.sourceforge.net/"
-SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
-LICENSE="GPL-2"
-
-SLOT="0"
-IUSE="debug jack alsa pulseaudio"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-
-DEPEND="
- || ( (
- x11-libs/qt-core:4
- x11-libs/qt-gui:4
- ) =x11-libs/qt-4.3*:4 )
- >=media-sound/fluidsynth-1.0.7a[jack?,alsa?,pulseaudio?]
- !pulseaudio? ( !jack? ( !alsa? ( >=media-sound/fluidsynth-1.0.7a[oss] ) ) )"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- # Stupidly, qsynth's configure does *not* use pkg-config to
- # discover the presence of Qt4, but uses fixed paths; as they
- # don't really work that well for our case, let's just use this
- # nasty hack and be done with it. *NOTE*: this hinders
- # cross-compile.
- append-flags -I/usr/include/qt4
- append-ldflags -L/usr/$(get_libdir)/qt4
-
- econf \
- $(use_enable debug) \
- || die "econf failed"
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog README TODO
-
- # The desktop file is invalid, and we also change the command
- # depending on useflags
- rm -rf "${D}/usr/share/applications/qsynth.desktop"
-
- local cmd
- if use jack; then
- cmd="qsynth"
- elif use pulseaudio; then
- cmd="qsynth -a pulseaudio"
- elif use alsa; then
- cmd="qsynth -a alsa"
- else
- cmd="qsynth -a oss"
- fi
-
- make_desktop_entry "${cmd}" Qsynth qsynth
-}
diff --git a/media-sound/qsynth/qsynth-0.3.3.ebuild b/media-sound/qsynth/qsynth-0.3.3.ebuild
deleted file mode 100644
index dcc22f4223cf..000000000000
--- a/media-sound/qsynth/qsynth-0.3.3.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qsynth/qsynth-0.3.3.ebuild,v 1.2 2008/07/27 01:10:38 carlo Exp $
-
-EAPI=1
-
-inherit qt4 eutils flag-o-matic
-
-DESCRIPTION="A Qt application to control FluidSynth"
-HOMEPAGE="http://qsynth.sourceforge.net/"
-SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
-LICENSE="GPL-2"
-
-SLOT="0"
-IUSE="debug jack alsa"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-
-DEPEND="
- || ( (
- x11-libs/qt-core:4
- x11-libs/qt-gui:4
- ) =x11-libs/qt-4.3*:4 )
- >=media-sound/fluidsynth-1.0.7a"
-
-pkg_setup() {
- if use jack; then
- if ! built_with_use media-sound/fluidsynth jack; then
- eerror "To use Qsynth with JACK, you need to build media-sound/fluidsynth"
- eerror "with the jack USE flag enabled."
- die "Missing jack USE flag on media-sound/fluidsynth"
- fi
- einfo "Enabling default JACK output."
- elif use alsa; then
- if ! built_with_use media-sound/fluidsynth alsa; then
- eerror "To use Qsynth with ALSA, you need to build media-sound/fluidsynth"
- eerror "with the alsa USE flag enabled."
- die "Missing alsa USE flag on media-sound/fluidsynth"
- fi
- einfo "Enabling non-default ALSA output."
- else
- if ! built_with_use media-sound/fluidsynth oss; then
- eerror "If you don't want to use either JACK or ALSA on Qsynth"
- eerror "you need to enable the oss USE flag on media-sound/fluidsynth"
- die "Missing oss USE flag on media-sound/fluidsynth"
- fi
- einfo "Enabling non-default OSS output."
- fi
-}
-
-src_compile() {
- # Stupidly, qsynth's configure does *not* use pkg-config to
- # discover the presence of Qt4, but uses fixed paths; as they
- # don't really work that well for our case, let's just use this
- # nasty hack and be done with it. *NOTE*: this hinders
- # cross-compile.
- append-flags -I/usr/include/qt4
- append-ldflags -L/usr/$(get_libdir)/qt4
-
- econf \
- $(use_enable debug) \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog README TODO
-
- # The desktop file is invalid, and we also change the command
- # depending on useflags
- rm -rf "${D}/usr/share/applications/qsynth.desktop"
-
- local cmd
- if use jack; then
- cmd="qsynth"
- elif use alsa; then
- cmd="qsynth -a alsa"
- else
- cmd="qsynth -a oss"
- fi
-
- make_desktop_entry "${cmd}" Qsynth qsynth
-}